summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2022-03-09 08:17:31 +0100
committerAlfredo Tupone <tupone@gentoo.org>2022-03-09 08:17:31 +0100
commit4cea1729a96a2060b769181a15ecf731f1b4c36e (patch)
treedd693c1844961682b584376e0a83643d7637ae52 /games-action/bzflag
parentnet-fs/s3fs: Stabilize 1.89 x86, #828367 (diff)
downloadgentoo-4cea1729a96a2060b769181a15ecf731f1b4c36e.tar.gz
gentoo-4cea1729a96a2060b769181a15ecf731f1b4c36e.tar.bz2
gentoo-4cea1729a96a2060b769181a15ecf731f1b4c36e.zip
games-action/bzflag: version bump to 2.4.24
Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Alfredo Tupone <tupone@gentoo.org>
Diffstat (limited to 'games-action/bzflag')
-rw-r--r--games-action/bzflag/Manifest1
-rw-r--r--games-action/bzflag/bzflag-2.4.24.ebuild73
2 files changed, 74 insertions, 0 deletions
diff --git a/games-action/bzflag/Manifest b/games-action/bzflag/Manifest
index 376b5c676891..6b5f7949ca64 100644
--- a/games-action/bzflag/Manifest
+++ b/games-action/bzflag/Manifest
@@ -1 +1,2 @@
DIST bzflag-2.4.22.tar.bz2 14169079 BLAKE2B e3020d161326215b721e142198295314fce60212322d787389ee47519a8f20a64065ec2744799b8dc282fb343af1b2c5ae54bdab93827a5716ad5ac2363f8978 SHA512 c78ad0e9e861d0c922ef73dd1e040d998836efaab3a48d5a3cd8392835ce37392b1b9438aed7483ea48c6bce672bb937aeba40553553dce0c0fd3cce38bf10cf
+DIST bzflag-2.4.24.tar.bz2 14094506 BLAKE2B 4b14f00ce071d69b75091d0492ce26862e1f01356c61048ba46381f60f091b5dbf144d979e1f07bc87f4bd1159df3fc48c739fa370c92b7cf630308c8478ce24 SHA512 2e6c620e39e65058397515f309b58b0338ee972a63b241546f9947889a43b6274ce313fe5551517d1a099963d0ce877c67e29dfb70d424626926e77b9562c3f7
diff --git a/games-action/bzflag/bzflag-2.4.24.ebuild b/games-action/bzflag/bzflag-2.4.24.ebuild
new file mode 100644
index 000000000000..704daa557b95
--- /dev/null
+++ b/games-action/bzflag/bzflag-2.4.24.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools desktop
+
+DESCRIPTION="3D tank combat simulator game"
+HOMEPAGE="https://www.bzflag.org/"
+SRC_URI="https://download.bzflag.org/bzflag/source/${PV}/${P}.tar.bz2"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="dedicated upnp"
+
+RDEPEND="
+ net-dns/c-ares
+ >=net-misc/curl-7.15.0
+ sys-libs/ncurses:0
+ sys-libs/zlib
+ !dedicated? (
+ media-libs/libsdl2[joystick,sound,video]
+ media-libs/glew:=
+ virtual/glu
+ virtual/opengl )
+ upnp? ( net-libs/miniupnpc )
+"
+DEPEND="
+ ${RDEPEND}
+ virtual/pkgconfig
+"
+PATCHES=(
+ "${FILESDIR}"/${PN}-2.4.12-configure.patch
+ "${FILESDIR}"/${PN}-2.4.12-tinfo.patch
+ "${FILESDIR}"/${PN}-2.4.12-sdl2-cppflags.patch
+)
+
+DOCS=( AUTHORS ChangeLog DEVINFO PORTING README README.Linux )
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ local myconf=(
+ $(use_enable upnp UPnP)
+ --libdir="${EPREFIX}"/usr/$(get_libdir)/${PN}
+ )
+
+ if use dedicated ; then
+ ewarn
+ ewarn "You are building a server-only copy of BZFlag"
+ ewarn
+ myconf+=( --disable-client --without-SDL )
+ else
+ myconf=( --with-SDL=2 )
+ fi
+
+ econf "${myconf[@]}"
+}
+
+src_install() {
+ default
+
+ if ! use dedicated ; then
+ newicon data/bzflag-48x48.png ${PN}.png
+ make_desktop_entry ${PN} "BZFlag"
+ fi
+
+ find "${ED}" -name '*.la' -delete || die
+}