summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAustin English <wizardedit@gentoo.org>2017-01-24 16:41:04 -0600
committerAustin English <wizardedit@gentoo.org>2017-01-24 17:39:16 -0600
commitb5d67b8846064c3a26d9e58a6cd4d921335a6968 (patch)
tree66fba6c53f4e0912afb4b1be3f89e9ceaf2571c7 /games-action/deathchase3d
parentgames-action/chromium-bsu: remove deprecated games eclass (diff)
downloadgentoo-b5d67b8846064c3a26d9e58a6cd4d921335a6968.tar.gz
gentoo-b5d67b8846064c3a26d9e58a6cd4d921335a6968.tar.bz2
gentoo-b5d67b8846064c3a26d9e58a6cd4d921335a6968.zip
games-action/deathchase3d: remove deprecated games eclass
Also update to EAPI 6 Gentoo-Bug: https://bugs.gentoo.org/574082 Package-Manager: Portage-2.3.2, Repoman-2.3.1
Diffstat (limited to 'games-action/deathchase3d')
-rw-r--r--games-action/deathchase3d/deathchase3d-0.9-r1.ebuild27
-rw-r--r--games-action/deathchase3d/files/deathchase3d-0.9-underlink.patch4
2 files changed, 29 insertions, 2 deletions
diff --git a/games-action/deathchase3d/deathchase3d-0.9-r1.ebuild b/games-action/deathchase3d/deathchase3d-0.9-r1.ebuild
new file mode 100644
index 000000000000..562897841eb5
--- /dev/null
+++ b/games-action/deathchase3d/deathchase3d-0.9-r1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+inherit eutils
+
+DESCRIPTION="A remake of the Sinclair Spectrum game of the same name"
+HOMEPAGE="http://www.autismuk.freeserve.co.uk/"
+SRC_URI="http://www.autismuk.freeserve.co.uk/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+DEPEND="media-libs/libsdl[video]"
+RDEPEND=${DEPEND}
+
+PATCHES=(
+ "${FILESDIR}/${P}-underlink.patch"
+)
+
+src_install() {
+ dobin "${PN}/${PN}"
+ dodoc README ${PN}/docs/en/index.html
+}
diff --git a/games-action/deathchase3d/files/deathchase3d-0.9-underlink.patch b/games-action/deathchase3d/files/deathchase3d-0.9-underlink.patch
index 79d1f69c7525..ac20e1ff3800 100644
--- a/games-action/deathchase3d/files/deathchase3d-0.9-underlink.patch
+++ b/games-action/deathchase3d/files/deathchase3d-0.9-underlink.patch
@@ -1,5 +1,5 @@
---- deathchase3d/Makefile.in.old 2011-06-13 09:22:44.140587725 +0200
-+++ deathchase3d/Makefile.in 2011-06-13 09:22:49.932942379 +0200
+--- a/deathchase3d/Makefile.in 2011-06-13 09:22:44.140587725 +0200
++++ b/deathchase3d/Makefile.in 2011-06-13 09:22:49.932942379 +0200
@@ -248,7 +248,7 @@
bin_PROGRAMS = deathchase3d