summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-action/descent2-data
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-action/descent2-data')
-rw-r--r--games-action/descent2-data/descent2-data-1.0.ebuild99
-rw-r--r--games-action/descent2-data/metadata.xml5
2 files changed, 104 insertions, 0 deletions
diff --git a/games-action/descent2-data/descent2-data-1.0.ebuild b/games-action/descent2-data/descent2-data-1.0.ebuild
new file mode 100644
index 000000000000..d75199b3fdf2
--- /dev/null
+++ b/games-action/descent2-data/descent2-data-1.0.ebuild
@@ -0,0 +1,99 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils cdrom games
+
+MY_PV=${PV/./}
+SOW="descent2.sow"
+
+DESCRIPTION="Data files for Descent 2"
+HOMEPAGE="http://www.interplay.com/games/product.asp?GameID=109"
+SRC_URI=""
+# Don't have a method of applying the ver 1.2 patch in Linux
+# http://www.interplay.com/support/product.asp?GameID=109
+# mirror://3dgamers/descent2/d2ptch${MY_PV}.exe
+
+# See readme.txt
+LICENSE="${PN}"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+IUSE="videos"
+
+# d2x-0.2.5-r2 may include the CD data itself.
+# d2x-0.2.5-r3 does not include the CD data.
+# d2x-rebirth is favoured because it is stable.
+#RDEPEND="|| (
+# games-action/d2x-rebirth
+# >=games-action/d2x-0.2.5-r3 )"
+RDEPEND="!<games-action/d2x-0.2.5-r3"
+DEPEND="app-arch/unarj"
+
+S=${WORKDIR}
+dir=${GAMES_DATADIR}/d2x
+
+pkg_setup() {
+ games_pkg_setup
+
+ local m f need_cd="n"
+
+ # Could have the ${SOW} file in ${DISTDIR}
+ if [[ -e "${DISTDIR}/${SOW}" ]] ; then
+ einfo "Using ${SOW} from ${DISTDIR}"
+ # Check that the movies are available in ${DISTDIR} if needed
+ if use videos ; then
+ for m in {intro,other,robots}-{h,l}.mvl ; do
+ [[ -e "${DISTDIR}/${m}" ]] || need_cd="y"
+ done
+ fi
+ else
+ need_cd="y"
+ fi
+
+ if [[ "${need_cd}" == "y" ]] ; then
+ # The Descent 2 CD is needed
+ cdrom_get_cds "d2data/${SOW}"
+ fi
+}
+
+src_unpack() {
+ local m f="${DISTDIR}/${SOW}"
+
+ [[ -e "${f}" ]] || f="${CDROM_ROOT}/d2data/${SOW}"
+ # Extract level data
+ unarj e "${f}" || die
+
+ if use videos ; then
+ # Include both high and low resolution movie files
+ for m in {intro,other,robots}-{h,l}.mvl ; do
+ f="${DISTDIR}/${m}"
+ [[ -e "${f}" ]] || f="${CDROM_ROOT}/d2data/${m}"
+ einfo "Copying ${m}"
+ cp -f "${f}" . || die
+ done
+ fi
+
+ rm -f endnote.txt
+ mkdir doc
+ mv -f *.txt doc
+
+ # Remove files not needed by any Linux native client
+ rm -f *.{bat,dll,exe,ini,lst}
+}
+
+src_install() {
+ insinto "${dir}"
+ doins *
+
+ dodoc doc/*
+
+ prepgamesdirs
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+
+ elog "A client is needed to run the game, e.g. games-action/d2x-rebirth."
+ echo
+}
diff --git a/games-action/descent2-data/metadata.xml b/games-action/descent2-data/metadata.xml
new file mode 100644
index 000000000000..d3c2cc926f0b
--- /dev/null
+++ b/games-action/descent2-data/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>games</herd>
+</pkgmetadata>