summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2022-02-11 16:54:41 -0500
committerIonen Wolkens <ionen@gentoo.org>2022-02-11 18:13:57 -0500
commitba65a523a982f51e0037f74e3ad36c6da3f58ed9 (patch)
treed16596d9a71ce67e433c098d6bbef8a9ebeb2677 /games-action/dxx-rebirth
parentgames-fps/doomsday: enable py3.10 (diff)
downloadgentoo-ba65a523a982f51e0037f74e3ad36c6da3f58ed9.tar.gz
gentoo-ba65a523a982f51e0037f74e3ad36c6da3f58ed9.tar.bz2
gentoo-ba65a523a982f51e0037f74e3ad36c6da3f58ed9.zip
games-action/dxx-rebirth: enable py3.10
Also add PYTHON_DEPS for completeness, although this is technically all already handled by scons-utils (imagine python-any-r1 was added because dxx-rebirth has its own python scripts too, but doing so means should add python deps normally). Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'games-action/dxx-rebirth')
-rw-r--r--games-action/dxx-rebirth/dxx-rebirth-0.61.0_pre20210623.ebuild8
-rw-r--r--games-action/dxx-rebirth/dxx-rebirth-9999.ebuild8
2 files changed, 10 insertions, 6 deletions
diff --git a/games-action/dxx-rebirth/dxx-rebirth-0.61.0_pre20210623.ebuild b/games-action/dxx-rebirth/dxx-rebirth-0.61.0_pre20210623.ebuild
index b941cf320c02..90a8b6d8c8ef 100644
--- a/games-action/dxx-rebirth/dxx-rebirth-0.61.0_pre20210623.ebuild
+++ b/games-action/dxx-rebirth/dxx-rebirth-0.61.0_pre20210623.ebuild
@@ -1,9 +1,9 @@
-# Copyright 2017-2021 Gentoo Authors
+# Copyright 2017-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python3_{7,8,9} )
+PYTHON_COMPAT=( python3_{8..10} )
inherit desktop python-any-r1 scons-utils toolchain-funcs xdg
@@ -151,7 +151,9 @@ REQUIRED_USE='
sdl2? ( opengl )
'
-BDEPEND="virtual/pkgconfig"
+BDEPEND="
+ ${PYTHON_DEPS}
+ virtual/pkgconfig"
# As of this writing, IUSE_RUNTIME is a GLEP, but not an implemented
# feature. This variable is stored here to be ready to activate when
diff --git a/games-action/dxx-rebirth/dxx-rebirth-9999.ebuild b/games-action/dxx-rebirth/dxx-rebirth-9999.ebuild
index 8b70e138369e..ed7efde84b19 100644
--- a/games-action/dxx-rebirth/dxx-rebirth-9999.ebuild
+++ b/games-action/dxx-rebirth/dxx-rebirth-9999.ebuild
@@ -1,9 +1,9 @@
-# Copyright 2017-2021 Gentoo Authors
+# Copyright 2017-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python3_{7,8,9} )
+PYTHON_COMPAT=( python3_{8..10} )
inherit desktop python-any-r1 scons-utils toolchain-funcs xdg
@@ -153,7 +153,9 @@ REQUIRED_USE='
sdl2? ( opengl )
'
-BDEPEND="virtual/pkgconfig"
+BDEPEND="
+ ${PYTHON_DEPS}
+ virtual/pkgconfig"
# As of this writing, IUSE_RUNTIME is a GLEP, but not an implemented
# feature. This variable is stored here to be ready to activate when