summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Sokolov <sokolov@google.com>2020-12-15 16:38:16 +0100
committerDavid Seifert <soap@gentoo.org>2020-12-15 16:38:16 +0100
commita0ebf8768a1b70210a9d17909248c93a0d957fd3 (patch)
treee7a8355465bf6211b49bcad6ab45fc08fb69d7db /games-action/formido
parentmedia-sound/scream: new ebuild (diff)
downloadgentoo-a0ebf8768a1b70210a9d17909248c93a0d957fd3.tar.gz
gentoo-a0ebf8768a1b70210a9d17909248c93a0d957fd3.tar.bz2
gentoo-a0ebf8768a1b70210a9d17909248c93a0d957fd3.zip
games-action/formido: fix build, bump EAPI
Closes: https://bugs.gentoo.org/710812 Package-Manager: Portage-3.0.9, Repoman-3.0.2 Signed-off-by: Alexey Sokolov <alexey+gentoo@asokolov.org> Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'games-action/formido')
-rw-r--r--games-action/formido/formido-1.0.1-r2.ebuild51
1 files changed, 51 insertions, 0 deletions
diff --git a/games-action/formido/formido-1.0.1-r2.ebuild b/games-action/formido/formido-1.0.1-r2.ebuild
new file mode 100644
index 000000000000..053a48c66e0f
--- /dev/null
+++ b/games-action/formido/formido-1.0.1-r2.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit desktop toolchain-funcs
+
+DESCRIPTION="A shooting game in the spirit of Phobia games"
+HOMEPAGE="http://www.mhgames.org/oldies/formido/"
+SRC_URI="http://noe.falzon.free.fr/prog/${P}.tar.gz
+ http://koti.mbnet.fi/lsoft/formido/formido-music.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT=0
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="media-libs/libsdl[sound,video]
+ media-libs/sdl-image
+ media-libs/sdl-mixer"
+RDEPEND=${DEPEND}
+
+src_unpack() {
+ unpack ${P}.tar.gz
+ cd "${S}"/data || die
+ unpack ${PN}-music.tar.bz2
+}
+
+src_prepare() {
+ default
+
+ sed -i \
+ -e '/^FLAGS=/s:$: $(CXXFLAGS):' \
+ Makefile || die
+}
+
+src_compile() {
+ emake CC="$(tc-getCXX)" \
+ CXXFLAGS="${CXXFLAGS}" \
+ LINKFLAGS="${LDFLAGS}" \
+ DATDIR="${EPREFIX}/usr/share/formido/data" \
+ DEFCONFIGDIR="${EPREFIX}/usr/share/formido"
+}
+
+src_install() {
+ dobin ${PN}
+ insinto /usr/share/${PN}
+ doins -r ${PN}.cfg data
+ newicon data/icon.dat ${PN}.bmp
+ make_desktop_entry ${PN} Formido /usr/share/pixmaps/${PN}.bmp
+ dodoc README README-1.0.1
+}