summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Sokolov <sokolov@google.com>2020-09-19 00:59:18 +0100
committerConrad Kostecki <conikost@gentoo.org>2020-09-20 17:30:51 +0200
commit48eaec8d39c191ef1c59ac457f882a6d61ad15c4 (patch)
treed0d58d8da75f40fcfb3eefe246eed5767c9b85dc /games-action/garden
parentdev-lang/spidermonkey: drop llvm_pkg_setup call (diff)
downloadgentoo-48eaec8d39c191ef1c59ac457f882a6d61ad15c4.tar.gz
gentoo-48eaec8d39c191ef1c59ac457f882a6d61ad15c4.tar.bz2
gentoo-48eaec8d39c191ef1c59ac457f882a6d61ad15c4.zip
games-action/garden: fix build with gcc 10
Closes: https://github.com/gentoo/gentoo/pull/17596 Closes: https://bugs.gentoo.org/707460 Package-Manager: Portage-3.0.4, Repoman-3.0.1 Signed-off-by: Alexey Sokolov <alexey+gentoo@asokolov.org> Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'games-action/garden')
-rw-r--r--games-action/garden/files/garden-1.0.9-fnocommon.patch11
-rw-r--r--games-action/garden/garden-1.0.9-r2.ebuild48
2 files changed, 59 insertions, 0 deletions
diff --git a/games-action/garden/files/garden-1.0.9-fnocommon.patch b/games-action/garden/files/garden-1.0.9-fnocommon.patch
new file mode 100644
index 000000000000..59d011f5f402
--- /dev/null
+++ b/games-action/garden/files/garden-1.0.9-fnocommon.patch
@@ -0,0 +1,11 @@
+--- a/src/main.c 2020-09-18 22:43:49.545959883 -0000
++++ b/src/main.c 2020-09-18 22:43:40.465778941 -0000
+@@ -55,7 +55,7 @@ struct enemystruct enemy [NO_ENEMIES];
+ struct ebulletstruct ebullet [NO_EBULLETS];
+ struct pbulletstruct pbullet [NO_PBULLETS];
+ struct arenastruct arena;
+-struct eclassstruct eclass [NO_ENEMY_TYPES];
++extern struct eclassstruct eclass [NO_ENEMY_TYPES];
+ struct cloudstruct cloud [NO_CLOUDS];
+ struct bossstruct boss;
+
diff --git a/games-action/garden/garden-1.0.9-r2.ebuild b/games-action/garden/garden-1.0.9-r2.ebuild
new file mode 100644
index 000000000000..5200fa04163f
--- /dev/null
+++ b/games-action/garden/garden-1.0.9-r2.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools desktop flag-o-matic xdg-utils
+
+DESCRIPTION="Multiplatform vertical shoot-em-up with non-traditional elements"
+HOMEPAGE="http://garden.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="<media-libs/allegro-5"
+RDEPEND="${DEPEND}"
+
+PATCHES=(
+ "${FILESDIR}/${P}-dash.patch"
+ "${FILESDIR}/${P}-resources.patch"
+ "${FILESDIR}/${P}-fnocommon.patch"
+)
+
+src_prepare() {
+ default
+
+ # build with gcc52
+ sed -i \
+ -e 's/inline/extern inline/' \
+ src/stuff.h || die
+ eautoreconf
+ append-cflags -std=gnu89 # build with gcc5 (bug #572672)
+}
+
+src_install() {
+ default
+ doicon -s scalable resources/garden.svg
+ make_desktop_entry garden "Garden of coloured lights"
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}