summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2020-11-21 21:37:55 +0100
committerDavid Seifert <soap@gentoo.org>2020-11-21 21:37:55 +0100
commit9212c96c491976f079b128f9c5e43bc285c564b9 (patch)
tree319166c0834cec67140a2860483512e93a749414 /games-action/luola
parentgames-util/xqf: Port to EAPI 7 (diff)
downloadgentoo-9212c96c491976f079b128f9c5e43bc285c564b9.tar.gz
gentoo-9212c96c491976f079b128f9c5e43bc285c564b9.tar.bz2
gentoo-9212c96c491976f079b128f9c5e43bc285c564b9.zip
games-action/luola: Port to EAPI 7
Closes: https://bugs.gentoo.org/708664 Package-Manager: Portage-3.0.9, Repoman-3.0.2 Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'games-action/luola')
-rw-r--r--games-action/luola/files/luola-1.3.2-fno-common.patch33
-rw-r--r--games-action/luola/luola-1.3.2-r1.ebuild32
2 files changed, 45 insertions, 20 deletions
diff --git a/games-action/luola/files/luola-1.3.2-fno-common.patch b/games-action/luola/files/luola-1.3.2-fno-common.patch
new file mode 100644
index 000000000000..e0b191df831f
--- /dev/null
+++ b/games-action/luola/files/luola-1.3.2-fno-common.patch
@@ -0,0 +1,33 @@
+--- a/src/pilot.c
++++ b/src/pilot.c
+@@ -43,6 +43,8 @@
+ #define PILOT_STD_RADIUS 4.1 /* Normal radius for pilot */
+ #define PILOT_PAR_RADIUS 8.0 /* Parachuting radius for pilot */
+
++struct Pilot Pilot;
++
+ /* List of active pilots */
+ struct dllist *pilot_list;
+
+--- a/src/pilot.h
++++ b/src/pilot.h
+@@ -45,7 +45,8 @@
+ int toofast; /* How long has the pilot been falling too fast */
+ struct Spring *rope; /* The ninjarope */
+ int ropectrl; /* -1 retracts rope, 1 extends it */
+-} Pilot;
++};
++extern struct Pilot Pilot;
+
+ /* Rope length limits. Actual rope length is nodelen*nodecount */
+ static const double pilot_rope_minlen = 0.1;
+--- a/tools/im_vwing.c
++++ b/tools/im_vwing.c
+@@ -24,6 +24,7 @@
+ #include <stdlib.h>
+ #include <limits.h>
+ #include <stdio.h>
++#include <string.h>
+ #include <ctype.h>
+
+ #include "im_vwing.h"
diff --git a/games-action/luola/luola-1.3.2-r1.ebuild b/games-action/luola/luola-1.3.2-r1.ebuild
index ff2ec53aa188..0a2f70c623da 100644
--- a/games-action/luola/luola-1.3.2-r1.ebuild
+++ b/games-action/luola/luola-1.3.2-r1.ebuild
@@ -1,22 +1,23 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
-inherit autotools desktop gnome2-utils
+inherit autotools desktop xdg
DESCRIPTION="A 2D multiplayer arcade game resembling V-Wing"
HOMEPAGE="http://freshmeat.sourceforge.net/projects/luola"
-SRC_URI="mirror://gentoo/${P}.tar.gz
+SRC_URI="
+ mirror://gentoo/${P}.tar.gz
mirror://gentoo/stdlevels-6.0.tar.gz
mirror://gentoo/nostalgia-1.2.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE=""
-RDEPEND="media-libs/libsdl[X,sound,joystick,video]
+RDEPEND="
+ media-libs/libsdl[X,sound,joystick,video]
media-libs/sdl-gfx
media-libs/sdl-image[jpeg,png]
media-libs/sdl-mixer
@@ -25,6 +26,7 @@ DEPEND="${RDEPEND}"
PATCHES=(
"${FILESDIR}"/${P}-underlink.patch
+ "${FILESDIR}"/${P}-fno-common.patch
)
src_prepare() {
@@ -37,24 +39,14 @@ src_configure() {
}
src_install() {
- emake DESTDIR="${D}" install
+ default
+
insinto /usr/share/${PN}/levels
doins "${WORKDIR}"/*.{lev,png}
- dodoc AUTHORS ChangeLog DATAFILE FAQ LEVELFILE README TODO \
- RELEASENOTES.txt ../README.Nostalgia
+
+ dodoc DATAFILE LEVELFILE RELEASENOTES.txt ../README.Nostalgia
newdoc ../README README.stdlevels
+
doicon -s 64 luola.png
make_desktop_entry luola Luola
}
-
-pkg_preinst() {
- gnome2_icon_savelist
-}
-
-pkg_postinst() {
- gnome2_icon_cache_update
-}
-
-pkg_postrm() {
- gnome2_icon_cache_update
-}