summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2019-04-11 00:18:53 +0200
committerDavid Seifert <soap@gentoo.org>2019-04-11 00:19:48 +0200
commitd26b3a32bc218398894096c050375d9fb457f23a (patch)
tree7b93a8450645442a670e5558f363162094c57b19 /games-action/minetest
parentdev-lang/go: 1.11.8 and 1.12.3 bump (diff)
downloadgentoo-d26b3a32bc218398894096c050375d9fb457f23a.tar.gz
gentoo-d26b3a32bc218398894096c050375d9fb457f23a.tar.bz2
gentoo-d26b3a32bc218398894096c050375d9fb457f23a.zip
games-action/minetest: Remove misleading USE=jsoncpp flag
* dev-libs/jsoncpp is required unconditionally, USE=jsoncpp would just toggle between the bundled and system one, which is obviously wrong. Closes: https://bugs.gentoo.org/682996 Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'games-action/minetest')
-rw-r--r--games-action/minetest/minetest-5.0.1-r1.ebuild (renamed from games-action/minetest/minetest-5.0.1.ebuild)9
1 files changed, 6 insertions, 3 deletions
diff --git a/games-action/minetest/minetest-5.0.1.ebuild b/games-action/minetest/minetest-5.0.1-r1.ebuild
index 32f400f26920..8147fcf53adb 100644
--- a/games-action/minetest/minetest-5.0.1.ebuild
+++ b/games-action/minetest/minetest-5.0.1-r1.ebuild
@@ -12,11 +12,12 @@ SRC_URI="https://github.com/${PN}/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
LICENSE="LGPL-2.1+ CC-BY-SA-3.0 OFL-1.1 Apache-2.0"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE="+curl dedicated doc jsoncpp +leveldb luajit ncurses nls postgres redis +server +sound spatial +truetype"
+IUSE="+curl dedicated doc +leveldb luajit ncurses nls postgres redis +server +sound spatial +truetype"
RDEPEND="
dev-db/sqlite:3
dev-libs/gmp:0=
+ dev-libs/jsoncpp:=
sys-libs/zlib
curl? ( net-misc/curl )
!dedicated? (
@@ -34,7 +35,6 @@ RDEPEND="
)
truetype? ( media-libs/freetype:2 )
)
- jsoncpp? ( dev-libs/jsoncpp )
leveldb? ( dev-libs/leveldb:= )
luajit? ( dev-lang/luajit:2 )
ncurses? ( sys-libs/ncurses:0= )
@@ -64,6 +64,9 @@ src_prepare() {
-e "s#@BINDIR@#${EPREFIX}/usr/bin#g" \
-e "s#@GROUP@#${PN}#g" \
"${FILESDIR}"/minetestserver.confd > "${T}"/minetestserver.confd || die
+
+ # remove bundled gmp/jsoncpp
+ rm -rf lib/{gmp,jsoncpp} || die
}
src_configure() {
@@ -85,7 +88,7 @@ src_configure() {
-DENABLE_REDIS=$(usex redis)
-DENABLE_SPATIAL=$(usex spatial)
-DENABLE_SOUND=$(usex sound)
- -DENABLE_SYSTEM_JSONCPP=$(usex jsoncpp)
+ -DENABLE_SYSTEM_JSONCPP=1
-DRUN_IN_PLACE=0
)