summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2015-12-18 04:17:28 -0500
committerMichael Sterrett <mr_bones_@gentoo.org>2015-12-18 04:17:28 -0500
commitea3e84f32b666d85a21af365e4cb07df216e6628 (patch)
tree356d641f69a3cc5cee0e37f1a39069619a5ae2bd /games-action/noiz2sa
parentEAPI=5 (diff)
downloadgentoo-ea3e84f32b666d85a21af365e4cb07df216e6628.tar.gz
gentoo-ea3e84f32b666d85a21af365e4cb07df216e6628.tar.bz2
gentoo-ea3e84f32b666d85a21af365e4cb07df216e6628.zip
EAPI=5; minor tidying
Package-Manager: portage-2.2.24
Diffstat (limited to 'games-action/noiz2sa')
-rw-r--r--games-action/noiz2sa/noiz2sa-0.51a.ebuild9
1 files changed, 4 insertions, 5 deletions
diff --git a/games-action/noiz2sa/noiz2sa-0.51a.ebuild b/games-action/noiz2sa/noiz2sa-0.51a.ebuild
index 2987086f94eb..dea4e350c039 100644
--- a/games-action/noiz2sa/noiz2sa-0.51a.ebuild
+++ b/games-action/noiz2sa/noiz2sa-0.51a.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI=4
+EAPI=5
inherit eutils games
DESCRIPTION="Abstract Shooting Game"
@@ -27,10 +27,9 @@ src_prepare(){
sed -i \
-e "s:/.noiz2sa.prf:/noiz2sa.prf:" \
-e "s:getenv(\"HOME\"):\"${GAMES_STATEDIR}\":" \
- attractmanager.c \
- || die "sed failed"
+ attractmanager.c || die
- cp makefile.lin Makefile || die "Failed copying Makefile"
+ cp makefile.lin Makefile || die
}
src_install(){
@@ -38,7 +37,7 @@ src_install(){
dogamesbin ${PN}
dodir "${datadir}" "${GAMES_STATEDIR}"
- cp -r ../noiz2sa_share/* "${D}/${datadir}" || die "cp failed"
+ cp -r ../noiz2sa_share/* "${D}/${datadir}" || die
dodoc ../readme*
touch "${D}${GAMES_STATEDIR}/${PN}.prf"
fperms 660 "${GAMES_STATEDIR}/${PN}.prf"