summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-action/openastromenace
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-action/openastromenace')
-rw-r--r--games-action/openastromenace/Manifest1
-rw-r--r--games-action/openastromenace/metadata.xml8
-rw-r--r--games-action/openastromenace/openastromenace-1.3.2.ebuild76
3 files changed, 85 insertions, 0 deletions
diff --git a/games-action/openastromenace/Manifest b/games-action/openastromenace/Manifest
new file mode 100644
index 000000000000..e0d6defd2ff9
--- /dev/null
+++ b/games-action/openastromenace/Manifest
@@ -0,0 +1 @@
+DIST astromenace-src-1.3.2.tar.bz2 55390211 SHA256 9b775df2b157565b97aca008dd879b867cd3377c07b829cee6b5342639357fe6 SHA512 0a06278a8a7fdaaf5c730590fcc1f8f59503fe4c94dcbb6dd6b6ee638048f9bebf7c49c75cd32f26e4cd08cfbe01f5082002860901b7196f08a55712bb3ed5d4 WHIRLPOOL b5dee8d3cef2f143e44730c2eb0a60e3537675499c7c726752fc016faace498bf9a951bf96fb03ff2b3e3b8699d9f0575cb5e39ceacceb01a0c270c21691aa1f
diff --git a/games-action/openastromenace/metadata.xml b/games-action/openastromenace/metadata.xml
new file mode 100644
index 000000000000..187d75a84626
--- /dev/null
+++ b/games-action/openastromenace/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>games</herd>
+ <upstream>
+ <remote-id type="sourceforge">openastromenace</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/games-action/openastromenace/openastromenace-1.3.2.ebuild b/games-action/openastromenace/openastromenace-1.3.2.ebuild
new file mode 100644
index 000000000000..8d9ced2b16d3
--- /dev/null
+++ b/games-action/openastromenace/openastromenace-1.3.2.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit gnome2-utils cmake-utils eutils games
+
+DESCRIPTION="Modern 3D space shooter with spaceship upgrade possibilities"
+HOMEPAGE="http://sourceforge.net/projects/openastromenace/"
+SRC_URI="mirror://sourceforge/openastromenace/${PV}/astromenace-src-${PV}.tar.bz2"
+
+LICENSE="GPL-3 GPL-3+ CC-BY-SA-3.0 UbuntuFontLicense-1.0 OFL-1.1"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+DEPEND="virtual/opengl
+ virtual/glu
+ media-libs/libsdl[joystick,video,X]
+ media-libs/openal
+ media-libs/freealut
+ media-libs/freetype:2
+ media-libs/libogg
+ media-libs/libvorbis
+ x11-libs/libXinerama"
+
+S=${WORKDIR}/AstroMenace
+
+src_prepare() {
+ # no messing with CXXFLAGS please.
+ sed -i -e '/-Os/d' CMakeLists.txt || die
+ epatch_user # bug #542930
+}
+
+src_configure() {
+ local mycmakeargs="-DDATADIR=${GAMES_DATADIR}/${PN}"
+
+ cmake-utils_src_configure
+}
+
+src_compile() {
+ cmake-utils_src_compile
+
+ "${CMAKE_BUILD_DIR}"/AstroMenace --pack \
+ --rawdata="${S}"/RAW_VFS_DATA \
+ --dir=$(dirname "${CMAKE_BUILD_DIR}") || die
+}
+
+src_install() {
+ newgamesbin "${CMAKE_BUILD_DIR}"/AstroMenace "${PN}"
+
+ insinto "${GAMES_DATADIR}/${PN}"
+ doins ../*.vfs
+
+ newicon -s 128 astromenace_128.png ${PN}.png
+ newicon -s 64 astromenace_64.png ${PN}.png
+
+ dodoc ChangeLog.txt ReadMe.txt
+
+ make_desktop_entry "${PN}" OpenAstroMenace
+ prepgamesdirs
+}
+
+pkg_preinst() {
+ games_pkg_preinst
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}