summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-action/orbital-eunuchs-sniper
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-action/orbital-eunuchs-sniper')
-rw-r--r--games-action/orbital-eunuchs-sniper/Manifest1
-rw-r--r--games-action/orbital-eunuchs-sniper/files/orbital-eunuchs-sniper-1.30-datadir.patch36
-rw-r--r--games-action/orbital-eunuchs-sniper/files/orbital-eunuchs-sniper-1.30-gcc43.patch10
-rw-r--r--games-action/orbital-eunuchs-sniper/metadata.xml5
-rw-r--r--games-action/orbital-eunuchs-sniper/orbital-eunuchs-sniper-1.30.ebuild39
5 files changed, 91 insertions, 0 deletions
diff --git a/games-action/orbital-eunuchs-sniper/Manifest b/games-action/orbital-eunuchs-sniper/Manifest
new file mode 100644
index 000000000000..4b0b69f2ffa7
--- /dev/null
+++ b/games-action/orbital-eunuchs-sniper/Manifest
@@ -0,0 +1 @@
+DIST orbital_eunuchs_sniper-1.30.tar.gz 4056847 SHA256 4c9c909183d27309cb967f64fef13f8c69f1c9a9d559bffb87045d21059ee70a SHA512 81da382bdb6cd25ea3f1a3ecebc2827173cd7c77903cd37b88f328ae2c42f5db5a668597ebb2fca1c5c307d6db2745614aebee6f5e1be48fade184381558f21a WHIRLPOOL b2c2108451629c06382375569cbf937318028236745aa25d74343b1b7de3c0634c92e8874c739f6343cbe48c0c6a0cfb7e11628c0a2529dbdc49eb674e317f6e
diff --git a/games-action/orbital-eunuchs-sniper/files/orbital-eunuchs-sniper-1.30-datadir.patch b/games-action/orbital-eunuchs-sniper/files/orbital-eunuchs-sniper-1.30-datadir.patch
new file mode 100644
index 000000000000..090fb601d4c4
--- /dev/null
+++ b/games-action/orbital-eunuchs-sniper/files/orbital-eunuchs-sniper-1.30-datadir.patch
@@ -0,0 +1,36 @@
+--- configure.ac
++++ configure.ac
+@@ -64,14 +64,12 @@
+ ,dnl default action of assigning shell value
+ with_games_dir="${runtime_datadir}/games"
+ )
+-AC_SUBST(datadir,"${with_games_dir}")
+ AC_DEFINE_UNQUOTED([GAMEDATADIR], "${datadir}/$PACKAGE_NAME",
+ [Game data directory])
+
+
+ #These should be automagically determined somehow.
+ #CPU Instruction Set. Should be automagic.
+-AC_SUBST(CPU_IS,`uname -m`)
+
+
+ echo $ac_n "ordering crap from http://www.amazon.com/gp/registry/296ST2NHEBO0Z" 1>&6
+--- src/Makefile.am
++++ src/Makefile.am
+@@ -1,6 +1,4 @@
+-pkgdata_PROGRAMS = snipe2d.@CPU_IS@.dynamic snipe2d.@CPU_IS@.static
+-BUILT_SOURCES = snipe2d
+-bin_SCRIPTS = snipe2d
++bin_PROGRAMS = snipe2d
+ snipe2d_common = \
+ ai.cpp \
+ binds.cpp \
+@@ -28,7 +26,7 @@
+ sexpr/io.c \
+ sexpr/parser.c
+
+-snipe2d_@CPU_IS@_dynamic_SOURCES = $(snipe2d_common)
++snipe2d_SOURCES = $(snipe2d_common)
+
+ #snipe2d_@CPU_IS@_static_LDFLAGS = -static
+ snipe2d_@CPU_IS@_static_SOURCES = $(snipe2d_common)
diff --git a/games-action/orbital-eunuchs-sniper/files/orbital-eunuchs-sniper-1.30-gcc43.patch b/games-action/orbital-eunuchs-sniper/files/orbital-eunuchs-sniper-1.30-gcc43.patch
new file mode 100644
index 000000000000..268294a2c6c9
--- /dev/null
+++ b/games-action/orbital-eunuchs-sniper/files/orbital-eunuchs-sniper-1.30-gcc43.patch
@@ -0,0 +1,10 @@
+--- src/snipe2d.h
++++ src/snipe2d.h
+@@ -39,6 +39,7 @@
+ #include <stdlib.h>
+ #include <math.h>
+ #include <string.h>
++#include <climits>
+ #include <libgen.h>
+ #include <SDL/SDL.h>
+ #include <SDL/SDL_image.h>
diff --git a/games-action/orbital-eunuchs-sniper/metadata.xml b/games-action/orbital-eunuchs-sniper/metadata.xml
new file mode 100644
index 000000000000..d3c2cc926f0b
--- /dev/null
+++ b/games-action/orbital-eunuchs-sniper/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>games</herd>
+</pkgmetadata>
diff --git a/games-action/orbital-eunuchs-sniper/orbital-eunuchs-sniper-1.30.ebuild b/games-action/orbital-eunuchs-sniper/orbital-eunuchs-sniper-1.30.ebuild
new file mode 100644
index 000000000000..de8f91e7bb34
--- /dev/null
+++ b/games-action/orbital-eunuchs-sniper/orbital-eunuchs-sniper-1.30.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit autotools eutils games
+
+MY_P=${PN//-/_}-${PV}
+DESCRIPTION="Snipe terrorists from your orbital base"
+HOMEPAGE="http://icculus.org/oes/"
+SRC_URI="http://filesingularity.timedoctor.org/${MY_P}.tar.gz"
+
+LICENSE="ZLIB"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+IUSE=""
+
+DEPEND="media-libs/libsdl
+ media-libs/sdl-mixer
+ media-libs/sdl-image"
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/${P}-datadir.patch \
+ "${FILESDIR}"/${P}-gcc43.patch
+ sed -i \
+ -e '/^sleep /d' \
+ configure.ac || die
+ eautoreconf
+}
+
+src_install() {
+ DOCS="AUTHORS ChangeLog readme.txt README TODO" \
+ default
+ make_desktop_entry snipe2d "Orbital Eunuchs Sniper"
+ prepgamesdirs
+}