summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThiago Donato Ferreira <flowlnlnln@gmail.com>2022-05-31 20:47:02 -0300
committerSam James <sam@gentoo.org>2022-06-01 01:10:41 +0100
commit69101d81e5b71f22cf39afe6cf3a01a2e670ca08 (patch)
tree66c15d4d288fb199fa8c740e38dbf621f857f6dc /games-action/polymc
parentapp-editors/gedit-plugins: update HOMEPAGE (diff)
downloadgentoo-69101d81e5b71f22cf39afe6cf3a01a2e670ca08.tar.gz
gentoo-69101d81e5b71f22cf39afe6cf3a01a2e670ca08.tar.bz2
gentoo-69101d81e5b71f22cf39afe6cf3a01a2e670ca08.zip
games-action/polymc: remove some troublesome compile flags
Remove -Werror and -D_FORTIFY_SOURCE from the upstream CMakeLists, to prevent breakage with user-defined flags. Closes: https://bugs.gentoo.org/848765 Signed-off-by: Thiago Donato Ferreira <flowlnlnln@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/25713 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'games-action/polymc')
-rw-r--r--games-action/polymc/polymc-1.3.0.ebuild4
-rw-r--r--games-action/polymc/polymc-1.3.1.ebuild4
-rw-r--r--games-action/polymc/polymc-9999.ebuild4
3 files changed, 12 insertions, 0 deletions
diff --git a/games-action/polymc/polymc-1.3.0.ebuild b/games-action/polymc/polymc-1.3.0.ebuild
index abe73ed34f30..1034a30e5df0 100644
--- a/games-action/polymc/polymc-1.3.0.ebuild
+++ b/games-action/polymc/polymc-1.3.0.ebuild
@@ -79,6 +79,10 @@ RDEPEND="
src_prepare() {
cmake_src_prepare
+
+ # Prevent conflicting with the user's flags
+ # See https://bugs.gentoo.org/848765 for more info
+ sed -i -e 's/-Werror//' -e 's/-D_FORTIFY_SOURCE=2//' CMakeLists.txt || die 'Failed to remove -Werror and -D_FORTIFY_SOURCE via sed'
}
src_configure(){
diff --git a/games-action/polymc/polymc-1.3.1.ebuild b/games-action/polymc/polymc-1.3.1.ebuild
index abe73ed34f30..1034a30e5df0 100644
--- a/games-action/polymc/polymc-1.3.1.ebuild
+++ b/games-action/polymc/polymc-1.3.1.ebuild
@@ -79,6 +79,10 @@ RDEPEND="
src_prepare() {
cmake_src_prepare
+
+ # Prevent conflicting with the user's flags
+ # See https://bugs.gentoo.org/848765 for more info
+ sed -i -e 's/-Werror//' -e 's/-D_FORTIFY_SOURCE=2//' CMakeLists.txt || die 'Failed to remove -Werror and -D_FORTIFY_SOURCE via sed'
}
src_configure(){
diff --git a/games-action/polymc/polymc-9999.ebuild b/games-action/polymc/polymc-9999.ebuild
index abe73ed34f30..1034a30e5df0 100644
--- a/games-action/polymc/polymc-9999.ebuild
+++ b/games-action/polymc/polymc-9999.ebuild
@@ -79,6 +79,10 @@ RDEPEND="
src_prepare() {
cmake_src_prepare
+
+ # Prevent conflicting with the user's flags
+ # See https://bugs.gentoo.org/848765 for more info
+ sed -i -e 's/-Werror//' -e 's/-D_FORTIFY_SOURCE=2//' CMakeLists.txt || die 'Failed to remove -Werror and -D_FORTIFY_SOURCE via sed'
}
src_configure(){