summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-action/rrootage
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-action/rrootage')
-rw-r--r--games-action/rrootage/Manifest1
-rw-r--r--games-action/rrootage/files/rrootage-0.23a-gcc41.patch28
-rw-r--r--games-action/rrootage/metadata.xml8
-rw-r--r--games-action/rrootage/rrootage-0.23a.ebuild70
4 files changed, 107 insertions, 0 deletions
diff --git a/games-action/rrootage/Manifest b/games-action/rrootage/Manifest
new file mode 100644
index 000000000000..0103ffbf8970
--- /dev/null
+++ b/games-action/rrootage/Manifest
@@ -0,0 +1 @@
+DIST rRootage-0.23a.tar.gz 3910941 SHA256 964edbe21802e3e40d6a8da19b61132decacd13bf9a71bac86abce012379ff07 SHA512 29af79ef7bae46a103abf31696209b1ff5915caeb614d474b6a83f7e9657c19dea586e64a99437bba3e1121bfacc92c8d8b3c8a6831214d0d7da89927ca64f66 WHIRLPOOL 81a87e78e0baa1c252825977db3463be5ac7d00537373d937f938c200fe25f3a78c15ff0e380810cd0f47f9b4c135e48c2ed0cbff357b764c9dd155b47084d23
diff --git a/games-action/rrootage/files/rrootage-0.23a-gcc41.patch b/games-action/rrootage/files/rrootage-0.23a-gcc41.patch
new file mode 100644
index 000000000000..1e6e50e683fd
--- /dev/null
+++ b/games-action/rrootage/files/rrootage-0.23a-gcc41.patch
@@ -0,0 +1,28 @@
+--- src/foecommand.h.old 2006-04-21 23:26:03.000000000 +0200
++++ src/foecommand.h 2006-04-21 23:26:26.000000000 +0200
+@@ -39,10 +39,10 @@
+
+ virtual void doChangeDirection(double d);
+ virtual void doChangeSpeed(double s);
+- virtual void FoeCommand::doAccelX(double ax);
+- virtual void FoeCommand::doAccelY(double ay);
+- virtual double FoeCommand::getBulletSpeedX();
+- virtual double FoeCommand::getBulletSpeedY();
++ virtual void doAccelX(double ax);
++ virtual void doAccelY(double ay);
++ virtual double getBulletSpeedX();
++ virtual double getBulletSpeedY();
+
+ private:
+ struct foe *foe;
+--- src/screen.c.old 2006-04-21 23:50:01.000000000 +0200
++++ src/screen.c 2006-04-21 23:50:30.000000000 +0200
+@@ -73,7 +73,7 @@
+ void loadGLTexture(char *fileName, GLuint *texture) {
+ SDL_Surface *surface;
+
+- char name[32];
++ char name[128];
+ strcpy(name, SHARE_LOC);
+ strcat(name, "images/");
+ strcat(name, fileName);
diff --git a/games-action/rrootage/metadata.xml b/games-action/rrootage/metadata.xml
new file mode 100644
index 000000000000..f598ac280d72
--- /dev/null
+++ b/games-action/rrootage/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>games</herd>
+ <upstream>
+ <remote-id type="sourceforge">rrootage</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/games-action/rrootage/rrootage-0.23a.ebuild b/games-action/rrootage/rrootage-0.23a.ebuild
new file mode 100644
index 000000000000..3a1657d58e40
--- /dev/null
+++ b/games-action/rrootage/rrootage-0.23a.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+inherit eutils games
+
+MY_PN="rRootage"
+MY_P="${MY_PN}-${PV}"
+DESCRIPTION="Abstract shooter - defeat auto-created huge battleships"
+HOMEPAGE="http://www.asahi-net.or.jp/~cs8k-cyu/windows/rr_e.html
+ http://rrootage.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+IUSE=""
+
+DEPEND="virtual/opengl
+ virtual/glu
+ media-libs/libsdl[video]
+ media-libs/sdl-mixer[vorbis]
+ >=dev-libs/libbulletml-0.0.3"
+RDEPEND="${DEPEND}"
+
+S=${WORKDIR}/${MY_PN}/src
+
+src_prepare() {
+ epatch "${FILESDIR}/${P}"-gcc41.patch
+ sed \
+ -e "s/-lglut/-lGL -lGLU -lm/" \
+ -e "/^CC/d" \
+ -e "/^CXX/d" \
+ -e "/^LDFLAGS/s/=/+=/" \
+ -e "/^CPPFLAGS/s/MORE_CFLAGS/MORE_CXXFLAGS/" \
+ -e "/^CPPFLAGS/s/MORE_CFLAGS/MORE_CXXFLAGS/" \
+ -e "s/ -mwindows//" \
+ -e "s:-I./bulletml/:-I/usr/include/bulletml:" \
+ makefile.lin > Makefile || die "sed failed"
+
+ sed -i \
+ -e "s:/usr/share/games:${GAMES_DATADIR}:" \
+ barragemanager.cc screen.c soundmanager.c \
+ || die "sed failed"
+}
+
+src_compile() {
+ emake \
+ MORE_CFLAGS="-DLINUX ${CFLAGS}" \
+ MORE_CXXFLAGS="-DLINUX ${CXXFLAGS}"
+}
+
+src_install() {
+ newgamesbin rr ${PN}
+ dodir "${GAMES_DATADIR}/${MY_PN}"
+ cp -r ../rr_share/* "${D}/${GAMES_DATADIR}/${MY_PN}" || die "cp failed"
+ dodoc ../readme*
+ prepgamesdirs
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+ if ! has_version "media-libs/sdl-mixer[vorbis]" ; then
+ elog "${PN} will not have sound since sdl-mixer"
+ elog "is built with USE=-vorbis"
+ elog "Please emerge sdl-mixer with USE=vorbis"
+ elog "if you want sound support"
+ fi
+}