summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAustin English <wizardedit@gentoo.org>2016-07-27 16:46:20 -0500
committerAustin English <wizardedit@gentoo.org>2016-07-27 16:46:35 -0500
commit44d3fdedf738b6475cf6d17e7378f75d3cb3f240 (patch)
treec0e5aedda7edce984b4a6cd3c07b12961bee1a67 /games-action/spacearyarya-kxl/spacearyarya-kxl-1.0.2-r2.ebuild
parentkde-apps/lokalize: Use subslot on app-text/hunspell (diff)
downloadgentoo-44d3fdedf738b6475cf6d17e7378f75d3cb3f240.tar.gz
gentoo-44d3fdedf738b6475cf6d17e7378f75d3cb3f240.tar.bz2
gentoo-44d3fdedf738b6475cf6d17e7378f75d3cb3f240.zip
games-action/spacearyarya-kxl: remove deprecated games eclass
Also update to EAPI 6 Also fix building with Clang Gentoo-Bug: https://bugs.gentoo.org/574082 Package-Manager: portage-2.3.0
Diffstat (limited to 'games-action/spacearyarya-kxl/spacearyarya-kxl-1.0.2-r2.ebuild')
-rw-r--r--games-action/spacearyarya-kxl/spacearyarya-kxl-1.0.2-r2.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/games-action/spacearyarya-kxl/spacearyarya-kxl-1.0.2-r2.ebuild b/games-action/spacearyarya-kxl/spacearyarya-kxl-1.0.2-r2.ebuild
new file mode 100644
index 000000000000..2378c437b1ae
--- /dev/null
+++ b/games-action/spacearyarya-kxl/spacearyarya-kxl-1.0.2-r2.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+inherit autotools eutils
+
+MY_P=SpaceAryarya-KXL-${PV}
+DESCRIPTION="A 2D/3D shooting game"
+HOMEPAGE="http://triring.net/ps2linux/games/kxl/kxlgames.html"
+SRC_URI="mirror://gentoo/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+DEPEND="dev-games/KXL"
+RDEPEND="${DEPEND}
+ media-fonts/font-adobe-100dpi
+ media-fonts/font-bitstream-100dpi"
+
+S=${WORKDIR}/${MY_P}
+
+PATCHES=(
+ "${FILESDIR}"/${P}-gentoo-paths.patch
+ "${FILESDIR}"/${P}-flags.patch
+ "${FILESDIR}"/${P}-clang.patch
+)
+
+src_prepare() {
+ default
+
+ mv configure.{in,ac}
+ rm aclocal.m4
+ eautoreconf
+}
+
+src_install() {
+ default
+ newicon bmp/enemy1.bmp ${PN}.bmp
+ make_desktop_entry spacearyarya SpaceAryarya /usr/share/pixmaps/${PN}.bmp
+}