summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@gentoo.org>2021-10-25 08:48:23 +0200
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2021-10-25 08:51:30 +0200
commit03b6f8768bd4e2eb73eaf87e3bcf07d0455875db (patch)
tree9d4e003803477c1f8dd220f6819222823a7e5eaf /games-action
parentdev-ruby/dust: add ruby30 (diff)
downloadgentoo-03b6f8768bd4e2eb73eaf87e3bcf07d0455875db.tar.gz
gentoo-03b6f8768bd4e2eb73eaf87e3bcf07d0455875db.tar.bz2
gentoo-03b6f8768bd4e2eb73eaf87e3bcf07d0455875db.zip
games-action/multimc: update URLs and add elog about -bin version
Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
Diffstat (limited to 'games-action')
-rw-r--r--games-action/multimc/metadata.xml4
-rw-r--r--games-action/multimc/multimc-0.6.13.ebuild23
2 files changed, 17 insertions, 10 deletions
diff --git a/games-action/multimc/metadata.xml b/games-action/multimc/metadata.xml
index 9246e9cd3415..3907aa588cee 100644
--- a/games-action/multimc/metadata.xml
+++ b/games-action/multimc/metadata.xml
@@ -2,8 +2,8 @@
<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<upstream>
- <remote-id type="github">MultiMC/MultiMC5</remote-id>
- <bugs-to>https://github.com/MultiMC/MultiMC5/issues</bugs-to>
+ <remote-id type="github">MultiMC/Launcher</remote-id>
+ <bugs-to>https://github.com/MultiMC/Launcher/issues</bugs-to>
</upstream>
<maintainer type="person">
<email>andrewammerlaan@gentoo.org</email>
diff --git a/games-action/multimc/multimc-0.6.13.ebuild b/games-action/multimc/multimc-0.6.13.ebuild
index 350fecbdb5b2..25107ac520de 100644
--- a/games-action/multimc/multimc-0.6.13.ebuild
+++ b/games-action/multimc/multimc-0.6.13.ebuild
@@ -5,21 +5,19 @@ EAPI=7
inherit desktop java-pkg-2 xdg cmake
-MY_PN="MultiMC5"
-MY_P="${MY_PN}-${PV}"
-
QUAZIP_VER="multimc-3"
LIBNBTPLUSPLUS_VER="multimc-0.6.1"
DESCRIPTION="An advanced Qt5-based open-source launcher for Minecraft"
HOMEPAGE="https://multimc.org
- https://github.com/MultiMC/MultiMC5"
+ https://github.com/MultiMC/Launcher"
BASE_URI="https://github.com/MultiMC"
SRC_URI="
- ${BASE_URI}/${MY_PN}/archive/${PV}.tar.gz -> ${P}.tar.gz
+ ${BASE_URI}/Launcher/archive/${PV}.tar.gz -> ${P}.tar.gz
${BASE_URI}/libnbtplusplus/archive/${LIBNBTPLUSPLUS_VER}.tar.gz -> libnbtplusplus-${LIBNBTPLUSPLUS_VER}.tar.gz
${BASE_URI}/quazip/archive/${QUAZIP_VER}.tar.gz -> quazip-${QUAZIP_VER}.tar.gz
"
+S="${WORKDIR}/MultiMC5-${PV}"
KEYWORDS="~amd64"
LICENSE="Apache-2.0 Boost-1.0 BSD-2 BSD GPL-2+ LGPL-2.1-with-linking-exception LGPL-3 OFL-1.1 MIT"
@@ -27,7 +25,7 @@ SLOT="0"
# Author has indicated that he is unhappy with redistributing custom builds
# under the MultiMC name/logo
-# https://github.com/MultiMC/MultiMC5/issues/4087
+# https://github.com/MultiMC/Launcher/issues/4087
RESTRICT="bindist"
COMMON_DEPEND="
@@ -49,8 +47,6 @@ RDEPEND="${COMMON_DEPEND}
x11-libs/libXrandr
"
-S="${WORKDIR}/${MY_P}"
-
src_unpack() {
default
rm -r "${S}/libraries/libnbtplusplus" "${S}/libraries/quazip" || die
@@ -75,3 +71,14 @@ src_install() {
domenu launcher/package/linux/multimc.desktop
doicon -s scalable launcher/resources/multimc/scalable/multimc.svg
}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ elog ""
+ elog "In order to use Microsoft accounts instead of Mojang accounts"
+ elog "either use the official binary packaged in games-action/multimc-bin,"
+ elog "or patch your own secret API key into the MSAClientID variable in"
+ elog "notsecrets/Secrets.cpp."
+ elog "See Also: https://bugs.gentoo.org/814404"
+ elog ""
+}