summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Szuba <marecki@gentoo.org>2021-05-13 17:26:48 +0200
committerMarek Szuba <marecki@gentoo.org>2021-05-13 17:33:11 +0200
commit28122e85fb3f6261a96d82ebbfb2ab917a564858 (patch)
treebba05defe6b0fcf55fcb877209a34e26c4d967f4 /games-action
parentvirtual/man: drop 0-r3 (diff)
downloadgentoo-28122e85fb3f6261a96d82ebbfb2ab917a564858.tar.gz
gentoo-28122e85fb3f6261a96d82ebbfb2ab917a564858.tar.bz2
gentoo-28122e85fb3f6261a96d82ebbfb2ab917a564858.zip
games-action/minetest: allow building with gcc-11
Backported upstream commit, should only be necessary until the next release. Closes: https://bugs.gentoo.org/789474 Signed-off-by: Marek Szuba <marecki@gentoo.org>
Diffstat (limited to 'games-action')
-rw-r--r--games-action/minetest/files/minetest-5.4.1-gcc11.patch21
-rw-r--r--games-action/minetest/minetest-5.4.1-r1.ebuild1
2 files changed, 22 insertions, 0 deletions
diff --git a/games-action/minetest/files/minetest-5.4.1-gcc11.patch b/games-action/minetest/files/minetest-5.4.1-gcc11.patch
new file mode 100644
index 000000000000..bb37cdf31e07
--- /dev/null
+++ b/games-action/minetest/files/minetest-5.4.1-gcc11.patch
@@ -0,0 +1,21 @@
+From 7c2826cbc0f36027d4a9781f433150d1c5d0d03f Mon Sep 17 00:00:00 2001
+From: lhofhansl <larsh@apache.org>
+Date: Thu, 6 May 2021 10:24:30 -0700
+Subject: [PATCH] Fix build for newer versions of GCC (#11246)
+
+---
+ src/clientiface.h | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/src/clientiface.h b/src/clientiface.h
+index cc5292b71bf9..dfd97674137c 100644
+--- a/src/clientiface.h
++++ b/src/clientiface.h
+@@ -31,6 +31,7 @@ with this program; if not, write to the Free Software Foundation, Inc.,
+ #include <list>
+ #include <vector>
+ #include <set>
++#include <memory>
+ #include <mutex>
+
+ class MapBlock;
diff --git a/games-action/minetest/minetest-5.4.1-r1.ebuild b/games-action/minetest/minetest-5.4.1-r1.ebuild
index dfd64db5a93d..401043e97758 100644
--- a/games-action/minetest/minetest-5.4.1-r1.ebuild
+++ b/games-action/minetest/minetest-5.4.1-r1.ebuild
@@ -63,6 +63,7 @@ BDEPEND="
nls? ( sys-devel/gettext )"
PATCHES=(
+ "${FILESDIR}"/${PN}-5.4.1-gcc11.patch
"${FILESDIR}"/${PN}-5.4.1-system_puc_lua.patch
)