summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJames Le Cuirot <chewi@gentoo.org>2021-02-24 20:41:03 +0000
committerJames Le Cuirot <chewi@gentoo.org>2021-02-24 20:47:37 +0000
commit339d021183644940647f4867fe949def0873da63 (patch)
treec7079ccce56d100ceead1f04bb6aba8dea2a2c13 /games-action
parentgames-action/minetest: Version bump to 5.4.0 (diff)
downloadgentoo-339d021183644940647f4867fe949def0873da63.tar.gz
gentoo-339d021183644940647f4867fe949def0873da63.tar.bz2
gentoo-339d021183644940647f4867fe949def0873da63.zip
games-action/minetest: Drop old 5.3.0
Package-Manager: Portage-3.0.15, Repoman-3.0.2 Signed-off-by: James Le Cuirot <chewi@gentoo.org>
Diffstat (limited to 'games-action')
-rw-r--r--games-action/minetest/Manifest1
-rw-r--r--games-action/minetest/minetest-5.3.0-r100.ebuild146
-rw-r--r--games-action/minetest/minetest-5.3.0.ebuild142
3 files changed, 0 insertions, 289 deletions
diff --git a/games-action/minetest/Manifest b/games-action/minetest/Manifest
index 46330273b6ca..3dd06573d258 100644
--- a/games-action/minetest/Manifest
+++ b/games-action/minetest/Manifest
@@ -1,2 +1 @@
-DIST minetest-5.3.0.tar.gz 10828893 BLAKE2B 0847c040d2874962be79af6fce89b19354f6763cb37dd61d7e5e91bcacb9a76a115e295976056ae761db257612277ceef0d7e8bfc55790b1bc59a9c4961af41b SHA512 7bb34a80107861539a9ac2417812625ef11d145bf9401afdb8e0a1b9f619adcce24e2becf5bf361b805f4610097cf9d44c76d497ab08d489a43655852ce44777
DIST minetest-5.4.0.tar.gz 11205196 BLAKE2B 4fd03cf75c6ace4a8e3b1fc81826a43df4a6ea68c7dbdc33cda948e5c81fb49440341f148943c7300036d4063fafb0104fc42a8a29a0495df65d4c66f0d4eb46 SHA512 4cb43678c56ee2ccf9d5dd9c1fc0007119d598a4a56df43fc2a1b827efe08feba0008a30bdb1a1fcd4efe0ada88484b7be0c9e46f108d5424451adb0999b0bcb
diff --git a/games-action/minetest/minetest-5.3.0-r100.ebuild b/games-action/minetest/minetest-5.3.0-r100.ebuild
deleted file mode 100644
index de4641d9e6a5..000000000000
--- a/games-action/minetest/minetest-5.3.0-r100.ebuild
+++ /dev/null
@@ -1,146 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-LUA_COMPAT=( luajit )
-
-inherit cmake lua-single xdg
-
-DESCRIPTION="A free open-source voxel game engine with easy modding and game creation"
-HOMEPAGE="https://www.minetest.net"
-SRC_URI="https://github.com/${PN}/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="LGPL-2.1+ CC-BY-SA-3.0 OFL-1.1 Apache-2.0"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="+client +curl doc +leveldb ncurses nls postgres prometheus redis +server +sound spatial test +truetype"
-REQUIRED_USE="
- ${LUA_REQUIRED_USE}
- || ( client server )"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
- ${LUA_DEPS}
- dev-db/sqlite:3
- dev-libs/gmp:0=
- dev-libs/jsoncpp:=
- sys-libs/zlib
- client? (
- app-arch/bzip2
- dev-games/irrlicht
- media-libs/libpng:0=
- virtual/jpeg:0
- virtual/opengl
- x11-libs/libX11
- x11-libs/libXxf86vm
- sound? (
- media-libs/libogg
- media-libs/libvorbis
- media-libs/openal
- )
- truetype? ( media-libs/freetype:2 )
- )
- curl? ( net-misc/curl )
- leveldb? ( dev-libs/leveldb:= )
- ncurses? ( sys-libs/ncurses:0= )
- nls? ( virtual/libintl )
- postgres? ( >=dev-db/postgresql-9.5:= )
- prometheus? ( dev-cpp/prometheus-cpp )
- redis? ( dev-libs/hiredis:= )
- server? (
- acct-group/minetest
- acct-user/minetest
- dev-games/irrlicht-headers
- )
- spatial? ( sci-libs/libspatialindex:= )"
-DEPEND="${RDEPEND}"
-BDEPEND="
- doc? (
- app-doc/doxygen
- media-gfx/graphviz
- )
- nls? ( sys-devel/gettext )"
-
-src_prepare() {
- cmake_src_prepare
- # set paths
- sed \
- -e "s#@BINDIR@#${EPREFIX}/usr/bin#g" \
- -e "s#@GROUP@#${PN}#g" \
- "${FILESDIR}"/minetestserver.confd > "${T}"/minetestserver.confd || die
-
- # remove bundled libraries
- rm -rf lib || die
-}
-
-src_configure() {
- local mycmakeargs=(
- -DBUILD_CLIENT=$(usex client)
- -DBUILD_SERVER=$(usex server)
- -DBUILD_UNITTESTS=$(usex test)
- -DCUSTOM_BINDIR="${EPREFIX}/usr/bin"
- -DCUSTOM_DOCDIR="${EPREFIX}/usr/share/doc/${PF}"
- -DCUSTOM_EXAMPLE_CONF_DIR="${EPREFIX}/usr/share/doc/${PF}"
- -DCUSTOM_LOCALEDIR="${EPREFIX}/usr/share/${PN}/locale"
- -DCUSTOM_SHAREDIR="${EPREFIX}/usr/share/${PN}"
- -DENABLE_CURL=$(usex curl)
- -DENABLE_CURSES=$(usex ncurses)
- -DENABLE_FREETYPE=$(usex truetype)
- -DENABLE_GETTEXT=$(usex nls)
- -DENABLE_GLES=0
- -DENABLE_LEVELDB=$(usex leveldb)
- -DENABLE_LUAJIT=1
- -DENABLE_POSTGRESQL=$(usex postgres)
- -DENABLE_PROMETHEUS=$(usex prometheus)
- -DENABLE_REDIS=$(usex redis)
- -DENABLE_SPATIAL=$(usex spatial)
- -DENABLE_SOUND=$(usex sound)
- -DENABLE_SYSTEM_GMP=1
- -DENABLE_SYSTEM_JSONCPP=1
- -DRUN_IN_PLACE=0
- )
-
- cmake_src_configure
-}
-
-src_compile() {
- cmake_src_compile
-
- if use doc ; then
- cmake_src_compile doc
- HTML_DOCS=( "${BUILD_DIR}"/doc/html/. )
- fi
-}
-
-src_install() {
- cmake_src_install
-
- if use server ; then
- keepdir /var/log/minetest
- fowners minetest:minetest /var/log/minetest
-
- newconfd "${T}"/minetestserver.confd minetest-server
- newinitd "${FILESDIR}"/minetestserver.initd minetest-server
-
- insinto /etc/logrotate.d
- newins "${FILESDIR}"/minetestserver.logrotate minetest-server
- fi
-}
-
-pkg_postinst() {
- xdg_pkg_postinst
-
- if use server ; then
- elog
- elog "Configure your server via /etc/conf.d/minetest-server"
- elog
- fi
-
- elog
- elog "The version 5.x series is not compatible to the version 0.4 series."
- elog "This applies to clients and servers, other content such as mods,"
- elog "texture packs and worlds is unaffected and backwards-compatible"
- elog "as usual."
- elog
-}
diff --git a/games-action/minetest/minetest-5.3.0.ebuild b/games-action/minetest/minetest-5.3.0.ebuild
deleted file mode 100644
index b954c7f0fa33..000000000000
--- a/games-action/minetest/minetest-5.3.0.ebuild
+++ /dev/null
@@ -1,142 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit cmake xdg
-
-DESCRIPTION="A free open-source voxel game engine with easy modding and game creation"
-HOMEPAGE="https://www.minetest.net"
-SRC_URI="https://github.com/${PN}/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="LGPL-2.1+ CC-BY-SA-3.0 OFL-1.1 Apache-2.0"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="+client +curl doc +leveldb ncurses nls postgres prometheus redis +server +sound spatial test +truetype"
-REQUIRED_USE="|| ( client server )"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
- dev-db/sqlite:3
- dev-lang/luajit:2
- dev-libs/gmp:0=
- dev-libs/jsoncpp:=
- sys-libs/zlib
- client? (
- app-arch/bzip2
- dev-games/irrlicht
- media-libs/libpng:0=
- virtual/jpeg:0
- virtual/opengl
- x11-libs/libX11
- x11-libs/libXxf86vm
- sound? (
- media-libs/libogg
- media-libs/libvorbis
- media-libs/openal
- )
- truetype? ( media-libs/freetype:2 )
- )
- curl? ( net-misc/curl )
- leveldb? ( dev-libs/leveldb:= )
- ncurses? ( sys-libs/ncurses:0= )
- nls? ( virtual/libintl )
- postgres? ( >=dev-db/postgresql-9.5:= )
- prometheus? ( dev-cpp/prometheus-cpp )
- redis? ( dev-libs/hiredis:= )
- server? (
- acct-group/minetest
- acct-user/minetest
- dev-games/irrlicht-headers
- )
- spatial? ( sci-libs/libspatialindex:= )"
-DEPEND="${RDEPEND}"
-BDEPEND="
- doc? (
- app-doc/doxygen
- media-gfx/graphviz
- )
- nls? ( sys-devel/gettext )"
-
-src_prepare() {
- cmake_src_prepare
- # set paths
- sed \
- -e "s#@BINDIR@#${EPREFIX}/usr/bin#g" \
- -e "s#@GROUP@#${PN}#g" \
- "${FILESDIR}"/minetestserver.confd > "${T}"/minetestserver.confd || die
-
- # remove bundled libraries
- rm -rf lib || die
-}
-
-src_configure() {
- local mycmakeargs=(
- -DBUILD_CLIENT=$(usex client)
- -DBUILD_SERVER=$(usex server)
- -DBUILD_UNITTESTS=$(usex test)
- -DCUSTOM_BINDIR="${EPREFIX}/usr/bin"
- -DCUSTOM_DOCDIR="${EPREFIX}/usr/share/doc/${PF}"
- -DCUSTOM_EXAMPLE_CONF_DIR="${EPREFIX}/usr/share/doc/${PF}"
- -DCUSTOM_LOCALEDIR="${EPREFIX}/usr/share/${PN}/locale"
- -DCUSTOM_SHAREDIR="${EPREFIX}/usr/share/${PN}"
- -DENABLE_CURL=$(usex curl)
- -DENABLE_CURSES=$(usex ncurses)
- -DENABLE_FREETYPE=$(usex truetype)
- -DENABLE_GETTEXT=$(usex nls)
- -DENABLE_GLES=0
- -DENABLE_LEVELDB=$(usex leveldb)
- -DENABLE_LUAJIT=1
- -DENABLE_POSTGRESQL=$(usex postgres)
- -DENABLE_PROMETHEUS=$(usex prometheus)
- -DENABLE_REDIS=$(usex redis)
- -DENABLE_SPATIAL=$(usex spatial)
- -DENABLE_SOUND=$(usex sound)
- -DENABLE_SYSTEM_GMP=1
- -DENABLE_SYSTEM_JSONCPP=1
- -DRUN_IN_PLACE=0
- )
-
- cmake_src_configure
-}
-
-src_compile() {
- cmake_src_compile
-
- if use doc ; then
- cmake_src_compile doc
- HTML_DOCS=( "${BUILD_DIR}"/doc/html/. )
- fi
-}
-
-src_install() {
- cmake_src_install
-
- if use server ; then
- keepdir /var/log/minetest
- fowners minetest:minetest /var/log/minetest
-
- newconfd "${T}"/minetestserver.confd minetest-server
- newinitd "${FILESDIR}"/minetestserver.initd minetest-server
-
- insinto /etc/logrotate.d
- newins "${FILESDIR}"/minetestserver.logrotate minetest-server
- fi
-}
-
-pkg_postinst() {
- xdg_pkg_postinst
-
- if use server ; then
- elog
- elog "Configure your server via /etc/conf.d/minetest-server"
- elog
- fi
-
- elog
- elog "The version 5.x series is not compatible to the version 0.4 series."
- elog "This applies to clients and servers, other content such as mods,"
- elog "texture packs and worlds is unaffected and backwards-compatible"
- elog "as usual."
- elog
-}