summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2015-12-18 04:00:42 -0500
committerMichael Sterrett <mr_bones_@gentoo.org>2015-12-18 04:00:42 -0500
commit5c6bc7dd1660cc35520d47e59e20e3fb4aae24e6 (patch)
tree1341a82675817c5195d42e687b9cd8aeb7feecb0 /games-action
parentfixup desktop file (diff)
downloadgentoo-5c6bc7dd1660cc35520d47e59e20e3fb4aae24e6.tar.gz
gentoo-5c6bc7dd1660cc35520d47e59e20e3fb4aae24e6.tar.bz2
gentoo-5c6bc7dd1660cc35520d47e59e20e3fb4aae24e6.zip
EAPI=5; minor tidying
Package-Manager: portage-2.2.24
Diffstat (limited to 'games-action')
-rw-r--r--games-action/0verkill/0verkill-0.16-r3.ebuild13
1 files changed, 5 insertions, 8 deletions
diff --git a/games-action/0verkill/0verkill-0.16-r3.ebuild b/games-action/0verkill/0verkill-0.16-r3.ebuild
index 9af4419c1599..df0776c37a4e 100644
--- a/games-action/0verkill/0verkill-0.16-r3.ebuild
+++ b/games-action/0verkill/0verkill-0.16-r3.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI=4
+EAPI=5
inherit autotools eutils games
DESCRIPTION="a bloody 2D action deathmatch-like game in ASCII-ART"
@@ -15,7 +15,7 @@ KEYWORDS="amd64 ia64 ppc sparc x86"
IUSE="X"
DEPEND="X? ( x11-libs/libXpm )"
-RDEPEND="${DEPEND}"
+RDEPEND=${DEPEND}
src_prepare() {
epatch \
@@ -27,14 +27,11 @@ src_prepare() {
"${FILESDIR}"/${P}-CC.patch \
"${FILESDIR}"/${P}-underflow-check.patch #136222 \
sed -i \
- -e "s:data/:${GAMES_DATADIR}/${PN}/data/:" cfg.h \
- || die "sed failed"
+ -e "s:data/:${GAMES_DATADIR}/${PN}/data/:" cfg.h || die
sed -i \
- -e "s:@CFLAGS@ -O3 :@CFLAGS@ :" Makefile.in \
- || die "sed failed"
+ -e "s:@CFLAGS@ -O3 :@CFLAGS@ :" Makefile.in || die
sed -i \
- -e "/gettimeofday/s/getopt/getopt calloc/" configure.in \
- || die "sed failed"
+ -e "/gettimeofday/s/getopt/getopt calloc/" configure.in || die
eautoreconf
}