summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVictor Kustov <ktrace@yandex.ru>2020-05-11 16:34:18 +0300
committerAndreas Sturmlechner <asturm@gentoo.org>2020-07-01 12:16:15 +0200
commit6101c95ee5879e1d10a5e502c88f3a752df06751 (patch)
tree62f05d37dc2d3611722b597642a033c3ffabfca4 /games-action
parentnet-libs/nodejs: Version 14.5.0 (diff)
downloadgentoo-6101c95ee5879e1d10a5e502c88f3a752df06751.tar.gz
gentoo-6101c95ee5879e1d10a5e502c88f3a752df06751.tar.bz2
gentoo-6101c95ee5879e1d10a5e502c88f3a752df06751.zip
games-action/teeworlds: bump to 0.7.5
Bump version Remove dev-util/bam (switch to cmake) Closes: https://bugs.gentoo.org/668928 Signed-off-by: Victor Kustov <ktrace@yandex.ru> Closes: https://github.com/gentoo/gentoo/pull/13781 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'games-action')
-rw-r--r--games-action/teeworlds/Manifest4
-rw-r--r--games-action/teeworlds/teeworlds-0.7.5.ebuild80
2 files changed, 84 insertions, 0 deletions
diff --git a/games-action/teeworlds/Manifest b/games-action/teeworlds/Manifest
index 78521c5092a3..6b9d796adb21 100644
--- a/games-action/teeworlds/Manifest
+++ b/games-action/teeworlds/Manifest
@@ -1 +1,5 @@
DIST teeworlds-0.6.4-src.tar.gz 8771622 BLAKE2B 14493fcad458b0e1c749e40bdd6a5a858704bf971d53d11782d52fbe9b5fe2a09235dcac25340e51a3330001d46ee512f2971e8db06eb9f51eec5e6b3cd2a328 SHA512 7546ee358a2126339f6c727bb7b5f49009a8fad0b5e77a796202cba4d8fc5dfcaf79b7e65151d85fead2a70ad61ef3e1888b8c07fe0206f87575d5dd8c9f91ce
+DIST teeworlds-0.7.5-maps.tar.gz 151689 BLAKE2B f8ffbb6a024755bb972955a8c7d277709e17021c0554be0e2803e8c1b4848f5dca6d91b9f7f4e0731766745878c1143d27be3fa8aede01ff9cc69ac557ca70a8 SHA512 74084e169c1870cd541f5bb719c209210227055d304b3ce22fbad3d32d24b3356fbdec8d948edf3aa582270a8b0db7dec41e4924401f8398f7d5feba5ded49b3
+DIST teeworlds-0.7.5-translation.tar.gz 169121 BLAKE2B 1c649392385abf8e00d8c9e64ca7eaaa5af5848878566081cda83c7d78c417652137e7285d16038f302a6fdf94eb3993c506886d4cc1359694d534c7be5ea925 SHA512 41c69cd9e9290857b44be18f89ab9f3a7ccd6804757332966b973aec3a9e6fd5a40d323696a044a724228b2bb67b097311fa8c24fdec226eecb7a27c2da559dc
+DIST teeworlds-0.7.5.tar.gz 8654985 BLAKE2B ebeb9aa1119950e4d78d8c0d6c7be5711894c3212755a6db3b8b8c1f1803dba1e0d2e1a0e294e1a1fffe84a28beab8fac0e55fa0e94c68ed97e8764ac3b742d3 SHA512 673410a5fb5e488229ddc4ea4a1ac9cd8143a6e9499bde9f5535d7f0be5b6c85163065da9580c3de0d240f1cad63e0bc12c10caf1d893c324edb301bc150653b
+DIST teeworlds.png 21502 BLAKE2B 8064e0c2149f20f182b2ca2f7454f0e8395e199a432b8f21a9963cc771b1504ebe8cbe427ecd738d35313b1a378eaf8e305d509cd5360a07e9ab3c5224b78b77 SHA512 a272a1d9f13504c43ba873d93899df93c435f58cec20ae68bc9493a983e54cdd4c8f0f2e0630558c5e915aec891d2267bc3459ecc78c25738602452a2123fadf
diff --git a/games-action/teeworlds/teeworlds-0.7.5.ebuild b/games-action/teeworlds/teeworlds-0.7.5.ebuild
new file mode 100644
index 000000000000..f2e0b2da85e6
--- /dev/null
+++ b/games-action/teeworlds/teeworlds-0.7.5.ebuild
@@ -0,0 +1,80 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{5,6,7} )
+
+inherit cmake-utils desktop python-any-r1 xdg-utils
+
+COMMIT_LANG="4ba6f824e9c34565e61340d25bc8c3cc004d40fb"
+COMMIT_MAPS="1d3401a37a3334e311faf18a22aeff0e0ac9ee65"
+
+DESCRIPTION="Online multi-player platform 2D shooter"
+HOMEPAGE="https://www.teeworlds.com/"
+SRC_URI="
+ https://github.com/ktrace/gentoo-blobs/raw/master/teeworlds.png
+ https://github.com/teeworlds/teeworlds/archive/${PV}.tar.gz -> ${P}.tar.gz
+ https://github.com/teeworlds/teeworlds-maps/archive/${COMMIT_MAPS}.tar.gz -> ${P}-maps.tar.gz
+ https://github.com/teeworlds/teeworlds-translation/archive/${COMMIT_LANG}.tar.gz -> ${P}-translation.tar.gz
+ "
+
+LICENSE="ZLIB"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug dedicated"
+
+RDEPEND="
+ !dedicated? (
+ app-arch/bzip2
+ media-libs/freetype
+ media-libs/libsdl[X,sound,opengl,video]
+ media-libs/pnglite
+ media-sound/wavpack
+ virtual/glu
+ virtual/opengl
+ x11-libs/libX11
+ )
+ dev-libs/openssl:0=
+ sys-libs/zlib"
+
+DEPEND="${RDEPEND} ${PYTHON_DEPS}"
+
+src_prepare() {
+ rm -r "${S}/datasrc/languages" || die
+ rm -r "${S}/datasrc/maps" || die
+ mv "${WORKDIR}/${PN}-translation-${COMMIT_LANG}" "${S}/datasrc/languages" || die
+ mv "${WORKDIR}/${PN}-maps-${COMMIT_MAPS}" "${S}/datasrc/maps" || die
+ cp "${DISTDIR}/${PN}.png" "${S}/" || die
+ python_fix_shebang scripts/
+ cmake-utils_src_prepare
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DCLIENT=$(usex dedicated OFF ON)
+ -DDEV=$(usex debug ON OFF)
+ -DPYTHON_EXECUTABLE="${PYTHON}"
+ )
+
+ cmake-utils_src_configure
+}
+
+src_install() {
+ cmake-utils_src_install
+ doicon -s 256 "${PN}.png"
+ domenu other/teeworlds.desktop
+ newinitd "${FILESDIR}"/${PN}-init.d ${PN}
+ insinto "/etc/${PN}"
+ doins "${FILESDIR}"/teeworlds_srv.cfg
+}
+
+pkg_postinst() {
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+}