summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2020-07-05 02:23:32 +0200
committerDavid Seifert <soap@gentoo.org>2020-07-05 02:23:32 +0200
commit79becd30b4adcd72606eb50b9b154d31aa791284 (patch)
treeba08fc996212e71d3e157be858e65f8827797b0a /games-action
parentgames-emulation/dgen-sdl: Call AM_PROG_AR (diff)
downloadgentoo-79becd30b4adcd72606eb50b9b154d31aa791284.tar.gz
gentoo-79becd30b4adcd72606eb50b9b154d31aa791284.tar.bz2
gentoo-79becd30b4adcd72606eb50b9b154d31aa791284.zip
games-action/koth: Fix build system
Closes: https://bugs.gentoo.org/724324 Package-Manager: Portage-2.3.103, Repoman-2.3.23 Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'games-action')
-rw-r--r--games-action/koth/files/koth-0.8.0-autotools.patch20
-rw-r--r--games-action/koth/files/koth-0.8.0-gcc.patch72
-rw-r--r--games-action/koth/files/koth-0.8.0-r1-gcc-3.4.patch29
-rw-r--r--games-action/koth/koth-0.8.0-r1.ebuild22
4 files changed, 103 insertions, 40 deletions
diff --git a/games-action/koth/files/koth-0.8.0-autotools.patch b/games-action/koth/files/koth-0.8.0-autotools.patch
new file mode 100644
index 000000000000..0303a0e0bec6
--- /dev/null
+++ b/games-action/koth/files/koth-0.8.0-autotools.patch
@@ -0,0 +1,20 @@
+--- a/configure.in
++++ b/configure.in
+@@ -4,15 +4,14 @@
+ AM_CONFIG_HEADER(config.h)
+ AC_PROG_MAKE_SET
+
+-USER_CFLAGS=$CFLAGS
+-
+ dnl Checks for programs.
+ AC_PROG_CC
+ AC_ISC_POSIX
++AM_PROG_AR
+ AC_PROG_RANLIB
+
+
+-CFLAGS="-g -O2 -Wall -Wimplicit $USER_CFLAGS"
++CFLAGS="${CFLAGS} -Wall -Wimplicit"
+ dnl Checks for library functions.
+ AC_ARG_ENABLE(client, [ --disable-client disable libggi detection (can only build server)],
+ if test $enableval == no; then
diff --git a/games-action/koth/files/koth-0.8.0-gcc.patch b/games-action/koth/files/koth-0.8.0-gcc.patch
new file mode 100644
index 000000000000..999498da7005
--- /dev/null
+++ b/games-action/koth/files/koth-0.8.0-gcc.patch
@@ -0,0 +1,72 @@
+--- a/src/ballistics.c
++++ b/src/ballistics.c
+@@ -92,6 +92,7 @@
+ break;
+ case WALL_LAST:
+ /* just to satisfy gcc -Wall */
++ ;
+ }
+ }
+
+@@ -210,7 +211,7 @@
+ break;
+ case WALL_RANDOM: /* both of this can't happen, */
+ case WALL_LAST: /* so they are here to satisfy gcc -Wall */
+-
++ ;
+ }
+ }
+ return FLYING;
+--- a/src/gfx.c
++++ b/src/gfx.c
+@@ -51,7 +51,7 @@
+ int gfx_armorBar=0;
+
+ /* The maximum value for a color. */
+-#define CMAX ((uint16)(~0))
++#define CMAX ((uint16_t)(~0))
+ #define MAX(a, b) (((a) > (b)) ? (a) : (b))
+ #define MIN(a, b) (((a) < (b)) ? (a) : (b))
+
+--- a/src/gfx.h
++++ b/src/gfx.h
+@@ -24,7 +24,7 @@
+ #include "terrain.h"
+
+ /* The maximum value for a color. */
+-#define CMAX ((uint16)(~0))
++#define CMAX ((uint16_t)(~0))
+ #define MAX_WALLS 6
+
+ extern ggi_visual_t gfx_vis;
+--- a/src/log.c
++++ b/src/log.c
+@@ -26,7 +26,7 @@
+
+ Levels_log log_level = INTERESTING;
+
+-inline void logPrintf(Levels_log level, char *fmt, ...)
++void logPrintf(Levels_log level, char *fmt, ...)
+ {
+ if(log_level < level)
+ return;
+--- a/src/log.h
++++ b/src/log.h
+@@ -25,6 +25,6 @@
+
+ extern Levels_log log_level;
+
+-inline void logPrintf(Levels_log level, char *fmt, ...);
++void logPrintf(Levels_log level, char *fmt, ...);
+
+ #endif
+--- a/src/relay.c
++++ b/src/relay.c
+@@ -260,6 +260,7 @@
+ else goto bail;
+ goto nextpkt;
+ bail:
++ ;
+ }
+ }
+ }
diff --git a/games-action/koth/files/koth-0.8.0-r1-gcc-3.4.patch b/games-action/koth/files/koth-0.8.0-r1-gcc-3.4.patch
deleted file mode 100644
index 145f17dbccdd..000000000000
--- a/games-action/koth/files/koth-0.8.0-r1-gcc-3.4.patch
+++ /dev/null
@@ -1,29 +0,0 @@
---- a/src/relay.c 2004-11-01 09:19:04.835537536 +0000
-+++ b/src/relay.c 2004-11-01 09:19:59.453234384 +0000
-@@ -260,6 +260,7 @@
- else goto bail;
- goto nextpkt;
- bail:
-+ ;
- }
- }
- }
---- a/src/ballistics.c 2004-11-01 09:19:33.132235784 +0000
-+++ b/src/ballistics.c 2004-11-01 09:20:16.849589736 +0000
-@@ -92,6 +92,7 @@
- break;
- case WALL_LAST:
- /* just to satisfy gcc -Wall */
-+ ;
- }
- }
-
-@@ -210,7 +211,7 @@
- break;
- case WALL_RANDOM: /* both of this can't happen, */
- case WALL_LAST: /* so they are here to satisfy gcc -Wall */
--
-+ ;
- }
- }
- return FLYING;
diff --git a/games-action/koth/koth-0.8.0-r1.ebuild b/games-action/koth/koth-0.8.0-r1.ebuild
index 988f9bf485dc..3030dcd88d94 100644
--- a/games-action/koth/koth-0.8.0-r1.ebuild
+++ b/games-action/koth/koth-0.8.0-r1.ebuild
@@ -1,8 +1,9 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
-inherit eutils flag-o-matic
+EAPI=7
+
+inherit autotools
DESCRIPTION="Multiplayer, networked game of little tanks with really big weapons"
HOMEPAGE="http://www.nongnu.org/koth/"
@@ -11,26 +12,25 @@ SRC_URI="https://savannah.nongnu.org/download/${PN}/default.pkg/${PV}/${P}.tar.b
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~x86"
-IUSE=""
DEPEND="media-libs/libggi"
RDEPEND="${DEPEND}"
PATCHES=(
- "${FILESDIR}"/${PF}-gcc-3.4.patch
+ "${FILESDIR}"/${P}-autotools.patch
+ "${FILESDIR}"/${P}-gcc.patch
)
src_prepare() {
default
- sed -i 's:-g -O2::' configure || die
- sed -i 's:(uint16):(uint16_t):' src/gfx.c src/gfx.h || die
- append-cflags -std=gnu89 # build with gcc5 (bug #570730)
+ mv configure.{in,ac} || die
+ eautoreconf
}
src_install() {
- DOCS="AUTHORS ChangeLog NEWS README doc/*.txt" \
- default
- dodir /etc/koth
+ default
+ dodoc doc/*.txt
+
insinto /etc/koth
doins src/koth.cfg
}