summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJames Le Cuirot <chewi@gentoo.org>2020-05-08 22:59:08 +0100
committerJames Le Cuirot <chewi@gentoo.org>2020-05-08 22:59:08 +0100
commit7b594507ca4ba1702865c28103ee2235a918494e (patch)
tree8f9c293a1a1879df539ac10a700de815e6f2bdbf /games-action
parentapp-portage/nattka: keyword arm64 (diff)
downloadgentoo-7b594507ca4ba1702865c28103ee2235a918494e.tar.gz
gentoo-7b594507ca4ba1702865c28103ee2235a918494e.tar.bz2
gentoo-7b594507ca4ba1702865c28103ee2235a918494e.zip
games-action/rive: New package
Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: James Le Cuirot <chewi@gentoo.org>
Diffstat (limited to 'games-action')
-rw-r--r--games-action/rive/Manifest1
-rw-r--r--games-action/rive/metadata.xml8
-rw-r--r--games-action/rive/rive-1.15.ebuild46
3 files changed, 55 insertions, 0 deletions
diff --git a/games-action/rive/Manifest b/games-action/rive/Manifest
new file mode 100644
index 000000000000..1bbdd715e715
--- /dev/null
+++ b/games-action/rive/Manifest
@@ -0,0 +1 @@
+DIST RIVE-Linux-2017-02-28.sh 836583560 BLAKE2B 2194d6174217a395e84f0defc336e741671f62b71cb15dad16fd9c3f1f23d844771e830858bbc8e8a26bd4ebf93e2f9b316c6a2a9c9de74d876a393b9911a806 SHA512 94d236421dc060b8e69552ee6bcbdc4b41caa4934ccf73f8d82dcd2ee14a9c334f43bc74e787a470b3103699c31b4f4ccf9272fbe69640e27df1fdbc2191447c
diff --git a/games-action/rive/metadata.xml b/games-action/rive/metadata.xml
new file mode 100644
index 000000000000..26079e608bed
--- /dev/null
+++ b/games-action/rive/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>games@gentoo.org</email>
+ <name>Gentoo Games Project</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/games-action/rive/rive-1.15.ebuild b/games-action/rive/rive-1.15.ebuild
new file mode 100644
index 000000000000..6014bf696dec
--- /dev/null
+++ b/games-action/rive/rive-1.15.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit desktop unpacker xdg
+
+DESCRIPTION="Metal wrecking, robot hacking 360-degree shooter/platformer hybrid"
+HOMEPAGE="https://rivethegame.com/"
+SRC_URI="${PN^^}-Linux-2017-02-28.sh"
+LICENSE="all-rights-reserved"
+SLOT="0"
+KEYWORDS="-* ~amd64"
+RESTRICT="bindist fetch splitdebug"
+
+RDEPEND="
+ media-libs/libsdl2[opengl,video]
+ media-libs/openal
+"
+
+S="${WORKDIR}/data"
+
+DIR="/opt/${PN}"
+QA_PREBUILT="${DIR#/}/*"
+
+pkg_nofetch() {
+ einfo "Please buy and download ${SRC_URI} from:"
+ einfo " https://www.humblebundle.com/store/${PN}"
+ einfo "and move it to your distfiles directory."
+}
+
+src_unpack() {
+ unpack_zip ${A}
+}
+
+src_install() {
+ exeinto "${DIR}"
+ newexe x86_64/${PN^^}.bin.x86_64 ${PN^^}.bin
+ dosym "../..${DIR}"/${PN^^}.bin /usr/bin/${PN}
+
+ insinto "${DIR}"
+ doins -r noarch/*
+
+ newicon -s 256 noarch/app_icon.png ${PN}.png
+ make_desktop_entry ${PN} ${PN^^}
+}