summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThiago Donato Ferreira <flowlnlnln@gmail.com>2022-06-12 14:56:05 -0300
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2022-06-12 22:24:26 +0200
commitbe3446362bb0b3c6008274f258da0a33ffcf34f8 (patch)
tree06aff83033e34648fe8e71efbe8a9dec7d6c63d7 /games-action
parentx11-wm/blackbox: fix build with GCC 12 (diff)
downloadgentoo-be3446362bb0b3c6008274f258da0a33ffcf34f8.tar.gz
gentoo-be3446362bb0b3c6008274f258da0a33ffcf34f8.tar.bz2
gentoo-be3446362bb0b3c6008274f258da0a33ffcf34f8.zip
games-action/polymc: add 1.3.2
Signed-off-by: Thiago Donato Ferreira <flowlnlnln@gmail.com> Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
Diffstat (limited to 'games-action')
-rw-r--r--games-action/polymc/Manifest1
-rw-r--r--games-action/polymc/polymc-1.3.2.ebuild115
2 files changed, 116 insertions, 0 deletions
diff --git a/games-action/polymc/Manifest b/games-action/polymc/Manifest
index 53f0d3f4fada..4d5e3fd4d0bc 100644
--- a/games-action/polymc/Manifest
+++ b/games-action/polymc/Manifest
@@ -1,2 +1,3 @@
DIST polymc-1.3.0.tar.gz 5115480 BLAKE2B ac818b899d25f1545ceafd109a8eb48acd6a2d4b09b8d7f5365de0fc1b6ce0171ed053bc19785192ab781a2d7f506167599e3f3747e94fe1cf62b9989208e685 SHA512 b33660dfc7026f1153aaffd4429b9047bffa9cc80a3231bb19c0f3a7d4046654c49f278d9c07ae3ac631172ed147fa06065c2713fb59221ff9131406d8c6df46
DIST polymc-1.3.1.tar.gz 5651471 BLAKE2B ee36d6f046959932c72d6b3320704bbc565afd56e03f715db0f9270148b7ced80ff46d4e2ad33167e77e9b95d5dbe3316d9c7b5f9b36c15e28989555fddf0239 SHA512 8cfd644574a588a0b8dca6adbd9aee21bd603fc29649bbf55ad713dc37a1a9d7a8720031a6952d97c6a597c082f7437315044926d7da2d50e58a3da096343c7b
+DIST polymc-1.3.2.tar.gz 5641952 BLAKE2B f1014c79c394db79e07bcd55c65c930ace80274a83cffc4c8adff58547f3ddf9baa5685ecd7b860c8ec21e4ae4ebf407233d3cb2b8d9ae2a81abd31248b1cebf SHA512 f272248631e76e2cb3b74f3bc91ab3d4f7e7cf4fb7396a09b8bcaf65d928076f49e436e3d7c1a34c32a2cbcf10760709f86cd9c0eca285b66790f25b1c466ea0
diff --git a/games-action/polymc/polymc-1.3.2.ebuild b/games-action/polymc/polymc-1.3.2.ebuild
new file mode 100644
index 000000000000..1034a30e5df0
--- /dev/null
+++ b/games-action/polymc/polymc-1.3.2.ebuild
@@ -0,0 +1,115 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake java-pkg-2 optfeature xdg
+
+HOMEPAGE="https://polymc.org/ https://github.com/PolyMC/PolyMC"
+DESCRIPTION="A custom, open source Minecraft launcher"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+
+ EGIT_REPO_URI="
+ https://github.com/PolyMC/PolyMC
+ https://github.com/PolyMC/libnbtplusplus
+ "
+
+ EGIT_SUBMODULES=( 'depends/libnbtplusplus' )
+else
+ MY_PN="PolyMC"
+
+ # Let's use the vendored tarball to avoid dealing with the submodules directly
+ SRC_URI="
+ https://github.com/PolyMC/PolyMC/releases/download/${PV}/${MY_PN}-${PV}.tar.gz -> ${P}.tar.gz
+ "
+
+ # The PolyMC's files are unpacked to ${WORKDIR}/PolyMC-${PV}
+ S="${WORKDIR}/${MY_PN}-${PV}"
+
+ KEYWORDS="~amd64"
+fi
+
+# Apache-2.0 for MultiMC (PolyMC is forked from it)
+# GPL-3 for PolyMC
+# LGPL-3 for libnbtplusplus
+# See the rest of PolyMC's libraries at https://github.com/PolyMC/PolyMC/tree/develop/libraries
+LICENSE="Apache-2.0 Boost-1.0 BSD BSD-2 GPL-2+ GPL-3 LGPL-3 OFL-1.1 MIT"
+
+SLOT="0"
+
+IUSE="debug lto"
+REQUIRED_USE="
+ lto? ( !debug )
+"
+
+MIN_QT="5.12.0"
+
+QT_DEPS="
+ >=dev-qt/qtconcurrent-${MIN_QT}:5
+ >=dev-qt/qtcore-${MIN_QT}:5
+ >=dev-qt/qtgui-${MIN_QT}:5
+ >=dev-qt/qtnetwork-${MIN_QT}:5
+ >=dev-qt/qttest-${MIN_QT}:5
+ >=dev-qt/qtwidgets-${MIN_QT}:5
+ >=dev-qt/qtxml-${MIN_QT}:5
+"
+
+# Required at both build-time and run-time
+COMMON_DEPENDS="
+ ${QT_DEPS}
+ >=dev-libs/quazip-1.3:=
+ sys-libs/zlib
+"
+
+DEPEND="
+ ${COMMON_DEPENDS}
+ media-libs/libglvnd
+ >=virtual/jdk-1.8.0:*
+"
+
+# At run-time we don't depend on JDK, only JRE
+# And we need more than just the GL headers
+RDEPEND="
+ ${COMMON_DEPENDS}
+ >=virtual/jre-1.8.0:*
+ virtual/opengl
+"
+
+src_prepare() {
+ cmake_src_prepare
+
+ # Prevent conflicting with the user's flags
+ # See https://bugs.gentoo.org/848765 for more info
+ sed -i -e 's/-Werror//' -e 's/-D_FORTIFY_SOURCE=2//' CMakeLists.txt || die 'Failed to remove -Werror and -D_FORTIFY_SOURCE via sed'
+}
+
+src_configure(){
+ local mycmakeargs=(
+ -DCMAKE_INSTALL_PREFIX="/usr"
+ # Resulting binary is named polymc
+ -DLauncher_APP_BINARY_NAME="${PN}"
+
+ -DENABLE_LTO=$(usex lto)
+ )
+
+ if use debug; then
+ CMAKE_BUILD_TYPE=Debug
+ else
+ CMAKE_BUILD_TYPE=Release
+ fi
+
+ cmake_src_configure
+}
+
+src_compile(){
+ cmake_src_compile
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+
+ # https://github.com/PolyMC/PolyMC/issues/227
+ optfeature "old Minecraft (<= 1.12.2) support" x11-libs/libXrandr
+}