summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorflow <flowlnlnln@gmail.com>2022-09-08 15:22:34 -0300
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2022-09-09 18:33:24 +0200
commitdf27101c265358f58d1a45e7328708de385b62c7 (patch)
treeddb398eb1967c570dfe7b766ed6c63a2ad940954 /games-action
parentgames-board/chessx: depend on quazip[qt5(+)] (diff)
downloadgentoo-df27101c265358f58d1a45e7328708de385b62c7.tar.gz
gentoo-df27101c265358f58d1a45e7328708de385b62c7.tar.bz2
gentoo-df27101c265358f58d1a45e7328708de385b62c7.zip
games-action/polymc: drop 1.3.2
Signed-off-by: Thiago Donato Ferreira <flowlnlnln@gmail.com> Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
Diffstat (limited to 'games-action')
-rw-r--r--games-action/polymc/Manifest1
-rw-r--r--games-action/polymc/polymc-1.3.2.ebuild115
2 files changed, 0 insertions, 116 deletions
diff --git a/games-action/polymc/Manifest b/games-action/polymc/Manifest
index 1b50bf038e81..0b23addb2f04 100644
--- a/games-action/polymc/Manifest
+++ b/games-action/polymc/Manifest
@@ -1,2 +1 @@
-DIST polymc-1.3.2.tar.gz 5641952 BLAKE2B f1014c79c394db79e07bcd55c65c930ace80274a83cffc4c8adff58547f3ddf9baa5685ecd7b860c8ec21e4ae4ebf407233d3cb2b8d9ae2a81abd31248b1cebf SHA512 f272248631e76e2cb3b74f3bc91ab3d4f7e7cf4fb7396a09b8bcaf65d928076f49e436e3d7c1a34c32a2cbcf10760709f86cd9c0eca285b66790f25b1c466ea0
DIST polymc-1.4.1.tar.gz 5771113 BLAKE2B d55907770d913c814015c4337c0442cb3fdaf92815f3e2f1f496b7869b6da8ee2295260efc3df67e7407ee27d300c4e89900603281e69163c07df216193c05d9 SHA512 170d03b61d3e9edbe1a0b27812e52fb90963d09769327f2d95eab6c4b7c88291136f47a44b7c206808fcc2e0e9ddf4aeb3a3f267ccbdc6b70b44d91c4642bf75
diff --git a/games-action/polymc/polymc-1.3.2.ebuild b/games-action/polymc/polymc-1.3.2.ebuild
deleted file mode 100644
index e59146da7e6f..000000000000
--- a/games-action/polymc/polymc-1.3.2.ebuild
+++ /dev/null
@@ -1,115 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit cmake java-pkg-2 optfeature xdg
-
-HOMEPAGE="https://polymc.org/ https://github.com/PolyMC/PolyMC"
-DESCRIPTION="A custom, open source Minecraft launcher"
-
-if [[ ${PV} == 9999 ]]; then
- inherit git-r3
-
- EGIT_REPO_URI="
- https://github.com/PolyMC/PolyMC
- https://github.com/PolyMC/libnbtplusplus
- "
-
- EGIT_SUBMODULES=( 'depends/libnbtplusplus' )
-else
- MY_PN="PolyMC"
-
- # Let's use the vendored tarball to avoid dealing with the submodules directly
- SRC_URI="
- https://github.com/PolyMC/PolyMC/releases/download/${PV}/${MY_PN}-${PV}.tar.gz -> ${P}.tar.gz
- "
-
- # The PolyMC's files are unpacked to ${WORKDIR}/PolyMC-${PV}
- S="${WORKDIR}/${MY_PN}-${PV}"
-
- KEYWORDS="~amd64"
-fi
-
-# Apache-2.0 for MultiMC (PolyMC is forked from it)
-# GPL-3 for PolyMC
-# LGPL-3 for libnbtplusplus
-# See the rest of PolyMC's libraries at https://github.com/PolyMC/PolyMC/tree/develop/libraries
-LICENSE="Apache-2.0 Boost-1.0 BSD BSD-2 GPL-2+ GPL-3 LGPL-3 OFL-1.1 MIT"
-
-SLOT="0"
-
-IUSE="debug lto"
-REQUIRED_USE="
- lto? ( !debug )
-"
-
-MIN_QT="5.12.0"
-
-QT_DEPS="
- >=dev-qt/qtconcurrent-${MIN_QT}:5
- >=dev-qt/qtcore-${MIN_QT}:5
- >=dev-qt/qtgui-${MIN_QT}:5
- >=dev-qt/qtnetwork-${MIN_QT}:5
- >=dev-qt/qttest-${MIN_QT}:5
- >=dev-qt/qtwidgets-${MIN_QT}:5
- >=dev-qt/qtxml-${MIN_QT}:5
-"
-
-# Required at both build-time and run-time
-COMMON_DEPENDS="
- ${QT_DEPS}
- >=dev-libs/quazip-1.3:=[qt5(+)]
- sys-libs/zlib
-"
-
-DEPEND="
- ${COMMON_DEPENDS}
- media-libs/libglvnd
- >=virtual/jdk-1.8.0:*
-"
-
-# At run-time we don't depend on JDK, only JRE
-# And we need more than just the GL headers
-RDEPEND="
- ${COMMON_DEPENDS}
- >=virtual/jre-1.8.0:*
- virtual/opengl
-"
-
-src_prepare() {
- cmake_src_prepare
-
- # Prevent conflicting with the user's flags
- # See https://bugs.gentoo.org/848765 for more info
- sed -i -e 's/-Werror//' -e 's/-D_FORTIFY_SOURCE=2//' CMakeLists.txt || die 'Failed to remove -Werror and -D_FORTIFY_SOURCE via sed'
-}
-
-src_configure(){
- local mycmakeargs=(
- -DCMAKE_INSTALL_PREFIX="/usr"
- # Resulting binary is named polymc
- -DLauncher_APP_BINARY_NAME="${PN}"
-
- -DENABLE_LTO=$(usex lto)
- )
-
- if use debug; then
- CMAKE_BUILD_TYPE=Debug
- else
- CMAKE_BUILD_TYPE=Release
- fi
-
- cmake_src_configure
-}
-
-src_compile(){
- cmake_src_compile
-}
-
-pkg_postinst() {
- xdg_pkg_postinst
-
- # https://github.com/PolyMC/PolyMC/issues/227
- optfeature "old Minecraft (<= 1.12.2) support" x11-libs/libXrandr
-}