summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJakov Smolić <jsmolic@gentoo.org>2023-08-12 14:39:57 +0200
committerJakov Smolić <jsmolic@gentoo.org>2023-08-12 14:42:28 +0200
commite182da092d1c0fd0c09c02a55b86822490b88966 (patch)
tree7fb94a7fa6c8e48e605a78b1f352faf14006d9cc /games-action
parentgames-action/descent3-demo: treeclean (diff)
downloadgentoo-e182da092d1c0fd0c09c02a55b86822490b88966.tar.gz
gentoo-e182da092d1c0fd0c09c02a55b86822490b88966.tar.bz2
gentoo-e182da092d1c0fd0c09c02a55b86822490b88966.zip
games-action/descent3: treeclean
Closes: https://bugs.gentoo.org/436140 Signed-off-by: Jakov Smolić <jsmolic@gentoo.org>
Diffstat (limited to 'games-action')
-rw-r--r--games-action/descent3/Manifest2
-rw-r--r--games-action/descent3/descent3-1.4.0b-r3.ebuild103
-rw-r--r--games-action/descent3/metadata.xml11
3 files changed, 0 insertions, 116 deletions
diff --git a/games-action/descent3/Manifest b/games-action/descent3/Manifest
deleted file mode 100644
index 2075e9c0d1c6..000000000000
--- a/games-action/descent3/Manifest
+++ /dev/null
@@ -1,2 +0,0 @@
-DIST descent3-1.4.0a-x86.run 2736956 BLAKE2B 23ea2042404308ff6d9b1b3fca688b1b59c9a774017ed0ca0a1e95166c698a41f7453addf6af043bb5faed8866ce590692dc8c708de01fb5464b0c456863c50e SHA512 e6c5d6a678c46374c5d5d40589d40906378fd17ebb658778a2d052a71cd069877a43eb83b344b41473fe443e886c3b07283ea9de908df4ab8584638670114ecc
-DIST descent3-1.4.0b-x86.run 4504631 BLAKE2B e6e807b8e1bc511a612a7b217ec9b86bb75cebfee3b30f636f7b668a651c09e61b13679d332e92708e8adc926033c4abe9b270e0357673d4026f934f31287de2 SHA512 912afcf51a2f4f8cacb231e318d4837c64b2f762109244c083760b5e580298d4166fea0878ee2d344b841c788d673896a09d0052ebea59dead637d834e826db3
diff --git a/games-action/descent3/descent3-1.4.0b-r3.ebuild b/games-action/descent3/descent3-1.4.0b-r3.ebuild
deleted file mode 100644
index 0756a6d15fc4..000000000000
--- a/games-action/descent3/descent3-1.4.0b-r3.ebuild
+++ /dev/null
@@ -1,103 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit cdrom desktop unpacker wrapper
-
-DESCRIPTION="Descent 3 - 3-Dimensional indoor/outdoor spaceship combat"
-HOMEPAGE="http://www.lokigames.com/products/descent3/"
-SRC_URI="mirror://lokigames/${PN}/${PN}-1.4.0a-x86.run
- mirror://lokigames/${PN}/${P}-x86.run"
-
-LICENSE="LOKI-EULA"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="nocd videos"
-
-RESTRICT="strip mirror bindist"
-
-RDEPEND="
- media-libs/libsdl[abi_x86_32(-)]
- media-libs/smpeg[abi_x86_32(-)]
- sys-libs/glibc
- virtual/opengl[abi_x86_32(-)]
- x11-libs/libX11[abi_x86_32(-)]
- x11-libs/libXext[abi_x86_32(-)]
-"
-
-dir=opt/${PN}
-Ddir="${ED}"/${dir}
-
-pkg_setup() {
- if use videos ; then
- ewarn "The installed game takes about 1.2GB of space!"
- elif use nocd ; then
- ewarn "The installed game takes about 510MB of space!"
- else
- ewarn "The installed game takes about 220MB of space!"
- fi
-}
-
-src_unpack() {
- if use videos ; then
- cdrom_get_cds missions/d3.mn3 movies/level1.mve
- else
- cdrom_get_cds missions/d3.mn3
- fi
-
- mkdir -p "${S}"/{a,b} || die
- cd "${S}"/a || die
- unpack_makeself ${PN}-1.4.0a-x86.run
- cd "${S}"/b || die
- unpack_makeself ${P}-x86.run
-}
-
-src_install() {
- einfo "Copying files... this may take a while..."
- exeinto ${dir}
- doexe ${CDROM_ROOT}/bin/x86/glibc-2.1/{${PN},nettest}
- insinto ${dir}
- doins ${CDROM_ROOT}/{FAQ.txt,README{,.mercenary},d3.hog,icon.{bmp,xpm}}
-
- cd "${Ddir}" || die
- # TODO: move this to src_unpack where it belongs
- tar xzf ${CDROM_ROOT}/data.tar.gz || die
- tar xzf ${CDROM_ROOT}/shared.tar.gz || die
-
- if use nocd; then
- doins -r ${CDROM_ROOT}/missions
- fi
-
- if use videos ; then
- cdrom_load_next_cd
- doins -r ${CDROM_ROOT}/movies
- fi
-
- cd "${S}"/a || die
- bin/Linux/x86/loki_patch --verify patch.dat || die
- bin/Linux/x86/loki_patch patch.dat "${Ddir}" >& /dev/null || die
-
- cd "${S}"/b || die
- bin/Linux/x86/loki_patch --verify patch.dat || die
- bin/Linux/x86/loki_patch patch.dat "${Ddir}" >& /dev/null || die
-
- # now, since these files are coming off a cd, the times/sizes/md5sums wont
- # be different ... that means portage will try to unmerge some files (!)
- # we run touch on ${D} so as to make sure portage doesnt do any such thing
- find "${Ddir}" -exec touch '{}' + || die
-
- make_wrapper descent3 ./descent3.dynamic "${dir}" "${dir}"
- newicon ${CDROM_ROOT}/icon.xpm ${PN}.xpm
-
- # Fix for 2.6 kernel crash
- cd "${Ddir}" || die
- ln -sf ppics.hog PPics.Hog || die
-
- make_desktop_entry ${PN} "Descent 3" ${PN}
-}
-
-pkg_postinst() {
- elog "To play the game run:"
- elog " descent3"
-}
diff --git a/games-action/descent3/metadata.xml b/games-action/descent3/metadata.xml
deleted file mode 100644
index f99362e46bdf..000000000000
--- a/games-action/descent3/metadata.xml
+++ /dev/null
@@ -1,11 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
-<maintainer type="project">
- <email>games@gentoo.org</email>
- <name>Gentoo Games Project</name>
-</maintainer>
-<longdescription>
-Descent 3 is a first-person 3-D action flight-sim which takes place in both indoor and outdoor arenas. The game was ported to Linux by the now defunct Loki Entertainment and is commercial software. You can still pick up a copy from Tuxgames (http://www.tuxgames.com), but supplies are limited, as the publisher is no longer in business.
-</longdescription>
-</pkgmetadata>