summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJames Le Cuirot <chewi@gentoo.org>2022-07-18 22:36:07 +0100
committerJames Le Cuirot <chewi@gentoo.org>2022-07-18 22:36:07 +0100
commitf6125674d3319051cd0ecf342a72ea580c002633 (patch)
treefe20380ed82f59f055218a5c86aca0787a4417f6 /games-action
parentapp-containers/cosign-1.8.0: drop unneeded patch (diff)
downloadgentoo-f6125674d3319051cd0ecf342a72ea580c002633.tar.gz
gentoo-f6125674d3319051cd0ecf342a72ea580c002633.tar.bz2
gentoo-f6125674d3319051cd0ecf342a72ea580c002633.zip
games-action/psychonauts2-hb: New package at version 1097251
Signed-off-by: James Le Cuirot <chewi@gentoo.org>
Diffstat (limited to 'games-action')
-rw-r--r--games-action/psychonauts2-hb/Manifest2
-rw-r--r--games-action/psychonauts2-hb/metadata.xml22
-rw-r--r--games-action/psychonauts2-hb/psychonauts2-hb-1097251.ebuild55
3 files changed, 79 insertions, 0 deletions
diff --git a/games-action/psychonauts2-hb/Manifest b/games-action/psychonauts2-hb/Manifest
new file mode 100644
index 000000000000..3c27a94747c2
--- /dev/null
+++ b/games-action/psychonauts2-hb/Manifest
@@ -0,0 +1,2 @@
+DIST Psychonauts2_1097251.tar.xz 30744988256 BLAKE2B b411a143ac10e3256dd0eec0615eac179d03465c6fedb7da9863da44ead160fbe6bc0e62ddb25e0fdf79d247c5325e6a6777f26a98cd97536b406b33e977f7c0 SHA512 fd6a94a1fbf6a12b38903a40ade86d58cb1826790c3b15bd1d272a80b71cf9bde68d34a2fb28987b01b0f88d21762edc403f442d1d73e6d6633d20c6f28f9204
+DIST psychonauts2.png 73910 BLAKE2B ce33615237b2ab65cf95da4febfdfa33884ab44f03f6bce50dd553a4b65dff96055d6e8e47d4c23483856f499ddb3b1b09cd19d29c1efd322b5e91bd60bb82ae SHA512 1ccb5c77f57aaec152d23c1b27ec880e5064a28a48e9f137e462ee656c672ab5f8c700583d97947d90cb244655f7ade89cd153cee29892e0852ca41e3370d664
diff --git a/games-action/psychonauts2-hb/metadata.xml b/games-action/psychonauts2-hb/metadata.xml
new file mode 100644
index 000000000000..3febbdad35dc
--- /dev/null
+++ b/games-action/psychonauts2-hb/metadata.xml
@@ -0,0 +1,22 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>games@gentoo.org</email>
+ <name>Gentoo Games Project</name>
+ </maintainer>
+ <longdescription lang="en">
+ Razputin “Raz” Aquato, trained acrobat and powerful young psychic, has
+ realized his lifelong dream of joining the international psychic
+ espionage organization known as the Psychonauts! But these psychic super
+ spies are in trouble. Their leader hasn't been the same since he was
+ rescued from a kidnapping, and what's worse, there's a mole hiding in
+ headquarters.
+
+ Combining quirky missions and mysterious conspiracies, Psychonauts 2 is
+ a platform-adventure game with cinematic style and tons of customizable
+ psychic powers. Psychonauts 2 serves up danger, excitement and laughs in
+ equal measure as players guide Raz on a journey through the minds of
+ friends and foes on a quest to defeat a murderous psychic villain.
+ </longdescription>
+</pkgmetadata>
diff --git a/games-action/psychonauts2-hb/psychonauts2-hb-1097251.ebuild b/games-action/psychonauts2-hb/psychonauts2-hb-1097251.ebuild
new file mode 100644
index 000000000000..c985c9884abc
--- /dev/null
+++ b/games-action/psychonauts2-hb/psychonauts2-hb-1097251.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+CHECKREQS_DISK_BUILD="30583M"
+inherit check-reqs desktop xdg
+
+MY_P="Psychonauts2_${PV}"
+MY_PN="${PN%-hb}"
+DESCRIPTION="Platform-adventure game with cinematic style and customizable psychic powers"
+HOMEPAGE="https://www.humblebundle.com/store/psychonauts-2"
+SRC_URI="${MY_P}.tar.xz
+ mirror+https://dev.gentoo.org/~chewi/distfiles/${MY_PN}.png"
+
+LICENSE="all-rights-reserved"
+SLOT="0"
+KEYWORDS="-* ~amd64"
+RESTRICT="bindist fetch splitdebug"
+
+RDEPEND="
+ >=sys-libs/glibc-2.17
+ x11-misc/xdg-user-dirs
+ !${CATEGORY}/${MY_PN}-gog
+"
+
+S="${WORKDIR}/${MY_P}"
+DIR="/opt/${MY_PN}"
+QA_PREBUILT="${DIR#/}/*"
+
+pkg_nofetch() {
+ einfo "Please buy and download ${SRC_URI} from:"
+ einfo " ${HOMEPAGE}"
+ einfo "and move it to your distfiles directory."
+}
+
+src_install() {
+ local d
+
+ insinto "${DIR}"/Psychonauts2
+ doins -r Psychonauts2/Content
+
+ for d in Engine/Binaries/ThirdParty/PhysX3/Linux/x86_64-unknown-linux-gnu \
+ Engine/Plugins/Wwise/ThirdParty/Linux_x64/Release/bin \
+ Psychonauts2/Binaries/Linux
+ do
+ exeinto "${DIR}/${d}"
+ doexe "${d}"/*
+ done
+
+ dosym ../..${DIR}/Psychonauts2/Binaries/Linux/Psychonauts2-Linux-Shipping /usr/bin/${MY_PN}
+
+ doicon -s 256 "${DISTDIR}"/${MY_PN}.png
+ make_desktop_entry ${MY_PN} "Psychonauts 2" ${MY_PN}
+}