summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-04-05 15:46:17 +0000
committerSam James <sam@gentoo.org>2021-04-05 15:46:17 +0000
commitfd2c42c18d59bd8f1c8e22c2d9446a52767a8ae8 (patch)
treea07bfddae4d87ff34f49fd0a508f648305e730d3 /games-action
parentdev-games/ps2-packer: port to EAPI 7, games.eclass-- (diff)
downloadgentoo-fd2c42c18d59bd8f1c8e22c2d9446a52767a8ae8.tar.gz
gentoo-fd2c42c18d59bd8f1c8e22c2d9446a52767a8ae8.tar.bz2
gentoo-fd2c42c18d59bd8f1c8e22c2d9446a52767a8ae8.zip
games-action/towbowl-tactics: port to EAPI 7, games.eclass--
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'games-action')
-rw-r--r--games-action/towbowl-tactics/files/towbowl-tactics-0.5-gentoo.patch10
-rw-r--r--games-action/towbowl-tactics/towbowl-tactics-0.5-r1.ebuild (renamed from games-action/towbowl-tactics/towbowl-tactics-0.5.ebuild)47
2 files changed, 34 insertions, 23 deletions
diff --git a/games-action/towbowl-tactics/files/towbowl-tactics-0.5-gentoo.patch b/games-action/towbowl-tactics/files/towbowl-tactics-0.5-gentoo.patch
index aa6a950e9a07..be8a3c42a994 100644
--- a/games-action/towbowl-tactics/files/towbowl-tactics-0.5-gentoo.patch
+++ b/games-action/towbowl-tactics/files/towbowl-tactics-0.5-gentoo.patch
@@ -1,6 +1,5 @@
-diff -ru tbt.orig/config.xml tbt/config.xml
---- tbt.orig/config.xml 2003-02-01 15:14:56.000000000 -0500
-+++ tbt/config.xml 2011-01-10 12:08:01.564649048 -0500
+--- a/config.xml
++++ b/config.xml
@@ -5,5 +5,5 @@
<screen_h>600</screen_h>
<sound_enabled>1</sound_enabled>
@@ -8,9 +7,8 @@ diff -ru tbt.orig/config.xml tbt/config.xml
-<language>0</language>
+<language>1</language>
</config>
-diff -ru tbt.orig/src/Makefile tbt/src/Makefile
---- tbt.orig/src/Makefile 2003-02-01 15:07:40.000000000 -0500
-+++ tbt/src/Makefile 2011-01-10 12:07:29.075274834 -0500
+--- a/src/Makefile
++++ b/src/Makefile
@@ -1,24 +1,20 @@
TBTHOME = /usr/local/games/tbt
INCDIR = -I /usr/include/smpeg -I /usr/include/libxml2 -I /usr/include/SDL/
diff --git a/games-action/towbowl-tactics/towbowl-tactics-0.5.ebuild b/games-action/towbowl-tactics/towbowl-tactics-0.5-r1.ebuild
index 68970fe0ac94..94a3daf70c8e 100644
--- a/games-action/towbowl-tactics/towbowl-tactics-0.5.ebuild
+++ b/games-action/towbowl-tactics/towbowl-tactics-0.5-r1.ebuild
@@ -1,51 +1,64 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
-inherit eutils games
+EAPI=7
+
+inherit desktop edos2unix toolchain-funcs
DESCRIPTION="Tow Bowl Tactics is a game based on Games Workshop's Blood Bowl"
HOMEPAGE="http://www.towbowltactics.com/index_en.html"
SRC_URI="http://www.towbowltactics.com/download/tbt.${PV}.src.zip"
+S="${WORKDIR}"/tbt/src
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE=""
-RDEPEND="dev-libs/libxml2
+RDEPEND="
+ dev-libs/libxml2
media-libs/smpeg
media-libs/libsdl[sound,video]
media-libs/sdl-net
media-libs/sdl-image[jpeg,png]
media-libs/sdl-mixer"
-DEPEND="${RDEPEND}
- app-arch/unzip"
+DEPEND="${RDEPEND}"
+BDEPEND="app-arch/unzip"
-S=${WORKDIR}/tbt/src
+PATCHES=(
+ "${FILESDIR}"/${P}-gentoo.patch
+)
src_prepare() {
- cd ..
+ cd .. || die
+
edos2unix $(find src -type f) config.xml
- epatch "${FILESDIR}"/${P}-gentoo.patch
+
+ default
+
sed -i \
- -e "/^TBTHOME/ s:/.*:${GAMES_DATADIR}/tbt:" \
+ -e "/^TBTHOME/ s:/.*:/usr/share/tbt:" \
src/Makefile || die
sed -i \
-e "/tbt.ico/ s:\"\./:TBTHOME \"/:" \
src/Main.cpp || die
sed -i \
- -e "s:TBTHOME \"/config.xml:\"${GAMES_SYSCONFDIR}/tbt/config.xml:g" \
+ -e "s:TBTHOME \"/config.xml:\"/etc/tbt/config.xml:g" \
src/global.h || die
}
+src_configure() {
+ tc-export CXX
+}
+
src_install() {
- dogamesbin tbt
- dodir "${GAMES_DATADIR}/tbt"
- cp -r ../data ../tbt.ico "${D}${GAMES_DATADIR}/tbt" || die
- insinto "${GAMES_SYSCONFDIR}/tbt"
+ dobin tbt
+
+ dodir /usr/share/tbt
+ cp -r ../data ../tbt.ico "${ED}"/usr/share/tbt || die
+
+ insinto /etc/tbt
doins ../config.xml
+
newicon ../data/images/panel/turn.png ${PN}.png
make_desktop_entry tbt "Tow Bowl Tactics"
- prepgamesdirs
}