summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-arcade/aop
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-arcade/aop')
-rw-r--r--games-arcade/aop/Manifest1
-rw-r--r--games-arcade/aop/aop-0.6.ebuild33
-rw-r--r--games-arcade/aop/files/aop-0.6-as-needed.patch9
-rw-r--r--games-arcade/aop/metadata.xml5
4 files changed, 48 insertions, 0 deletions
diff --git a/games-arcade/aop/Manifest b/games-arcade/aop/Manifest
new file mode 100644
index 000000000000..5371e7509995
--- /dev/null
+++ b/games-arcade/aop/Manifest
@@ -0,0 +1 @@
+DIST aop-0.6.tar.gz 11811 SHA256 68a8b6b8f08216b31895d536f7dc4beb137a787fd17096da2d46fd863497f65a SHA512 0ce37647a0832b17e23df409633952f902e02666fa536cc4393a35bf91b245a501feeb4f14fd16d1a1d5c4f39682dad18a8e671e107e96cf5ba9c89965f8a77c WHIRLPOOL 8c8c358e465bd667fe9ac95573da1746f0267cb4be8f3d35919c097bf58051e52eebf9626aa48de3ecbe92e164b79f88d02d93f98a9fc7980bca19224eedbb9f
diff --git a/games-arcade/aop/aop-0.6.ebuild b/games-arcade/aop/aop-0.6.ebuild
new file mode 100644
index 000000000000..d4368231ec85
--- /dev/null
+++ b/games-arcade/aop/aop-0.6.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils games
+
+DESCRIPTION="Ambassador of Pain is a curses based game with only 64 lines of code"
+HOMEPAGE="http://raffi.at/view/code/aop"
+SRC_URI="http://www.raffi.at/code/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc ppc64 ~sparc x86 ~x86-fbsd"
+IUSE=""
+
+RDEPEND="sys-libs/ncurses"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_prepare() {
+ sed -i \
+ -e "s#/usr/local/share#${GAMES_DATADIR}#" \
+ aop.c || die
+ epatch "${FILESDIR}"/${P}-as-needed.patch
+}
+
+src_install() {
+ dogamesbin aop
+ insinto "${GAMES_DATADIR}/${PN}"
+ doins aop-level-*.txt
+ prepgamesdirs
+}
diff --git a/games-arcade/aop/files/aop-0.6-as-needed.patch b/games-arcade/aop/files/aop-0.6-as-needed.patch
new file mode 100644
index 000000000000..5d70e2b01af4
--- /dev/null
+++ b/games-arcade/aop/files/aop-0.6-as-needed.patch
@@ -0,0 +1,9 @@
+--- Makefile.old 2009-01-30 17:00:58.000000000 +0100
++++ Makefile 2009-01-30 17:01:15.000000000 +0100
+@@ -1,5 +1,5 @@
+
+-LDFLAGS = -lncurses
++LDLIBS := $(shell pkg-config ncurses --libs)
+
+ aop: aop.c
+
diff --git a/games-arcade/aop/metadata.xml b/games-arcade/aop/metadata.xml
new file mode 100644
index 000000000000..d3c2cc926f0b
--- /dev/null
+++ b/games-arcade/aop/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>games</herd>
+</pkgmetadata>