summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-04-19 09:01:21 +0100
committerSam James <sam@gentoo.org>2021-04-19 20:10:50 +0100
commitfa9bf912bcc06bc50a54bdb77f200c5e040b068d (patch)
treebe0441792871cd1e88444dcef96a23d35bb3955c /games-arcade/aop
parentdev-util/wiggle: repsect PKG_CONFIG (diff)
downloadgentoo-fa9bf912bcc06bc50a54bdb77f200c5e040b068d.tar.gz
gentoo-fa9bf912bcc06bc50a54bdb77f200c5e040b068d.tar.bz2
gentoo-fa9bf912bcc06bc50a54bdb77f200c5e040b068d.zip
games-arcade/aop: respect PKG_CONFIG
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'games-arcade/aop')
-rw-r--r--games-arcade/aop/aop-0.6-r2.ebuild6
-rw-r--r--games-arcade/aop/files/aop-0.6-as-needed.patch6
2 files changed, 8 insertions, 4 deletions
diff --git a/games-arcade/aop/aop-0.6-r2.ebuild b/games-arcade/aop/aop-0.6-r2.ebuild
index d0849e3b9401..8cc1d56adb23 100644
--- a/games-arcade/aop/aop-0.6-r2.ebuild
+++ b/games-arcade/aop/aop-0.6-r2.ebuild
@@ -3,6 +3,8 @@
EAPI=7
+inherit toolchain-funcs
+
DESCRIPTION="Ambassador of Pain is a curses based game with only 64 lines of code"
HOMEPAGE="http://raffi.at/view/code/aop"
SRC_URI="http://www.raffi.at/code/${PN}/${P}.tar.gz"
@@ -22,6 +24,8 @@ PATCHES=(
src_prepare() {
default
+ tc-export PKG_CONFIG
+
sed -i \
-e "s#/usr/local/share#/usr/share/${PN}#" \
aop.c || die
@@ -30,7 +34,7 @@ src_prepare() {
src_install() {
dobin aop
- insinto "/usr/share/${PN}"
+ insinto /usr/share/${PN}
doins aop-level-*.txt
einstalldocs
diff --git a/games-arcade/aop/files/aop-0.6-as-needed.patch b/games-arcade/aop/files/aop-0.6-as-needed.patch
index f172919553b4..85934f30b062 100644
--- a/games-arcade/aop/files/aop-0.6-as-needed.patch
+++ b/games-arcade/aop/files/aop-0.6-as-needed.patch
@@ -1,9 +1,9 @@
---- a/Makefile.old 2009-01-30 17:00:58.000000000 +0100
-+++ b/Makefile 2009-01-30 17:01:15.000000000 +0100
+--- a/Makefile
++++ b/Makefile
@@ -1,5 +1,5 @@
-LDFLAGS = -lncurses
-+LDLIBS := $(shell pkg-config ncurses --libs)
++LDLIBS := $(shell ${PKG_CONFIG} ncurses --libs)
aop: aop.c