summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-arcade/balloonchase
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-arcade/balloonchase')
-rw-r--r--games-arcade/balloonchase/Manifest1
-rw-r--r--games-arcade/balloonchase/balloonchase-0.9.6.ebuild36
-rw-r--r--games-arcade/balloonchase/files/0.9.6-gentoo.patch183
-rw-r--r--games-arcade/balloonchase/metadata.xml5
4 files changed, 225 insertions, 0 deletions
diff --git a/games-arcade/balloonchase/Manifest b/games-arcade/balloonchase/Manifest
new file mode 100644
index 000000000000..591a10553eeb
--- /dev/null
+++ b/games-arcade/balloonchase/Manifest
@@ -0,0 +1 @@
+DIST balloonchase-0.9.6.tar.bz2 523085 SHA256 6bf3e3db80a9b38941cace397232e33c8f00597e32c0036abbe927590d04d86c SHA512 ab5617713c96187564926fd5ecbdbf5186f78c23cfb43b26b28b9d18e71330efd77700cf7cd02e04be7fd8e33f2d30bf59f64954135ac82802d1d839dc2e7767 WHIRLPOOL 2033b329a5529d5f2d995de99f4848419d85c942eedbaee307000b797253b5c3b96cb043dc79130b2e736737ce5d074f5aa11d7ff0a09663838e13c829066505
diff --git a/games-arcade/balloonchase/balloonchase-0.9.6.ebuild b/games-arcade/balloonchase/balloonchase-0.9.6.ebuild
new file mode 100644
index 000000000000..cfc96f81a0cd
--- /dev/null
+++ b/games-arcade/balloonchase/balloonchase-0.9.6.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+inherit eutils toolchain-funcs games
+
+DESCRIPTION="Fly a hot air balloon and try to blow the other player out of the screen"
+HOMEPAGE="http://koti.mbnet.fi/makegho/c/bchase/"
+SRC_URI="http://koti.mbnet.fi/makegho/c/bchase/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~ppc ~sparc x86"
+IUSE=""
+
+DEPEND="media-libs/libsdl"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PV}-gentoo.patch
+ sed -i "s:g++:$(tc-getCXX):" Makefile || die "sed failed"
+ sed -i \
+ -e "s:GENTOODIR:${GAMES_DATADIR}/${PN}:" src/main.c \
+ || die 'sed failed'
+}
+
+src_install() {
+ dogamesbin ${PN}
+ insinto "${GAMES_DATADIR}"/${PN}
+ doins -r images
+ newicon images/kp2b.bmp ${PN}.bmp
+ make_desktop_entry ${PN} "Balloon Chase" /usr/share/pixmaps/${PN}.bmp
+ dodoc README
+ prepgamesdirs
+}
diff --git a/games-arcade/balloonchase/files/0.9.6-gentoo.patch b/games-arcade/balloonchase/files/0.9.6-gentoo.patch
new file mode 100644
index 000000000000..55e978850bbe
--- /dev/null
+++ b/games-arcade/balloonchase/files/0.9.6-gentoo.patch
@@ -0,0 +1,183 @@
+--- Makefile
++++ Makefile
+@@ -1,4 +1,3 @@
+-LDFLAGS= -lSDL -lpthread -s
+ CFLAGS= -Wall # -DDEBUG
+ PKG_BCDIR=balloonchase-`cat src/ver`
+ PKG_BCVER=`cat src/ver`
+@@ -9,8 +8,8 @@
+ clean:
+ rm balloonchase src/*.o
+ main: src/main.c
+- g++ -c -o src/main.o `sdl-config --cflags` src/main.c
+- g++ -o balloonchase src/main.o `sdl-config --libs`
++ g++ $(CXXFLAGS) -c -o src/main.o `sdl-config --cflags` src/main.c
++ g++ $(LDFLAGS) -o balloonchase src/main.o `sdl-config --libs`
+ pkg:
+ @echo $(PKG_BCVERSION) >VERSION
+ rm balloonchase src/*.o
+--- src/main.c
++++ src/main.c
+@@ -333,47 +333,47 @@
+
+ int InitImages()
+ {
+- back = SDL_LoadBMP("images/back.bmp");
++ back = SDL_LoadBMP("GENTOODIR/images/back.bmp");
+
+- num3 = SDL_LoadBMP("images/num3.bmp");
++ num3 = SDL_LoadBMP("GENTOODIR/images/num3.bmp");
+ SDL_SetColorKey(num3, SDL_SRCCOLORKEY, SDL_MapRGB(num3->format, 0xFF, 0xFF, 0xFF));
+- num2 = SDL_LoadBMP("images/num2.bmp");
++ num2 = SDL_LoadBMP("GENTOODIR/images/num2.bmp");
+ SDL_SetColorKey(num2, SDL_SRCCOLORKEY, SDL_MapRGB(num2->format, 0xFF, 0xFF, 0xFF));
+- num1 = SDL_LoadBMP("images/num1.bmp");
++ num1 = SDL_LoadBMP("GENTOODIR/images/num1.bmp");
+ SDL_SetColorKey(num1, SDL_SRCCOLORKEY, SDL_MapRGB(num1->format, 0xFF, 0xFF, 0xFF));
+- num0 = SDL_LoadBMP("images/num0.bmp");
++ num0 = SDL_LoadBMP("GENTOODIR/images/num0.bmp");
+ SDL_SetColorKey(num0, SDL_SRCCOLORKEY, SDL_MapRGB(num0->format, 0xFF, 0xFF, 0xFF));
+- numv = SDL_LoadBMP("images/num-.bmp");
++ numv = SDL_LoadBMP("GENTOODIR/images/num-.bmp");
+ SDL_SetColorKey(numv, SDL_SRCCOLORKEY, SDL_MapRGB(numv->format, 0xFF, 0xFF, 0xFF));
+
+- menu = SDL_LoadBMP("images/menu.bmp");
+- menu_onoff = SDL_LoadBMP("images/menu_onoff.bmp");
++ menu = SDL_LoadBMP("GENTOODIR/images/menu.bmp");
++ menu_onoff = SDL_LoadBMP("GENTOODIR/images/menu_onoff.bmp");
+
+
+-// arrow[0] = SDL_LoadBMP("images/down.bmp");
++// arrow[0] = SDL_LoadBMP("GENTOODIR/images/down.bmp");
+ // SDL_SetColorKey(arrow[0], SDL_SRCCOLORKEY, SDL_MapRGB(arrow[0]->format, 0x00, 0x00, 0x00));
+-// arrow[1] = SDL_LoadBMP("images/down.bmp");
++// arrow[1] = SDL_LoadBMP("GENTOODIR/images/down.bmp");
+ // SDL_SetColorKey(arrow[1], SDL_SRCCOLORKEY, SDL_MapRGB(arrow[1]->format, 0x00, 0x00, 0x00));
+
+- kp1 = SDL_LoadBMP("images/kp1.bmp");
++ kp1 = SDL_LoadBMP("GENTOODIR/images/kp1.bmp");
+ SDL_SetColorKey(kp1, SDL_SRCCOLORKEY, SDL_MapRGB(kp1->format, 0xFF, 0xFF, 0xFF));
+- kp1b = SDL_LoadBMP("images/kp1b.bmp");
++ kp1b = SDL_LoadBMP("GENTOODIR/images/kp1b.bmp");
+ SDL_SetColorKey(kp1b, SDL_SRCCOLORKEY, SDL_MapRGB(kp1b->format, 0xFF, 0xFF, 0xFF));
+
+- kp2 = SDL_LoadBMP("images/kp2.bmp");
++ kp2 = SDL_LoadBMP("GENTOODIR/images/kp2.bmp");
+ SDL_SetColorKey(kp2, SDL_SRCCOLORKEY, SDL_MapRGB(kp2->format, 0xFF, 0xFF, 0xFF));
+- kp2b = SDL_LoadBMP("images/kp2b.bmp");
++ kp2b = SDL_LoadBMP("GENTOODIR/images/kp2b.bmp");
+ SDL_SetColorKey(kp2b, SDL_SRCCOLORKEY, SDL_MapRGB(kp2b->format, 0xFF, 0xFF, 0xFF));
+
+- font2 = SDL_LoadBMP("images/font.bmp");
++ font2 = SDL_LoadBMP("GENTOODIR/images/font.bmp");
+ font = SDL_CreateRGBSurface(SDL_SWSURFACE, 1288, 100, 32, 0xFF000000, 0x00FF0000, 0x0000FF00, 0x000000FF);
+ SDL_SetColorKey(font, SDL_SRCCOLORKEY, SDL_MapRGB(font->format, 0x00, 0x00, 0x00));
+ DrawIMG (font, font2, 0, 0);
+
+- blobtrox = SDL_LoadBMP("images/blobtrox.bmp");
++ blobtrox = SDL_LoadBMP("GENTOODIR/images/blobtrox.bmp");
+ //SDL_SetColorKey(blobtrox, SDL_SRCCOLORKEY, SDL_MapRGB(blobtrox->format, 0x01, 0x01, 0x01));
+
+- balloonchase = SDL_LoadBMP("images/balloonchase.bmp");
++ balloonchase = SDL_LoadBMP("GENTOODIR/images/balloonchase.bmp");
+
+ TMP = SDL_CreateRGBSurface(SDL_SWSURFACE, 259, 200, 32, 0xFF000000, 0x00FF0000, 0x0000FF00, 0x000000FF);
+ blursurface = SDL_CreateRGBSurface(SDL_SWSURFACE, 640, 480, 32, 0x00000000, 0x00000000, 0x00000000, 0x00000000);
+@@ -578,7 +578,7 @@
+
+ void createdat(int winsneed, int option_wave_effect)
+ {
+- FILE *OPTFILE=fopen ("balloonchase.dat", "w+");
++ FILE *OPTFILE=fopen (".balloonchaserc", "w+");
+ char datmsg[60];
+ sprintf (datmsg, "Balloon Chase settings file -- Do not edit manually!");
+ char tmp2;
+@@ -588,52 +588,32 @@
+ }
+ fputc (winsneed, OPTFILE);
+ fputc (option_wave_effect+2, OPTFILE);
+- fprintf (stderr, "Saved configuration to balloonchase.dat\n");
++ fprintf (stderr, "Saved configuration to .balloonchaserc\n");
+ fclose (OPTFILE);
+ }
+
+ void checkfiles()
+ {
+- char found=0;
+- #ifdef WIN32
+- WIN32_FIND_DATA fileinfo;
+- BOOL rc = 0;
+- HANDLE hFile;
+- hFile = FindFirstFile("*", &fileinfo);
+- while(rc)
+- {
+- rc = FindNextFile(hFile, &fileinfo);
+- if (strcmp (fileinfo.cFileName, "balloonchase.dat")==0)
+- {
+- fprintf(stderr, "Found balloonchase.dat\n");
+- found = 1;
+- _findclose(hFile);
+- #endif
+- #ifndef WIN32
+- struct dirent *filelist[255];
+- int i=0;
+- int j=0;
+ DIR *dp;
+- dp=opendir("./");
+- int filenum=0;
+- while( filelist[filenum]=readdir(dp) )
+- filenum++;
+- closedir(dp);
+- if (filenum>=2)
+- for (i=0;i<filenum;i++)
+- {
+- if (strcmp(filelist[i]->d_name,"balloonchase.dat")==0)
+- {
+- fprintf (stderr, "Found balloonchase.dat\n");
+- found=1;
+- }
++
++ if (getenv("HOME")) {
++ chdir(getenv("HOME"));
++ }
++ if ((dp = opendir("./"))) {
++ struct dirent *f;
++
++ while(f=readdir(dp)) {
++ if (strcmp(f->d_name, ".balloonchaserc") == 0) {
++ fprintf (stderr, "Found .balloonchaserc\n");
++ closedir(dp);
++ return;
+ }
+- #endif
+- if (found==0)
+- {
+- fprintf (stderr, "Balloonchase.dat not found!\nCreating new...\n");
+- if (found==0) createdat(2, 1);
+ }
++ closedir(dp);
++ fprintf (stderr,
++ "Balloonchase.dat not found!\nCreating new...\n");
++ createdat(2, 1);
++ }
+ }
+
+ Uint32 rgb(Uint8 r, Uint8 g, Uint8 b)
+@@ -1257,7 +1237,7 @@
+ SDL_WM_SetCaption ("Balloon Chase", 0);
+ checkfiles();
+
+- FILE *OPTFILE=fopen ("balloonchase.dat", "r");
++ FILE *OPTFILE=fopen (".balloonchaserc", "r");
+ char datmsg[60];
+ char varmistus[60];
+
+@@ -1275,7 +1255,7 @@
+ {
+ winsneeded=fgetc(OPTFILE);
+ option_wave_effect=fgetc(OPTFILE)-2;
+- fprintf (stderr, "Successfully loaded balloonchase.dat\n");
++ fprintf (stderr, "Successfully loaded .balloonchaserc\n");
+ }
+ else
+ {
diff --git a/games-arcade/balloonchase/metadata.xml b/games-arcade/balloonchase/metadata.xml
new file mode 100644
index 000000000000..d3c2cc926f0b
--- /dev/null
+++ b/games-arcade/balloonchase/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>games</herd>
+</pkgmetadata>