summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-arcade/batrachians/files/batrachians-0.1.6-makefile.patch
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-arcade/batrachians/files/batrachians-0.1.6-makefile.patch')
-rw-r--r--games-arcade/batrachians/files/batrachians-0.1.6-makefile.patch35
1 files changed, 35 insertions, 0 deletions
diff --git a/games-arcade/batrachians/files/batrachians-0.1.6-makefile.patch b/games-arcade/batrachians/files/batrachians-0.1.6-makefile.patch
new file mode 100644
index 000000000000..f01fdfb0da8d
--- /dev/null
+++ b/games-arcade/batrachians/files/batrachians-0.1.6-makefile.patch
@@ -0,0 +1,35 @@
+diff -ru batrachians-0.1.6.orig/src/Makefile.am batrachians-0.1.6/src/Makefile.am
+--- batrachians-0.1.6.orig/src/Makefile.am 2011-04-18 21:25:53.000000000 -0400
++++ batrachians-0.1.6/src/Makefile.am 2014-10-27 23:19:58.292260669 -0400
+@@ -20,7 +20,7 @@
+ -DPACKAGE_FULL_NAME_EN=\"$(PACKAGE_FULL_NAME_EN)\" \
+ -DPKGSOUNDDIR=\"$(pkgsounddir)\"
+
+-pkgsounddir = $(datadir)/sounds/$(PACKAGE)
++pkgsounddir = $(datadir)/$(PACKAGE)/sounds
+ pkgsound_DATA = \
+ sounds/game-starts.wav \
+ sounds/game-ends.wav \
+@@ -29,18 +29,18 @@
+ sounds/frog-jumps.wav \
+ sounds/tongue-out.wav
+
+-desktopentrydir = $(datadir)/applications
++desktopentrydir =/usr/share/applications
+ desktopentry_DATA = $(PACKAGE).desktop
+
+-pixmapdir = $(datadir)/pixmaps
++pixmapdir =/usr/share/icons/hicolor/48x48/apps/
+ pixmap_DATA = images/$(PACKAGE).png
+
+
+ check: all
+ if HAVE_GETOPT_LONG
+ test "`./$(PACKAGE) --version`" = "$(PACKAGE) $(VERSION)"
+- ./$(PACKAGE) --version >& /dev/null
+- ./$(PACKAGE) --help >& /dev/null
++ ./$(PACKAGE) --version > /dev/null 2>&1
++ ./$(PACKAGE) --help > /dev/null 2>&1
+ endif
+
+