summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2020-01-03 20:34:09 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2020-01-04 10:37:21 +0100
commit7b39c6e5c4db51c5f45bb47a3e38d0da17ef95af (patch)
treee0665a5ce5c6e08888f9f76d783748602c5b92c8 /games-arcade/commandergenius
parentwww-client/epiphany: bump to 3.32.6 (diff)
downloadgentoo-7b39c6e5c4db51c5f45bb47a3e38d0da17ef95af.tar.gz
gentoo-7b39c6e5c4db51c5f45bb47a3e38d0da17ef95af.tar.bz2
gentoo-7b39c6e5c4db51c5f45bb47a3e38d0da17ef95af.zip
*/*: Switch games proj to cmake.eclass
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'games-arcade/commandergenius')
-rw-r--r--games-arcade/commandergenius/commandergenius-2.3.3.ebuild6
1 files changed, 3 insertions, 3 deletions
diff --git a/games-arcade/commandergenius/commandergenius-2.3.3.ebuild b/games-arcade/commandergenius/commandergenius-2.3.3.ebuild
index e2625339eed6..9aabfe025211 100644
--- a/games-arcade/commandergenius/commandergenius-2.3.3.ebuild
+++ b/games-arcade/commandergenius/commandergenius-2.3.3.ebuild
@@ -5,7 +5,7 @@ EAPI=7
PYTHON_COMPAT=( python3_{5,6,7} )
-inherit cmake-utils desktop python-single-r1 xdg-utils
+inherit cmake desktop python-single-r1 xdg-utils
MY_PN="Commander-Genius"
MY_P="${MY_PN}-v${PV}"
@@ -58,11 +58,11 @@ src_configure() {
-DBUILD_SHARED_LIBS=OFF
)
- cmake-utils_src_configure
+ cmake_src_configure
}
src_install() {
- cmake-utils_src_install
+ cmake_src_install
# The normal executable name is weird.
dosym CGeniusExe /usr/bin/${PN}