summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2018-04-22 11:13:57 +0200
committerPacho Ramos <pacho@gentoo.org>2018-04-22 11:13:57 +0200
commita698fd284b0e253d68032d48ddb83b70b4adb91a (patch)
treeb9d647fa9086862a961d16e43f0cf6bf01e02994 /games-arcade/late
parentdev-python/enable: Fix gcc5 patch (#599738 by Philippe Trottier) (diff)
downloadgentoo-a698fd284b0e253d68032d48ddb83b70b4adb91a.tar.gz
gentoo-a698fd284b0e253d68032d48ddb83b70b4adb91a.tar.bz2
gentoo-a698fd284b0e253d68032d48ddb83b70b4adb91a.zip
games-arcade/late: Stop using games.eclass
Package-Manager: Portage-2.3.31, Repoman-2.3.9
Diffstat (limited to 'games-arcade/late')
-rw-r--r--games-arcade/late/files/late-0.1.0-gcc43.patch4
-rw-r--r--games-arcade/late/late-0.1.0-r1.ebuild35
2 files changed, 37 insertions, 2 deletions
diff --git a/games-arcade/late/files/late-0.1.0-gcc43.patch b/games-arcade/late/files/late-0.1.0-gcc43.patch
index bce26464cf04..8cfead22a27d 100644
--- a/games-arcade/late/files/late-0.1.0-gcc43.patch
+++ b/games-arcade/late/files/late-0.1.0-gcc43.patch
@@ -1,5 +1,5 @@
---- src/init.cpp
-+++ src/init.cpp
+--- a/src/init.cpp
++++ b/src/init.cpp
@@ -26,6 +26,8 @@
#include "scorescreen.h"
#include <fstream>
diff --git a/games-arcade/late/late-0.1.0-r1.ebuild b/games-arcade/late/late-0.1.0-r1.ebuild
new file mode 100644
index 000000000000..dd837c5f6220
--- /dev/null
+++ b/games-arcade/late/late-0.1.0-r1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit desktop
+
+DESCRIPTION="A game, similar to Barrack by Ambrosia Software"
+HOMEPAGE="http://late.sourceforge.net/"
+SRC_URI="mirror://sourceforge/late/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="media-libs/libsdl[video]
+ media-libs/sdl-image[jpeg]"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ default
+ eapply \
+ "${FILESDIR}"/${P}-gcc43.patch \
+ "${FILESDIR}"/${P}-gcc46.patch
+ sed -i \
+ -e "/chown/d" \
+ Makefile.in \
+ || die "sed failed"
+}
+
+src_install () {
+ default
+ newicon graphics/latebg2.jpg ${PN}.jpg
+ make_desktop_entry late Late /usr/share/pixmaps/${PN}.jpg
+}