summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-arcade/netris
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-arcade/netris')
-rw-r--r--games-arcade/netris/Manifest2
-rw-r--r--games-arcade/netris/metadata.xml5
-rw-r--r--games-arcade/netris/netris-0.52.ebuild67
3 files changed, 74 insertions, 0 deletions
diff --git a/games-arcade/netris/Manifest b/games-arcade/netris/Manifest
new file mode 100644
index 000000000000..3400d8f65b11
--- /dev/null
+++ b/games-arcade/netris/Manifest
@@ -0,0 +1,2 @@
+DIST netris-0.52.tar.gz 33135 SHA256 8bc770ebb2c3ead1611ca7a1a2f3d833e169536c78d53b3fcf49381164ee9706 SHA512 842ad8602394dee929c3c4ba222f9f5ffe628e52348c3faf7c9098bbd5b0b0279fffc7927320f8ee8a5102537c995a8ed605d851f1cd32e4bd8976a7889c84e1 WHIRLPOOL 7bf0356b85107ec871c15afa9e680596e890e22cfb6ba9e72b4487af84c01b5aa4519a0d218c8736f80edaa8ba0c488d49aca07dd67c75dad91054de3a7ea7aa
+DIST netris_0.52-7.diff.gz 11586 SHA256 6b4d157768d075d9fedb9318f2583add253af994bab8ed6fe25b65b5086c8cc5 SHA512 2d2fe28dbf886107fa27f631e30534aab8afe027b5a41da3761ff39a16d65d7cf6ff5bf409708d55740638df75e334b5fb1ae4c5304616731fb6498d2cc00ca9 WHIRLPOOL ff1ff01f25b12f809f72682e48f539dd55df8e370151effe1222898b12239abf972e97ff1e8cc768beedf3c085b96e6c3540a309f08205245811ae1b52b51ac2
diff --git a/games-arcade/netris/metadata.xml b/games-arcade/netris/metadata.xml
new file mode 100644
index 000000000000..d3c2cc926f0b
--- /dev/null
+++ b/games-arcade/netris/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>games</herd>
+</pkgmetadata>
diff --git a/games-arcade/netris/netris-0.52.ebuild b/games-arcade/netris/netris-0.52.ebuild
new file mode 100644
index 000000000000..5e0d8019bfcc
--- /dev/null
+++ b/games-arcade/netris/netris-0.52.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils games
+
+DEB_VER=7
+DESCRIPTION='Classic networked version of T*tris'
+HOMEPAGE='http://www.netris.org/'
+SRC_URI="ftp://ftp.netris.org/pub/netris/${P}.tar.gz
+ mirror://debian/pool/main/n/netris/netris_${PV}-${DEB_VER}.diff.gz"
+
+LICENSE='GPL-2'
+SLOT='0'
+KEYWORDS='amd64 ~mips ppc ~sparc x86 ~x86-fbsd'
+IUSE=''
+
+DEPEND='sys-libs/ncurses'
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ epatch "${WORKDIR}"/netris_${PV}-${DEB_VER}.diff
+ # bug #185332
+ sed -i \
+ -e '/sys\/time/ i\
+#include <sys/types.h> \
+#include <time.h>
+' \
+ -e '/netint2/ s/short/int16_t/' \
+ -e '/netint4/ s/long/int32_t/' \
+ netris.h \
+ || die 'sed failed'
+ sed -i \
+ -e '/curses\.h/ a\
+#include <term.h>
+' \
+ curses.c \
+ || die 'sed failed'
+ sed -i \
+ -e 's/volatile //g' \
+ -e '/Be more forgiving/d' \
+ -e 's/static myRandSeed/static int myRandSeed/' \
+ util.c \
+ || die 'sed failed'
+ sed -i \
+ -e 's/\(long pauseTimeLeft\)/\1 = 0/' \
+ game.c \
+ || die 'sed failed'
+ sed -i \
+ -e '/^CC/d' \
+ -e '/^COPT/d' \
+ -e '/^CFLAGS/d' \
+ -e 's/(LFLAGS)/(LDFLAGS) $(LFLAGS)/' \
+ Configure \
+ || die 'sed failed'
+}
+
+src_configure() {
+ bash ./Configure -O || die 'Configure failed'
+}
+
+src_install() {
+ dogamesbin netris sr
+ dodoc FAQ README robot_desc
+ prepgamesdirs
+}