summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-arcade/notpacman
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-arcade/notpacman')
-rw-r--r--games-arcade/notpacman/Manifest2
-rw-r--r--games-arcade/notpacman/metadata.xml13
-rw-r--r--games-arcade/notpacman/notpacman-1.0.4.ebuild52
3 files changed, 67 insertions, 0 deletions
diff --git a/games-arcade/notpacman/Manifest b/games-arcade/notpacman/Manifest
new file mode 100644
index 000000000000..4223046be9c3
--- /dev/null
+++ b/games-arcade/notpacman/Manifest
@@ -0,0 +1,2 @@
+DIST notpacman-1.0.4.zip 439775 SHA256 9ec13bb0737d69c8954a5012ab3c84917f8db6285f74605c6faac7592a7ef2fc SHA512 c64d74cad972c22fe7674b55c0155fcd6e0176c580f53645a0cef7ae1e2c3453807f13fd9bbc9992cdc1176bc1687800f957ef5c11034a2ffe0774ec0118a863 WHIRLPOOL 94fa5c3a865b3fea736a41cb9000522cfdd36cfd63703f0a811743bd9fdc082f98c85407b9248a3e066f06c34cd44b15a7c2ace0956fc72a4541b933169b1457
+DIST notpacman.png 1556 SHA256 79e3d47abc08c4e07d70a410fd841fbccf0289443fa5f6f09d74ec674ff86d3a SHA512 38fca81429255a5857476cbbcccb188ae4cc7fae4c044b45d82206ffcb41da5737e20135be2a6ab15ec1ff5faa74e5208a33a4966b3e9e99293c0ccb276b0c1b WHIRLPOOL bd0a91e87c410d1901f6839df88e5a70ca6c193cda842fff878f055a384cbc667b2e688b2e3c7015cdfd862545dda1a38e55e91aa2d23e9ca9b8b67eb780dbf3
diff --git a/games-arcade/notpacman/metadata.xml b/games-arcade/notpacman/metadata.xml
new file mode 100644
index 000000000000..7b7fcbaee9c0
--- /dev/null
+++ b/games-arcade/notpacman/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>games</herd>
+ <longdescription lang="en">
+ Ever wondered how Pacman would be like with physics? No? Well, it's
+ revolutionary. This mashup of "Not" and "Pacman" puts The Pac and
+ the Ghosts in a in a Pacworld cage, at mercy of gravity and the
+ level's shape, controlled solely by you. Ghosts still don't like
+ you very much, so you should be careful to make Pacman avoid them.
+ </longdescription>
+</pkgmetadata>
+
diff --git a/games-arcade/notpacman/notpacman-1.0.4.ebuild b/games-arcade/notpacman/notpacman-1.0.4.ebuild
new file mode 100644
index 000000000000..74e7eeed3c04
--- /dev/null
+++ b/games-arcade/notpacman/notpacman-1.0.4.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils gnome2-utils games
+
+DESCRIPTION="A mashup of \"Not\" and \"Pacman\""
+HOMEPAGE="http://stabyourself.net/notpacman/"
+SRC_URI="http://stabyourself.net/dl.php?file=notpacman-1004/notpacman-linux.zip -> ${P}.zip
+ http://dev.gentoo.org/~hasufell/distfiles/${PN}.png"
+
+LICENSE="WTFPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+
+LVSLOT="0.7"
+RDEPEND=">=games-engines/love-0.7.2:${LVSLOT}
+ media-libs/devil[png]"
+DEPEND="app-arch/unzip"
+
+S=${WORKDIR}
+
+src_install() {
+ local dir=${GAMES_DATADIR}/love/${PN}
+
+ exeinto "${dir}"
+ newexe not_pacman.love ${PN}.love
+
+ dodoc README
+
+ doicon -s 32 "${DISTDIR}"/${PN}.png
+ games_make_wrapper ${PN} "love-${LVSLOT} ${PN}.love" "${dir}"
+ make_desktop_entry ${PN}
+
+ prepgamesdirs
+}
+
+pkg_preinst() {
+ games_pkg_preinst
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}