summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Sokolov <sokolov@google.com>2020-09-13 23:42:01 +0100
committerJames Le Cuirot <chewi@gentoo.org>2020-09-21 22:14:13 +0100
commita229976dffa2a8ae85c872761b15918a04280ddc (patch)
tree85b4c359940a503525fe479dc11a5740fc7eee1e /games-arcade/pacmanarena
parentgames-emulation/gngeo: drop 0.8-r1 (diff)
downloadgentoo-a229976dffa2a8ae85c872761b15918a04280ddc.tar.gz
gentoo-a229976dffa2a8ae85c872761b15918a04280ddc.tar.bz2
gentoo-a229976dffa2a8ae85c872761b15918a04280ddc.zip
games-arcade/pacmanarena: fix build on gcc 10
Fix removing of -g from CFLAGS Closes: https://bugs.gentoo.org/708066 Package-Manager: Portage-3.0.4, Repoman-2.3.23 Signed-off-by: Alexey Sokolov <alexey+gentoo@asokolov.org> Signed-off-by: James Le Cuirot <chewi@gentoo.org>
Diffstat (limited to 'games-arcade/pacmanarena')
-rw-r--r--games-arcade/pacmanarena/files/pacmanarena-0.15-fnocommon.patch15
-rw-r--r--games-arcade/pacmanarena/pacmanarena-0.15-r2.ebuild59
2 files changed, 74 insertions, 0 deletions
diff --git a/games-arcade/pacmanarena/files/pacmanarena-0.15-fnocommon.patch b/games-arcade/pacmanarena/files/pacmanarena-0.15-fnocommon.patch
new file mode 100644
index 000000000000..103976f4c48e
--- /dev/null
+++ b/games-arcade/pacmanarena/files/pacmanarena-0.15-fnocommon.patch
@@ -0,0 +1,15 @@
+Fix build. https://bugs.gentoo.org/708066#c8
+
+diff --git a/include/input.h b/include/input.h
+index 08a4aee..491c01d 100644
+--- a/include/input.h
++++ b/include/input.h
+@@ -22,8 +22,6 @@
+ #ifndef _INPUT_H
+ #define _INPUT_H
+
+-char *keyboard_map;
+-
+ void input_reset(void);
+ void input_update(void);
+ int input_kstate(int ksym);
diff --git a/games-arcade/pacmanarena/pacmanarena-0.15-r2.ebuild b/games-arcade/pacmanarena/pacmanarena-0.15-r2.ebuild
new file mode 100644
index 000000000000..4b16585222e4
--- /dev/null
+++ b/games-arcade/pacmanarena/pacmanarena-0.15-r2.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools desktop
+
+DESCRIPTION="3D Pacman clone with a few surprises. Rockets, bombs and explosions abound"
+HOMEPAGE="http://pacmanarena.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/pacman-arena-${PV}.tar.bz2
+ mirror://sourceforge/${PN}/pacman-data-0.0.zip"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~x86"
+
+RDEPEND="
+ media-libs/libsdl[sound]
+ media-libs/sdl-mixer[vorbis]
+ media-libs/sdl-net
+ virtual/glu
+ virtual/opengl
+"
+DEPEND="${RDEPEND}"
+BDEPEND="app-arch/unzip"
+
+S="${WORKDIR}/pacman"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-underlink.patch
+ "${FILESDIR}"/${P}-fnocommon.patch
+)
+
+src_unpack() {
+ unpack pacman-arena-${PV}.tar.bz2
+ cd "${S}"
+ unpack pacman-data-0.0.zip
+}
+
+src_prepare() {
+ default
+ sed -i \
+ -e "/^CFLAGS/ s:pacman:${PN}:" \
+ -e '1i CC=@CC@' \
+ Makefile.in || die
+ sed -i \
+ -e '/CFLAGS/s:-g::' \
+ configure.ac || die
+ eautoreconf
+}
+
+src_install() {
+ newbin pacman ${PN}
+ insinto /usr/share/${PN}
+ doins -r gfx sfx
+ newicon gfx/pacman_arena1.tga ${PN}.tga
+ make_desktop_entry ${PN} "Pacman Arena" /usr/share/pixmaps/${PN}.tga
+ einstalldocs
+}