summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2018-04-23 20:08:58 +0200
committerPacho Ramos <pacho@gentoo.org>2018-04-23 21:16:57 +0200
commitddc6e8b317b5cebd0c03736b5cc3825c0a6f34ca (patch)
treed51f18b134c6f640ff6c386fb86ea113b52e7100 /games-arcade/penguin-command/penguin-command-1.6.11-r1.ebuild
parentgames-arcade/pacmanarena: Stop using games.eclass (diff)
downloadgentoo-ddc6e8b317b5cebd0c03736b5cc3825c0a6f34ca.tar.gz
gentoo-ddc6e8b317b5cebd0c03736b5cc3825c0a6f34ca.tar.bz2
gentoo-ddc6e8b317b5cebd0c03736b5cc3825c0a6f34ca.zip
games-arcade/penguin-command: Stop using games.eclass
Package-Manager: Portage-2.3.31, Repoman-2.3.9
Diffstat (limited to 'games-arcade/penguin-command/penguin-command-1.6.11-r1.ebuild')
-rw-r--r--games-arcade/penguin-command/penguin-command-1.6.11-r1.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/games-arcade/penguin-command/penguin-command-1.6.11-r1.ebuild b/games-arcade/penguin-command/penguin-command-1.6.11-r1.ebuild
new file mode 100644
index 000000000000..c442fae3b31e
--- /dev/null
+++ b/games-arcade/penguin-command/penguin-command-1.6.11-r1.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit desktop
+
+DESCRIPTION="A clone of the classic Missile Command game"
+HOMEPAGE="http://www.linux-games.com/penguin-command/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="media-libs/libsdl[sound,joystick,video]
+ media-libs/sdl-mixer[mod]
+ media-libs/sdl-image[jpeg,png]"
+RDEPEND="${DEPEND}"
+
+src_install() {
+ default
+ newicon data/gfx/icon.xpm ${PN}.xpm
+ make_desktop_entry ${PN} "Penguin Command" ${PN}
+}