summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-arcade/pydance/pydance-1.1.0.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-arcade/pydance/pydance-1.1.0.ebuild')
-rw-r--r--games-arcade/pydance/pydance-1.1.0.ebuild54
1 files changed, 54 insertions, 0 deletions
diff --git a/games-arcade/pydance/pydance-1.1.0.ebuild b/games-arcade/pydance/pydance-1.1.0.ebuild
new file mode 100644
index 000000000000..01dbc05779d7
--- /dev/null
+++ b/games-arcade/pydance/pydance-1.1.0.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils games
+
+DESCRIPTION="a DDR clone for linux written in Python"
+HOMEPAGE="http://www.icculus.org/pyddr/"
+SRC_URI="http://www.icculus.org/pyddr/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+IUSE=""
+
+DEPEND="dev-python/pygame
+ media-libs/libvorbis
+ media-libs/sdl-mixer"
+RDEPEND=${DEPEND}
+PDEPEND="games-arcade/pydance-songs"
+
+src_prepare() {
+ sed -i \
+ -e "s:1\.0\.1:1.0.2:" \
+ -e "s:/etc/:${GAMES_SYSCONFDIR}/:" \
+ pydance.py constants.py docs/man/pydance.6 || die
+}
+
+src_install() {
+ local dir=${GAMES_DATADIR}/${PN}
+
+ insinto "${dir}"
+ doins *.py
+ cp -R CREDITS {sound,images,utils,themes} "${D}${dir}/" || die
+
+ insinto "${GAMES_SYSCONFDIR}"
+ newins pydance.posix.cfg pydance.cfg
+
+ games_make_wrapper pydance "python2 ./pydance.py" "${dir}"
+
+ dodoc BUGS CREDITS ChangeLog HACKING README TODO
+ dohtml -r docs/manual.html docs/images
+ doman docs/man/*
+ prepgamesdirs
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+ echo
+ elog "If you want to use a DDR pad with pyDance,"
+ elog "all you need to do is emerge the games-arcade/ddrmat kernel module."
+ echo
+}