summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-arcade/rockdodger
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-arcade/rockdodger')
-rw-r--r--games-arcade/rockdodger/Manifest1
-rw-r--r--games-arcade/rockdodger/files/0.6.0a-sec.patch20
-rw-r--r--games-arcade/rockdodger/files/rockdodger-0.6.0a-gcc41.patch18
-rw-r--r--games-arcade/rockdodger/files/rockdodger-0.6.0a-underlink.patch11
-rw-r--r--games-arcade/rockdodger/metadata.xml8
-rw-r--r--games-arcade/rockdodger/rockdodger-0.6.0a-r1.ebuild58
6 files changed, 116 insertions, 0 deletions
diff --git a/games-arcade/rockdodger/Manifest b/games-arcade/rockdodger/Manifest
new file mode 100644
index 000000000000..64cc1d45668c
--- /dev/null
+++ b/games-arcade/rockdodger/Manifest
@@ -0,0 +1 @@
+DIST rockdodger-0.6.0a.tar.gz 410223 SHA256 3b6676676d47c1a4d6074c6b811f7a0449f1e4774b2200127c9096c489def17e SHA512 d517cc844df21e8772b13d0226841a64bede0cc2f5461fb83d313f49cd99192dcf6af4597e3d1f3e1c60f578437e355ce665e0288415da803a503fb12d8462eb WHIRLPOOL 4961a6d39c0c4102b54d3e9cd938448cea5c2ba41a562f38d557d6e11b5c3d638bb67f21c48414ede3b7d4f8406161c3aef5165a03de8ae006e7cc9138ad842f
diff --git a/games-arcade/rockdodger/files/0.6.0a-sec.patch b/games-arcade/rockdodger/files/0.6.0a-sec.patch
new file mode 100644
index 000000000000..e870cf2d2974
--- /dev/null
+++ b/games-arcade/rockdodger/files/0.6.0a-sec.patch
@@ -0,0 +1,20 @@
+--- main.c.old 2002-11-17 23:56:12.000000000 +0100
++++ main.c 2004-10-29 22:32:00.000000000 +0200
+@@ -459,7 +459,7 @@ FILE *hs_fopen(char *mode) {/*{{{*/
+ else {
+ char s[1024];
+ umask(0177);
+- sprintf(s,"%s/.rockdodger_high",getenv("HOME"));
++ snprintf(s,1024,"%s/.rockdodger_high",getenv("HOME"));
+ if (f=fopen(s,mode)) {
+ umask(mask);
+ return f;
+@@ -478,7 +478,7 @@ void read_high_score_table() {/*{{{*/
+ for (i=0; i<8; i++) {
+ char s[1024];
+ int highscore;
+- if (fscanf (f, "%d %[^\n]", &highscore, s)!=2)
++ if (fscanf (f, "%d %1023[^\n]", &highscore, s)!=2)
+ break;
+ if (high[i].allocated)
+ free(high[i].name);
diff --git a/games-arcade/rockdodger/files/rockdodger-0.6.0a-gcc41.patch b/games-arcade/rockdodger/files/rockdodger-0.6.0a-gcc41.patch
new file mode 100644
index 000000000000..59e01bba17c3
--- /dev/null
+++ b/games-arcade/rockdodger/files/rockdodger-0.6.0a-gcc41.patch
@@ -0,0 +1,18 @@
+--- main.c.old 2006-04-24 16:16:13.000000000 +0200
++++ main.c 2006-04-24 16:16:21.000000000 +0200
+@@ -206,7 +206,6 @@
+ struct bangdots bdot[MAX_BANG_DOTS], *bdotptr=bdot;
+ struct spacedot sdot[MAX_SPACE_DOTS];
+
+-struct greeble greeb[MAX_GREEBLES];
+ struct greeble {
+ int active;
+ float x,y; // When landed, these represent an offset from the host rock
+@@ -214,6 +213,7 @@
+ int landed;
+ int boredom; // Goes up while landed
+ };
++struct greeble greeb[MAX_GREEBLES];
+ // }}}
+
+ void init_greeblies() {
diff --git a/games-arcade/rockdodger/files/rockdodger-0.6.0a-underlink.patch b/games-arcade/rockdodger/files/rockdodger-0.6.0a-underlink.patch
new file mode 100644
index 000000000000..87cd8453476c
--- /dev/null
+++ b/games-arcade/rockdodger/files/rockdodger-0.6.0a-underlink.patch
@@ -0,0 +1,11 @@
+--- Makefile.old 2011-06-20 21:25:56.788323912 +0200
++++ Makefile 2011-06-20 21:26:11.970287694 +0200
+@@ -27,7 +27,7 @@
+ #SOUNDLIBRARIES=
+ SOUNDLIBRARIES=-lSDL_mixer
+
+-LIBRARIES=`sdl-config --libs` -lSDL_image $(SOUNDLIBRARIES)
++LIBRARIES=`sdl-config --libs` -lSDL_image $(SOUNDLIBRARIES) -lm
+
+ all: $(EXENAME)
+
diff --git a/games-arcade/rockdodger/metadata.xml b/games-arcade/rockdodger/metadata.xml
new file mode 100644
index 000000000000..bf5eb2351781
--- /dev/null
+++ b/games-arcade/rockdodger/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>games</herd>
+ <upstream>
+ <remote-id type="sourceforge">spacerocks</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/games-arcade/rockdodger/rockdodger-0.6.0a-r1.ebuild b/games-arcade/rockdodger/rockdodger-0.6.0a-r1.ebuild
new file mode 100644
index 000000000000..205a51a4b335
--- /dev/null
+++ b/games-arcade/rockdodger/rockdodger-0.6.0a-r1.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils games
+
+DESCRIPTION="Dodge the rocks for as long as possible until you die"
+HOMEPAGE="http://spacerocks.sourceforge.net/"
+SRC_URI="mirror://sourceforge/spacerocks/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc x86 ~x86-fbsd"
+IUSE=""
+
+DEPEND="media-libs/libsdl[sound,video]
+ media-libs/sdl-image[png]
+ media-libs/sdl-mixer"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ # Modify highscores & data directory and add our CFLAGS to the Makefile
+ sed -i \
+ -e "s:\./data:${GAMES_DATADIR}/${PN}:" \
+ -e "s:/usr/share/rockdodger/\.highscore:${GAMES_STATEDIR}/rockdodger.scores:" \
+ -e 's:umask(0111):umask(0117):' main.c \
+ || die " sed main.c failed"
+ sed -i \
+ -e "s:-g:${CFLAGS}:" \
+ -e 's:cc:$(CC):' \
+ -e '/-o/s:\$+:$(LDFLAGS) $+:' \
+ Makefile \
+ || die "sed Makefile failed"
+
+ # The 512 chunksize makes the music skip
+ sed -i \
+ -e "s:512:1024:" sound.c \
+ || die "sed sound.c failed"
+ epatch \
+ "${FILESDIR}"/${PV}-sec.patch \
+ "${FILESDIR}"/${P}-gcc41.patch \
+ "${FILESDIR}"/${P}-underlink.patch
+}
+
+src_install() {
+ dogamesbin ${PN}
+ insinto "${GAMES_DATADIR}"/${PN}
+ doins data/*
+
+ newicon spacerocks.xpm ${PN}.xpm
+ make_desktop_entry ${PN} "Rock Dodger" ${PN}
+
+ dodir "${GAMES_STATEDIR}"
+ touch "${D}/${GAMES_STATEDIR}"/${PN}.scores
+ fperms 660 "${GAMES_STATEDIR}"/${PN}.scores
+ prepgamesdirs
+}