summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2015-11-21 22:53:33 -0500
committerMichael Sterrett <mr_bones_@gentoo.org>2015-11-21 22:53:33 -0500
commit0837fbac306fbd984027c9cd8c9969009dd34f10 (patch)
tree77390d9c57a8d42d1ba58fe082cb5cdaef26777c /games-arcade/sable
parentuse epatch to apply patch (diff)
downloadgentoo-0837fbac306fbd984027c9cd8c9969009dd34f10.tar.gz
gentoo-0837fbac306fbd984027c9cd8c9969009dd34f10.tar.bz2
gentoo-0837fbac306fbd984027c9cd8c9969009dd34f10.zip
use epatch to apply patch; update HOMEPAGE; better deps
Package-Manager: portage-2.2.20.1
Diffstat (limited to 'games-arcade/sable')
-rw-r--r--games-arcade/sable/sable-1.0.ebuild13
1 files changed, 8 insertions, 5 deletions
diff --git a/games-arcade/sable/sable-1.0.ebuild b/games-arcade/sable/sable-1.0.ebuild
index c2eded71b95f..6f9001fdcabe 100644
--- a/games-arcade/sable/sable-1.0.ebuild
+++ b/games-arcade/sable/sable-1.0.ebuild
@@ -6,8 +6,8 @@ EAPI=5
inherit eutils games
DESCRIPTION="A frantic 3D space shooter"
-HOMEPAGE="http://www.stanford.edu/~mcmartin/sable/"
-SRC_URI="http://www.stanford.edu/~mcmartin/${PN}/${P}-src.tgz
+HOMEPAGE="http://jeuxlibres.net/showgame/sable.html"
+SRC_URI="mirror://gentoo/${P}-src.tgz
mirror://gentoo/${PN}.png"
LICENSE="GPL-2"
@@ -16,13 +16,16 @@ KEYWORDS="amd64 x86"
IUSE=""
DEPEND="virtual/opengl
- media-libs/libsdl
+ media-libs/libsdl[joystick,opengl,sound,video]
media-libs/sdl-image[png]
media-libs/sdl-mixer"
-RDEPEND="${DEPEND}"
+RDEPEND=${DEPEND}
+
S=${WORKDIR}/${PN}
-PATCHES=( "${FILESDIR}"/${P}-gentoo.patch )
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-gentoo.patch
+}
src_compile() {
emake INSTALL_RESDIR="${GAMES_DATADIR}"