summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2018-04-24 19:56:56 +0200
committerPacho Ramos <pacho@gentoo.org>2018-04-24 21:26:04 +0200
commit0d7da14089b36aa3f97273b7095ffa43dd5ed8c8 (patch)
treedc80073c59f5975116a5486e90351f784a57e1e8 /games-arcade/slimevolley
parentgames-arcade/sdlsasteroids: Drop old (diff)
downloadgentoo-0d7da14089b36aa3f97273b7095ffa43dd5ed8c8.tar.gz
gentoo-0d7da14089b36aa3f97273b7095ffa43dd5ed8c8.tar.bz2
gentoo-0d7da14089b36aa3f97273b7095ffa43dd5ed8c8.zip
games-arcade/slimevolley: Stop using games.eclass
Package-Manager: Portage-2.3.31, Repoman-2.3.9
Diffstat (limited to 'games-arcade/slimevolley')
-rw-r--r--games-arcade/slimevolley/files/slimevolley-2.4.2-underlink.patch4
-rw-r--r--games-arcade/slimevolley/slimevolley-2.4.2-r1.ebuild44
2 files changed, 46 insertions, 2 deletions
diff --git a/games-arcade/slimevolley/files/slimevolley-2.4.2-underlink.patch b/games-arcade/slimevolley/files/slimevolley-2.4.2-underlink.patch
index 7ca362c7bc63..1aad45f6cf5f 100644
--- a/games-arcade/slimevolley/files/slimevolley-2.4.2-underlink.patch
+++ b/games-arcade/slimevolley/files/slimevolley-2.4.2-underlink.patch
@@ -1,5 +1,5 @@
---- CMakeLists.txt.old 2011-06-20 20:42:26.545500925 +0200
-+++ CMakeLists.txt 2011-06-20 20:42:34.407999223 +0200
+--- a/CMakeLists.txt.old 2011-06-20 20:42:26.545500925 +0200
++++ b/CMakeLists.txt 2011-06-20 20:42:34.407999223 +0200
@@ -42,6 +42,7 @@
${SDL_LIBRARY}
${SDLTTF_LIBRARY}
diff --git a/games-arcade/slimevolley/slimevolley-2.4.2-r1.ebuild b/games-arcade/slimevolley/slimevolley-2.4.2-r1.ebuild
new file mode 100644
index 000000000000..e4a8fe67dfab
--- /dev/null
+++ b/games-arcade/slimevolley/slimevolley-2.4.2-r1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit cmake-utils
+
+DESCRIPTION="A simple volleyball game"
+HOMEPAGE="http://slime.tuxfamily.org/index.php"
+SRC_URI="http://downloads.tuxfamily.org/slime/v242/${PN}_${PV}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="net"
+
+RDEPEND="
+ media-libs/libsdl[X,sound,video]
+ media-libs/sdl-ttf
+ media-libs/sdl-image[png]
+ net? ( media-libs/sdl-net )
+ virtual/libintl
+"
+DEPEND="${RDEPEND}
+ sys-devel/gettext
+"
+
+DOCS="docs/README docs/TODO"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-nodatalocal.patch
+ "${FILESDIR}"/${P}-underlink.patch
+)
+
+S="${WORKDIR}/${PN}"
+
+src_configure() {
+ local mycmakeargs=(
+ "-DCMAKE_VERBOSE_MAKEFILE=TRUE"
+ "-DCMAKE_INSTALL_PREFIX=/usr"
+ "-DDATA_DIR=/usr/share/slimevolley"
+ $(use net && echo "-DNO_NET=0" || echo "-DNO_NET=1")
+ )
+ cmake-utils_src_configure
+}