summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-arcade/triplexinvaders
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-arcade/triplexinvaders')
-rw-r--r--games-arcade/triplexinvaders/Manifest1
-rw-r--r--games-arcade/triplexinvaders/files/triplexinvaders-1.08-gentoo.patch62
-rw-r--r--games-arcade/triplexinvaders/metadata.xml9
-rw-r--r--games-arcade/triplexinvaders/triplexinvaders-1.08.ebuild40
4 files changed, 112 insertions, 0 deletions
diff --git a/games-arcade/triplexinvaders/Manifest b/games-arcade/triplexinvaders/Manifest
new file mode 100644
index 000000000000..e4372cbb26f7
--- /dev/null
+++ b/games-arcade/triplexinvaders/Manifest
@@ -0,0 +1 @@
+DIST triplexinvaders-1.08.zip 354188 SHA256 ead4f0b139e487e742902e184ce146469d12ecc345d363147395c484cc8c4bfc SHA512 c763cf650046612152c9305a2067f52feedfeac5f16dd292031a184563f40efc9d95553bc01d59c5c6382394fd2a2d3fe971471cf775fe64c3b1f3c4842a0780 WHIRLPOOL 7c693962d0d0604d7b813ec051b3ecca050ae3ca7a25f0dd1fe5f7c11add4260e2ee080ffc62fa751e17388ee677485486f3d9be650232440275c3e45d58d707
diff --git a/games-arcade/triplexinvaders/files/triplexinvaders-1.08-gentoo.patch b/games-arcade/triplexinvaders/files/triplexinvaders-1.08-gentoo.patch
new file mode 100644
index 000000000000..56f9c1a1596a
--- /dev/null
+++ b/games-arcade/triplexinvaders/files/triplexinvaders-1.08-gentoo.patch
@@ -0,0 +1,62 @@
+--- sound.py.old 2007-04-14 21:52:02.000000000 +0200
++++ sound.py 2007-04-14 21:52:27.000000000 +0200
+@@ -16,7 +16,7 @@
+
+
+ def reloadMusic():
+- pygame.mixer.music.load(os.path.join('sound', choice(music)))
++ pygame.mixer.music.load(os.path.join('@GENTOO_DATADIR@/sound', choice(music)))
+ pygame.mixer.music.set_endevent(ENDMUSIC)
+ pygame.mixer.music.play()
+
+@@ -24,7 +24,7 @@
+
+ def getSound(name, volume=0.4):
+ if name not in LoadedSounds:
+- sound = pygame.mixer.Sound(os.path.join('sound', '%s.ogg' % name))
++ sound = pygame.mixer.Sound(os.path.join('@GENTOO_DATADIR@/sound', '%s.ogg' % name))
+ sound.set_volume(volume)
+ LoadedSounds[name] = sound
+ return LoadedSounds[name]
+--- util.py.old 2007-04-14 21:56:30.000000000 +0200
++++ util.py 2007-04-14 21:56:48.000000000 +0200
+@@ -30,7 +30,7 @@
+ LoadedTextures = weakref.WeakValueDictionary()
+
+ def loadTexture(name):
+- filename = os.path.join('textures', '%s.png' % name)
++ filename = os.path.join('@GENTOO_DATADIR@/textures', '%s.png' % name)
+ textureSurface = pygame.image.load(filename)
+ textureData = pygame.image.tostring(textureSurface, "RGBA", True)
+ texid = glGenTextures(1)
+@@ -47,7 +47,7 @@
+
+ def getModel(name):
+ if name not in LoadedModels:
+- model = wavefront.load(os.path.join('models', '%s.obj' % name), name)
++ model = wavefront.load(os.path.join('@GENTOO_DATADIR@/models', '%s.obj' % name), name)
+ LoadedModels[name] = model
+ return LoadedModels[name]
+
+--- hiscore.py.old 2007-04-14 22:04:04.000000000 +0200
++++ hiscore.py 2007-04-14 22:04:25.000000000 +0200
+@@ -5,7 +5,7 @@
+ # copy the highscores to the user's homedir
+ highscorefile = os.path.join(configdir, 'hiscores')
+ if not os.path.exists(highscorefile):
+- oldpath = 'hiscores'
++ oldpath = '@GENTOO_DATADIR@/hiscores'
+ shutil.copy(oldpath, highscorefile)
+
+ def write(score, name):
+--- options.py.old 2007-04-14 22:05:23.000000000 +0200
++++ options.py 2007-04-14 22:05:42.000000000 +0200
+@@ -5,7 +5,7 @@
+ # copy the options to the user's homedir
+ optionfile = os.path.join(configdir, 'options.conf')
+ if not os.path.exists(optionfile):
+- oldpath = 'options.conf'
++ oldpath = '@GENTOO_DATADIR@/options.conf'
+ shutil.copy(oldpath, optionfile)
+
+ execfile(optionfile)
diff --git a/games-arcade/triplexinvaders/metadata.xml b/games-arcade/triplexinvaders/metadata.xml
new file mode 100644
index 000000000000..e60905ac4c14
--- /dev/null
+++ b/games-arcade/triplexinvaders/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>games</herd>
+ <longdescription lang="en">
+In Triplex Invaders, the player pilots a spaceship against a never ending horde
+of enemy ships. It has psychedelic 3d graphics (but 2d gameplay).
+</longdescription>
+</pkgmetadata>
diff --git a/games-arcade/triplexinvaders/triplexinvaders-1.08.ebuild b/games-arcade/triplexinvaders/triplexinvaders-1.08.ebuild
new file mode 100644
index 000000000000..6fdab3042115
--- /dev/null
+++ b/games-arcade/triplexinvaders/triplexinvaders-1.08.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils games
+
+DESCRIPTION="An Alien Invaders style game with 3d graphics"
+HOMEPAGE="http://triplexinvaders.infogami.com"
+SRC_URI="http://acm.jhu.edu/~arthur/invaders/${P}.zip"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+DEPEND="app-arch/unzip"
+RDEPEND="dev-python/pygame
+ dev-python/pyopengl"
+
+src_prepare() {
+ epatch "${FILESDIR}/${P}"-gentoo.patch
+ sed -i -e "s:@GENTOO_DATADIR@:${GAMES_DATADIR}/${PN}:" \
+ sound.py \
+ util.py \
+ hiscore.py \
+ options.py || die "sed failed"
+}
+
+src_install() {
+ local libdir=$(games_get_libdir)
+
+ insinto "${libdir}/${PN}"
+ doins -r *.py
+ insinto "${GAMES_DATADIR}/${PN}"
+ doins -r models sound options.conf hiscores
+ games_make_wrapper ${PN} "python ./invaders.py" "${libdir}/${PN}"
+ dodoc README.txt TODO.txt
+ prepgamesdirs
+}