summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-arcade/watermelons
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-arcade/watermelons')
-rw-r--r--games-arcade/watermelons/Manifest1
-rw-r--r--games-arcade/watermelons/metadata.xml5
-rw-r--r--games-arcade/watermelons/watermelons-1.1.1-r1.ebuild57
3 files changed, 63 insertions, 0 deletions
diff --git a/games-arcade/watermelons/Manifest b/games-arcade/watermelons/Manifest
new file mode 100644
index 000000000000..a2557c231673
--- /dev/null
+++ b/games-arcade/watermelons/Manifest
@@ -0,0 +1 @@
+DIST melons-1.1.1.tgz 318692 SHA256 7433004460bf97a055d7c4c28fc274eeda920f30d5441e76020a7b8db223a336 SHA512 50bb66de9806fb1bbe946ad5063e68d3327d6184b3e95230573f71053426ed877fc9762ef2b44e6964c9d7b8dc5081e9c3015885800dd6644a1dd88c9c5dc357 WHIRLPOOL 8f9c5ecb7591949deaa83a60a7334cec3822c7116a4d3a66c069bcacc523b3f9c708ba276845f4a11df1e5e6642e144cce1eb74976c4a96e0609396d1feb6b32
diff --git a/games-arcade/watermelons/metadata.xml b/games-arcade/watermelons/metadata.xml
new file mode 100644
index 000000000000..d3c2cc926f0b
--- /dev/null
+++ b/games-arcade/watermelons/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>games</herd>
+</pkgmetadata>
diff --git a/games-arcade/watermelons/watermelons-1.1.1-r1.ebuild b/games-arcade/watermelons/watermelons-1.1.1-r1.ebuild
new file mode 100644
index 000000000000..f0541d5e2026
--- /dev/null
+++ b/games-arcade/watermelons/watermelons-1.1.1-r1.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+inherit eutils python-single-r1 games
+
+MY_PN="melons"
+DESCRIPTION="A thrilling watermelon bouncing game"
+HOMEPAGE="http://www.imitationpickles.org/melons/index.html"
+SRC_URI="mirror://gentoo/${MY_PN}-${PV}.tgz"
+# No version upstream
+#SRC_URI="http://www.imitationpickles.org/${MY_PN}/${MY_PN}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86 ~x86-fbsd"
+IUSE=""
+
+DEPEND="dev-python/pygame[${PYTHON_USEDEP}]
+ ${PYTHON_DEPS}"
+RDEPEND=${DEPEND}
+REQUIRED_USE=${PYTHON_REQUIRED_USE}
+
+S=${WORKDIR}/${MY_PN}
+
+pkg_setup() {
+ python-single-r1_pkg_setup
+ games_pkg_setup
+}
+
+src_prepare() {
+ sed -i \
+ -e "s:melons.hs:${GAMES_STATEDIR}/${PN}/&:" \
+ main.py || die
+
+ cat <<-EOF > "${PN}" || die
+ #!/bin/bash
+ cd "${GAMES_DATADIR}/${PN}"
+ exec ${EPYTHON} main.py
+EOF
+}
+
+src_install() {
+ dogamesbin ${PN}
+ insinto "${GAMES_DATADIR}/${PN}"
+ doins -r data pgu const.py game.py main.py melon.py melons.py menu.py trampoline.py
+ python_optimize "${D}${GAMES_DATADIR}/${PN}"
+ dodoc *.txt
+ dodir "${GAMES_STATEDIR}/${PN}"
+ touch "${D}${GAMES_STATEDIR}"/${PN}/melons.hs
+ fperms 664 "${GAMES_STATEDIR}"/${PN}/melons.hs
+ newicon data/mellon0013.png "${PN}.png"
+ make_desktop_entry ${PN} Watermelons
+ prepgamesdirs
+}