summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-arcade/xbubble
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-arcade/xbubble')
-rw-r--r--games-arcade/xbubble/Manifest1
-rw-r--r--games-arcade/xbubble/files/xbubble-0.5.8-libpng14.patch13
-rw-r--r--games-arcade/xbubble/files/xbubble-0.5.8-locale.patch10
-rw-r--r--games-arcade/xbubble/files/xbubble-0.5.8-png15.patch20
-rw-r--r--games-arcade/xbubble/files/xbubble-0.5.8-xpaths.patch11
-rw-r--r--games-arcade/xbubble/metadata.xml5
-rw-r--r--games-arcade/xbubble/xbubble-0.5.8.ebuild48
7 files changed, 108 insertions, 0 deletions
diff --git a/games-arcade/xbubble/Manifest b/games-arcade/xbubble/Manifest
new file mode 100644
index 000000000000..fe0ad96b1266
--- /dev/null
+++ b/games-arcade/xbubble/Manifest
@@ -0,0 +1 @@
+DIST xbubble-0.5.8.tar.gz 5544359 SHA256 91fc805f661f5fdc3ddca4cfcfc06670b948f4f80f01333372368a0be4743025 SHA512 132052d8e57218a2991ce0a0383f69f8818deafbf56046acaa3bc1c8ed7f31e5fb6b9b045df11eb3eaf77a8347b16ad663bb0f727823995e5df6d3adfcb75df2 WHIRLPOOL 94e2457b113cf9a1e19cc2a18793b74da68375b49a3a9e37d713953e31717f717ba639641fa46c63b38eb53463da84bcee06f57dfd393a3e26fb46b686389db9
diff --git a/games-arcade/xbubble/files/xbubble-0.5.8-libpng14.patch b/games-arcade/xbubble/files/xbubble-0.5.8-libpng14.patch
new file mode 100644
index 000000000000..ad689e29d739
--- /dev/null
+++ b/games-arcade/xbubble/files/xbubble-0.5.8-libpng14.patch
@@ -0,0 +1,13 @@
+http://bugs.gentoo.org/show_bug.cgi?id=308731
+
+--- src/loadpng.c
++++ src/loadpng.c
+@@ -55,7 +55,7 @@ unsigned char * load_png_file( const cha
+ }
+ /* ensure that we opened a PNG file */
+ fread( header, 1, 8, fd );
+- if ( ! png_check_sig( header, 8 ) ) {
++ if ( png_sig_cmp( header, 0, 8 ) ) {
+ fclose(fd);
+ fprintf(stderr,_("File %s does not have a valid PNG signature.\n"), file);
+ return NULL;
diff --git a/games-arcade/xbubble/files/xbubble-0.5.8-locale.patch b/games-arcade/xbubble/files/xbubble-0.5.8-locale.patch
new file mode 100644
index 000000000000..a83d36fbd911
--- /dev/null
+++ b/games-arcade/xbubble/files/xbubble-0.5.8-locale.patch
@@ -0,0 +1,10 @@
+--- src/gettext.h.orig 2008-10-07 12:01:37.000000000 -0400
++++ src/gettext.h 2008-10-07 12:01:45.000000000 -0400
+@@ -24,6 +24,7 @@
+
+ /* Get declarations of GNU message catalog functions. */
+ # include <libintl.h>
++# include <locale.h>
+
+ #else
+
diff --git a/games-arcade/xbubble/files/xbubble-0.5.8-png15.patch b/games-arcade/xbubble/files/xbubble-0.5.8-png15.patch
new file mode 100644
index 000000000000..3a0a7d360efb
--- /dev/null
+++ b/games-arcade/xbubble/files/xbubble-0.5.8-png15.patch
@@ -0,0 +1,20 @@
+--- src/loadpng.c.old 2011-09-14 09:58:40.503566961 +0200
++++ src/loadpng.c 2011-09-14 10:03:39.708531447 +0200
+@@ -73,7 +73,7 @@
+ return NULL;
+ }
+ /* libpng does a longjmp here when it encounters an error */
+- if ( setjmp( png_ptr->jmpbuf ) ) {
++ if ( setjmp( png_jmpbuf(png_ptr) ) ) {
+ png_destroy_read_struct( &png_ptr, &info_ptr, NULL);
+ fclose(fd);
+ return NULL;
+@@ -95,7 +95,7 @@
+ png_set_gray_to_rgb(png_ptr);
+
+ /* detect alpha layer */
+- if (( info_ptr->color_type & PNG_COLOR_MASK_ALPHA )||
++ if (( png_get_color_type(png_ptr, info_ptr) & PNG_COLOR_MASK_ALPHA )||
+ ( png_get_valid( png_ptr, info_ptr, PNG_INFO_tRNS )))
+ *has_alpha = 1;
+ else
diff --git a/games-arcade/xbubble/files/xbubble-0.5.8-xpaths.patch b/games-arcade/xbubble/files/xbubble-0.5.8-xpaths.patch
new file mode 100644
index 000000000000..c3dfa83cb5e3
--- /dev/null
+++ b/games-arcade/xbubble/files/xbubble-0.5.8-xpaths.patch
@@ -0,0 +1,11 @@
+the x_libraries variable isnt always defined
+http://bugs.gentoo.org/92688
+
+--- configure
++++ configure
+@@ -4511,3 +4511,5 @@
+ fi
++if test x"$x_libraries" != x; then
+ LIBS="-L$x_libraries $LIBS"
++fi
+
diff --git a/games-arcade/xbubble/metadata.xml b/games-arcade/xbubble/metadata.xml
new file mode 100644
index 000000000000..d3c2cc926f0b
--- /dev/null
+++ b/games-arcade/xbubble/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>games</herd>
+</pkgmetadata>
diff --git a/games-arcade/xbubble/xbubble-0.5.8.ebuild b/games-arcade/xbubble/xbubble-0.5.8.ebuild
new file mode 100644
index 000000000000..2b3417679e45
--- /dev/null
+++ b/games-arcade/xbubble/xbubble-0.5.8.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils games
+
+DESCRIPTION="a Puzzle Bobble clone similar to Frozen-Bubble"
+HOMEPAGE="http://www.nongnu.org/xbubble/"
+SRC_URI="http://www.ibiblio.org/pub/mirrors/gnu/ftp/savannah/files/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 ppc x86"
+IUSE="nls"
+
+RDEPEND="x11-libs/libX11
+ x11-libs/libXt
+ media-libs/libpng:0
+ nls? ( virtual/libintl )"
+DEPEND="${RDEPEND}
+ nls? ( sys-devel/gettext )"
+DOCS=( AUTHORS ChangeLog NEWS NetworkProtocol README TODO )
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/${P}-xpaths.patch \
+ "${FILESDIR}"/${P}-locale.patch \
+ "${FILESDIR}"/${P}-libpng14.patch \
+ "${FILESDIR}"/${P}-png15.patch
+ sed -i \
+ -e '/^AM_CFLAGS/d' \
+ src/Makefile.in || die
+ sed -i \
+ -e '/^localedir/s:=.*:=/usr/share/locale:' \
+ configure po/Makefile.in.in || die
+}
+
+src_configure() {
+ egamesconf $(use_enable nls)
+}
+
+src_install() {
+ default
+ newicon data/themes/fancy/Bubble_black_DEAD_01.png ${PN}.png
+ make_desktop_entry ${PN} XBubble
+ prepgamesdirs
+}