summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2018-04-15 20:15:36 +0200
committerPacho Ramos <pacho@gentoo.org>2018-04-15 21:00:15 +0200
commit11c0d37ac3b5eb33fadafed63a8506214469ea79 (patch)
tree4653bad9996521f660e7efd7fc698ab4511fdb14 /games-arcade
parentgames-arcade/ceferino: Drop old (diff)
downloadgentoo-11c0d37ac3b5eb33fadafed63a8506214469ea79.tar.gz
gentoo-11c0d37ac3b5eb33fadafed63a8506214469ea79.tar.bz2
gentoo-11c0d37ac3b5eb33fadafed63a8506214469ea79.zip
games-arcade/circuslinux: Stop using games.eclass
Package-Manager: Portage-2.3.28, Repoman-2.3.9
Diffstat (limited to 'games-arcade')
-rw-r--r--games-arcade/circuslinux/circuslinux-1.0.3-r1.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/games-arcade/circuslinux/circuslinux-1.0.3-r1.ebuild b/games-arcade/circuslinux/circuslinux-1.0.3-r1.ebuild
new file mode 100644
index 000000000000..bc3c43f34833
--- /dev/null
+++ b/games-arcade/circuslinux/circuslinux-1.0.3-r1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit desktop
+
+DESCRIPTION="clone of the Atari 2600 game \"Circus Atari\""
+SRC_URI="ftp://ftp.sonic.net/pub/users/nbs/unix/x/circus-linux/${P}.tar.gz"
+HOMEPAGE="http://www.newbreedsoftware.com/circus-linux/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~x86"
+IUSE=""
+
+DEPEND="media-libs/libsdl
+ media-libs/sdl-image[png]
+ media-libs/sdl-mixer[mod]"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ default
+ sed -i \
+ -e "/^install-data-am/d" \
+ Makefile.in \
+ || die
+ sed -i \
+ -e 's/\$(pkgdatadir)/$(DESTDIR)&/' \
+ data/Makefile.in \
+ || die
+}
+
+src_install () {
+ default
+ newicon data/images/${PN}-icon.xpm ${PN}.xpm
+ make_desktop_entry ${PN} "Circus Linux!"
+}