summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2018-04-15 20:52:06 +0200
committerPacho Ramos <pacho@gentoo.org>2018-04-15 21:00:34 +0200
commit2150eae012c731a290997734475f37401c4344ab (patch)
treea9e8a198d1f3f8c360f3b70b3522da4a1d15b870 /games-arcade
parentgames-arcade/criticalmass: Drop old (diff)
downloadgentoo-2150eae012c731a290997734475f37401c4344ab.tar.gz
gentoo-2150eae012c731a290997734475f37401c4344ab.tar.bz2
gentoo-2150eae012c731a290997734475f37401c4344ab.zip
games-arcade/defendguin: Stop using games.eclass
Package-Manager: Portage-2.3.28, Repoman-2.3.9
Diffstat (limited to 'games-arcade')
-rw-r--r--games-arcade/defendguin/defendguin-0.0.12-r1.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/games-arcade/defendguin/defendguin-0.0.12-r1.ebuild b/games-arcade/defendguin/defendguin-0.0.12-r1.ebuild
new file mode 100644
index 000000000000..db692cd67f23
--- /dev/null
+++ b/games-arcade/defendguin/defendguin-0.0.12-r1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit desktop
+
+DESCRIPTION="A clone of the arcade game Defender, but with a Linux theme"
+HOMEPAGE="http://www.newbreedsoftware.com/defendguin/"
+SRC_URI="ftp://ftp.tuxpaint.org/unix/x/${PN}/src/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~x86-fbsd"
+IUSE=""
+
+DEPEND="media-libs/sdl-mixer[mod]
+ media-libs/libsdl[video]"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ default
+ sed -i \
+ -e "s:\$(DATA_PREFIX):/usr/share/${PN}/:" \
+ -e '/^CFLAGS=.*-O2/d' \
+ -e '/^CFLAGS=/s:=:+= $(LDFLAGS) :' \
+ Makefile \
+ || die
+ rm -f data/images/*.sh
+}
+
+src_install() {
+ dobin ${PN}
+ insinto /usr/share/${PN}
+ doins -r ./data/*
+
+ newicon data/images/ufo/ufo0.bmp ${PN}.bmp
+ make_desktop_entry ${PN} Defendguin /usr/share/pixmaps/${PN}.bmp
+
+ doman src/${PN}.6
+ dodoc docs/{AUTHORS,CHANGES,README,TODO}.txt
+}