summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2015-11-22 00:42:39 -0500
committerMichael Sterrett <mr_bones_@gentoo.org>2015-11-22 00:44:18 -0500
commit342c2d35d3b223c71c04b1af57e4d3eaedea203b (patch)
tree08a419093511127364038b79985ff97a8666cdb7 /games-arcade
parentdev-python/urllib3: Stable for HPPA (bug #549898). (diff)
downloadgentoo-342c2d35d3b223c71c04b1af57e4d3eaedea203b.tar.gz
gentoo-342c2d35d3b223c71c04b1af57e4d3eaedea203b.tar.bz2
gentoo-342c2d35d3b223c71c04b1af57e4d3eaedea203b.zip
use epatch to apply patch
Package-Manager: portage-2.2.20.1
Diffstat (limited to 'games-arcade')
-rw-r--r--games-arcade/asteroid/asteroid-1.1.ebuild12
1 files changed, 7 insertions, 5 deletions
diff --git a/games-arcade/asteroid/asteroid-1.1.ebuild b/games-arcade/asteroid/asteroid-1.1.ebuild
index 5e951998fcee..2ffbe944acf4 100644
--- a/games-arcade/asteroid/asteroid-1.1.ebuild
+++ b/games-arcade/asteroid/asteroid-1.1.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI=4
+EAPI=5
inherit eutils games
DESCRIPTION="A modern version of the arcade classic that uses OpenGL"
@@ -19,12 +19,14 @@ DEPEND="virtual/opengl
virtual/glu
media-libs/libsdl
media-libs/sdl-mixer"
-RDEPEND="${DEPEND}"
+RDEPEND=${DEPEND}
-PATCHES=( "${FILESDIR}"/${P}-include.patch )
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-include.patch
+}
src_install() {
- emake DESTDIR="${D}" install
- dodoc asteroid-{authors,changes,readme}.txt
+ DOCS="$(echo asteroid-{authors,changes,readme}.txt)" \
+ default
prepgamesdirs
}