summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2022-09-30 01:19:02 -0400
committerIonen Wolkens <ionen@gentoo.org>2022-09-30 06:30:33 -0400
commit66144432c2b91cf4e3f99f95c2385d0367d92e2a (patch)
tree944067bcedbcb96399accc1c1d40dc57d23e190d /games-arcade
parentgames-arcade/xboing: force gcc -E for imake's generation (diff)
downloadgentoo-66144432c2b91cf4e3f99f95c2385d0367d92e2a.tar.gz
gentoo-66144432c2b91cf4e3f99f95c2385d0367d92e2a.tar.bz2
gentoo-66144432c2b91cf4e3f99f95c2385d0367d92e2a.zip
games-arcade/xboing: fix build with clang16
Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'games-arcade')
-rw-r--r--games-arcade/xboing/files/xboing-2.4-clang16.patch37
-rw-r--r--games-arcade/xboing/xboing-2.4-r4.ebuild (renamed from games-arcade/xboing/xboing-2.4-r3.ebuild)6
2 files changed, 42 insertions, 1 deletions
diff --git a/games-arcade/xboing/files/xboing-2.4-clang16.patch b/games-arcade/xboing/files/xboing-2.4-clang16.patch
new file mode 100644
index 000000000000..72c632850de0
--- /dev/null
+++ b/games-arcade/xboing/files/xboing-2.4-clang16.patch
@@ -0,0 +1,37 @@
+Ideally would want to enable -DNeedFunctionPrototypes=1
+but it leads to more issues not handled here.
+
+https://bugs.gentoo.org/870412
+--- a/eyedude.c
++++ b/eyedude.c
+@@ -51,2 +51,3 @@
+ #include <stdio.h>
++#include <stdlib.h>
+ #include <math.h>
+--- a/include/intro.h
++++ b/include/intro.h
+@@ -84,2 +84,3 @@
+ void DrawIntroTitle(Display *display, Window window, int x, int y);
++void HandleBlink(Display *display, Window window);
+ #else
+@@ -92,2 +93,3 @@
+ void DoIntroTitle();
++void HandleBlink();
+ #endif
+--- a/include/level.h
++++ b/include/level.h
+@@ -74,2 +74,3 @@
+ void DisplayLevelInfo(Display *display, Window window, u_long level);
++void DisplayLevelNumber(Display *display, Window window, u_long level);
+ void CheckGameRules(Display *display, Window window);
+@@ -113,2 +114,3 @@
+ void DisplayLevelInfo();
++void DisplayLevelNumber();
+ void CheckGameRules();
+--- a/main.c
++++ b/main.c
+@@ -231,3 +231,3 @@
+ {
+- static oldx = 0;
++ static int oldx = 0;
+ int x, y;
diff --git a/games-arcade/xboing/xboing-2.4-r3.ebuild b/games-arcade/xboing/xboing-2.4-r4.ebuild
index 40988b31ee7c..c92635a96e67 100644
--- a/games-arcade/xboing/xboing-2.4-r3.ebuild
+++ b/games-arcade/xboing/xboing-2.4-r4.ebuild
@@ -17,8 +17,11 @@ KEYWORDS="amd64 ~x86"
RDEPEND="
acct-group/gamestat
+ x11-libs/libX11
x11-libs/libXpm"
-DEPEND="${RDEPEND}"
+DEPEND="
+ ${RDEPEND}
+ x11-base/xorg-proto"
BDEPEND="
app-text/rman
sys-devel/gcc
@@ -29,6 +32,7 @@ PATCHES=(
"${WORKDIR}"/${P}-debian.patch
"${FILESDIR}"/${P}-buffer.patch
"${FILESDIR}"/${P}-sleep.patch
+ "${FILESDIR}"/${P}-clang16.patch
)
src_prepare() {