summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2015-12-18 04:33:15 -0500
committerMichael Sterrett <mr_bones_@gentoo.org>2015-12-18 04:33:15 -0500
commit78f8b903d7b1e36ce3f85fc7ba21fe324b126b2d (patch)
tree267b5c1dbe8820b2f45f6dcbca8deb05beb4a75f /games-arcade
parentEAPI=5; minor tidying (diff)
downloadgentoo-78f8b903d7b1e36ce3f85fc7ba21fe324b126b2d.tar.gz
gentoo-78f8b903d7b1e36ce3f85fc7ba21fe324b126b2d.tar.bz2
gentoo-78f8b903d7b1e36ce3f85fc7ba21fe324b126b2d.zip
EAPI=5; minor tidying
Package-Manager: portage-2.2.24
Diffstat (limited to 'games-arcade')
-rw-r--r--games-arcade/briquolo/briquolo-0.5.7.ebuild18
1 files changed, 7 insertions, 11 deletions
diff --git a/games-arcade/briquolo/briquolo-0.5.7.ebuild b/games-arcade/briquolo/briquolo-0.5.7.ebuild
index 2690ebcf66e1..efd0d53f629d 100644
--- a/games-arcade/briquolo/briquolo-0.5.7.ebuild
+++ b/games-arcade/briquolo/briquolo-0.5.7.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI=4
+EAPI=5
inherit eutils games
DESCRIPTION="Breakout with 3D representation based on OpenGL"
@@ -16,10 +16,10 @@ IUSE="nls"
RDEPEND="virtual/opengl
virtual/glu
- media-libs/libsdl
+ media-libs/libsdl[joystick,sound,video]
media-libs/sdl-mixer
media-libs/sdl-ttf
- media-libs/libpng
+ media-libs/libpng:0
nls? ( virtual/libintl )"
DEPEND="${RDEPEND}
nls? ( sys-devel/gettext )"
@@ -30,22 +30,18 @@ src_prepare() {
# no thanks we'll take care of it.
sed -i \
-e '/^SUBDIRS/s/desktop//' \
- Makefile.in \
- || die "sed Makefile.in failed"
+ Makefile.in || die
sed -i \
-e "/CXXFLAGS/s:-O3:${CXXFLAGS}:" \
-e 's:=.*share/locale:=/usr/share/locale:' \
- configure \
- || die "sed configure failed"
+ configure || die
sed -i \
-e 's:$(datadir)/locale:/usr/share/locale:' \
- po/Makefile.in.in \
- || die "sed Makefile.in.in failed"
+ po/Makefile.in.in || die
}
src_configure() {
- egamesconf \
- $(use_enable nls)
+ egamesconf $(use_enable nls)
}
src_install() {