summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter-Levine <plevine457@gmail.com>2017-04-07 16:51:24 -0400
committerDavid Seifert <soap@gentoo.org>2017-04-16 20:57:38 +0200
commitb581f310212bf0254f21f4de3aa5b3c368ec9389 (patch)
treeb399f7c3fa4f2bb4f4ec89860328880aac9c69e0 /games-arcade
parentgames-action/clanbomber: Fix building with GCC-6 (bug #613332) (diff)
downloadgentoo-b581f310212bf0254f21f4de3aa5b3c368ec9389.tar.gz
gentoo-b581f310212bf0254f21f4de3aa5b3c368ec9389.tar.bz2
gentoo-b581f310212bf0254f21f4de3aa5b3c368ec9389.zip
games-arcade/retrobattle: Fix building with GCC-6 (bug #614398)
Package-Manager: Portage-2.3.5, Repoman-2.3.2 Closes: https://github.com/gentoo/gentoo/pull/4384
Diffstat (limited to 'games-arcade')
-rw-r--r--games-arcade/retrobattle/files/retrobattle-1.0.0-gcc6.patch22
-rw-r--r--games-arcade/retrobattle/retrobattle-1.0.0.ebuild4
2 files changed, 24 insertions, 2 deletions
diff --git a/games-arcade/retrobattle/files/retrobattle-1.0.0-gcc6.patch b/games-arcade/retrobattle/files/retrobattle-1.0.0-gcc6.patch
new file mode 100644
index 000000000000..19974e36ea56
--- /dev/null
+++ b/games-arcade/retrobattle/files/retrobattle-1.0.0-gcc6.patch
@@ -0,0 +1,22 @@
+--- a/src/GameLogic.h
++++ b/src/GameLogic.h
+@@ -52,8 +52,8 @@
+ /* Fixed interval time-based animation */
+ static const int maximumFrameRate = 60;
+ static const int minimumFrameRate = 15;
+- static const float updateInterval = 1.0 / maximumFrameRate;
+- static const float maxCyclesPerFrame = maximumFrameRate / minimumFrameRate;
++ static const float updateInterval;
++ static const float maxCyclesPerFrame;
+
+ float lastFrameTime;
+ float cyclesLeftOver;
+--- a/src/GameLogic.cc
++++ b/src/GameLogic.cc
+@@ -206,3 +206,6 @@
+ {
+ sprintf(buf, "%s/data/gfx/%s", datadir, file);
+ }
++
++const float GameLogic::updateInterval = 1.0 / maximumFrameRate;
++const float GameLogic::maxCyclesPerFrame = maximumFrameRate / minimumFrameRate;
diff --git a/games-arcade/retrobattle/retrobattle-1.0.0.ebuild b/games-arcade/retrobattle/retrobattle-1.0.0.ebuild
index ad00348dd599..eed0252ed1e1 100644
--- a/games-arcade/retrobattle/retrobattle-1.0.0.ebuild
+++ b/games-arcade/retrobattle/retrobattle-1.0.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=5
@@ -22,7 +22,7 @@ RDEPEND="${DEPEND}"
S=${WORKDIR}/${MY_P}/src
src_prepare() {
- epatch "${FILESDIR}"/${P}-{build,sound}.patch
+ epatch "${FILESDIR}"/${P}-{build,sound,gcc6}.patch
}
src_install() {