summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2015-12-18 04:28:51 -0500
committerMichael Sterrett <mr_bones_@gentoo.org>2015-12-18 04:28:51 -0500
commitf42835e9495c7230f90bff4cdf48b1dad7061a9f (patch)
tree5cf497cbc925033a01eb959300af1a6a243cd568 /games-arcade
parentEAPI=5; minor tidying (diff)
downloadgentoo-f42835e9495c7230f90bff4cdf48b1dad7061a9f.tar.gz
gentoo-f42835e9495c7230f90bff4cdf48b1dad7061a9f.tar.bz2
gentoo-f42835e9495c7230f90bff4cdf48b1dad7061a9f.zip
EAPI=5; minor tidying
Package-Manager: portage-2.2.24
Diffstat (limited to 'games-arcade')
-rw-r--r--games-arcade/balloonchase/balloonchase-0.9.6.ebuild11
1 files changed, 5 insertions, 6 deletions
diff --git a/games-arcade/balloonchase/balloonchase-0.9.6.ebuild b/games-arcade/balloonchase/balloonchase-0.9.6.ebuild
index cfc96f81a0cd..8f0f79d32742 100644
--- a/games-arcade/balloonchase/balloonchase-0.9.6.ebuild
+++ b/games-arcade/balloonchase/balloonchase-0.9.6.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI=4
+EAPI=5
inherit eutils toolchain-funcs games
DESCRIPTION="Fly a hot air balloon and try to blow the other player out of the screen"
@@ -14,15 +14,14 @@ SLOT="0"
KEYWORDS="amd64 ~ppc ~sparc x86"
IUSE=""
-DEPEND="media-libs/libsdl"
-RDEPEND="${DEPEND}"
+DEPEND="media-libs/libsdl[video]"
+RDEPEND=${DEPEND}
src_prepare() {
epatch "${FILESDIR}"/${PV}-gentoo.patch
- sed -i "s:g++:$(tc-getCXX):" Makefile || die "sed failed"
+ sed -i "s:g++:$(tc-getCXX):" Makefile || die
sed -i \
- -e "s:GENTOODIR:${GAMES_DATADIR}/${PN}:" src/main.c \
- || die 'sed failed'
+ -e "s:GENTOODIR:${GAMES_DATADIR}/${PN}:" src/main.c || die
}
src_install() {